summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-02-25 21:14:38 +0100
committerFabian Groffen <grobian@gentoo.org>2016-02-25 21:15:25 +0100
commitcc4413124c89fd482910478c3161d77eab38d104 (patch)
tree1392c803512e11c718d40ba1681583e9c969b977 /www-apps
parentprofiles: eselect-maven and webcdwriter have been removed (diff)
downloadgentoo-cc4413124c89fd482910478c3161d77eab38d104.tar.gz
gentoo-cc4413124c89fd482910478c3161d77eab38d104.tar.bz2
gentoo-cc4413124c89fd482910478c3161d77eab38d104.zip
www-apps/baikal: version bump by Perfect Gentleman in bug #575082
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/baikal/Manifest1
-rw-r--r--www-apps/baikal/baikal-0.3.5.ebuild57
-rw-r--r--www-apps/baikal/files/postinstall-en.txt1
3 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/baikal/Manifest b/www-apps/baikal/Manifest
index a02314e8d2a3..745a43742b03 100644
--- a/www-apps/baikal/Manifest
+++ b/www-apps/baikal/Manifest
@@ -1,2 +1,3 @@
+DIST baikal-0.3.5.zip 3282401 SHA256 a3da3ed6d668b5ea9c2c83a231b5cfe827d25d4f45991554e27c3b277446d728 SHA512 b0e1c9387c92a355c25c39165f608a956778199b23922b10cc9721ac0c5b5c3465e743ab6d890c2400eddaf7249bb2749c2065539892567430f4bef0625d760d WHIRLPOOL f1a9e1cd9512b6e6aa89449a341c8da09b36f24b67462e44fe2a9ec5b7843a9b8aaf6cf89b645c668e8e14fa2432c84737e6eb40f136ca11929d7617e2d2cf3a
DIST baikal-regular-0.2.4.tgz 868606 SHA256 5a8a57323d3662e167c8b45b5d10748139be94f54d4cc440aca8aff0159f9678 SHA512 84ac92a9fc0da108a7a56972a6ec4f08bdd5223c4052589db2cbe030093eeb250e5df769a02cd86b74e92c6c56601e1df1f1d422e3a9bc1fc958931f93a0d6ba WHIRLPOOL 010f4da3c1bb3cf08c1567f80843c44877f2a46a2d0a86258cb903bfc9e7c08da7afeae69e93c524a178ebf2cb89ab35579485349e06e52619b34ca163e09b05
DIST baikal-regular-0.2.7.tgz 2273699 SHA256 268daeec96b9f1bbfee0c16398ae213abfe827c97ec487179985828b6267359f SHA512 261e34eda6e85e38f9478e04f68fdea09ea12203a11b47aaf1a446e33333a9d8d1d9663f4a36da1cfd2adf776ba3f4be459b2639cc1a23e64e8584e47632bb8f WHIRLPOOL bf3e750c9cb5e9e372794e24516e8acb6d43abe1e76d30e3033994e617082f62bef87f5b33363937818ccb1ac35cd37d59dc7caab42356206be37967d284b8f0
diff --git a/www-apps/baikal/baikal-0.3.5.ebuild b/www-apps/baikal/baikal-0.3.5.ebuild
new file mode 100644
index 000000000000..a52cacbf4b78
--- /dev/null
+++ b/www-apps/baikal/baikal-0.3.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://sabre.io/baikal/"
+SRC_URI="https://github.com/fruux/Baikal/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+RDEPEND=">=dev-lang/php-5.5[ctype,filter,pdo,session,xml,xmlreader,mysql?,sqlite?]
+ mysql? ( virtual/mysql )
+ sqlite? ( dev-db/sqlite )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc *.md || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r html/* html/.htaccess Core vendor || die "doins failed"
+
+ einfo "Setting up container for configuration"
+ insinto /etc/${PN}
+
+ einfo "Fixing symlinks"
+ local link target
+ find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+ target=$(readlink "${link}")
+ target=${target/..\/Core/Core}
+ rm "${link}" && ln -s "${target}" "${link}"
+ done
+ dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+ dosym . "${MY_HTDOCSDIR}"/html
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ if has_version www-servers/apache ; then
+ fowners -R apache:apache /etc/${PN}
+ elif has_version www-servers/nginx ; then
+ fowners -R nginx:nginx /etc/${PN}
+ else
+ einfo "/etc/${PN} must be owned by the webserver user for baikal"
+ fi
+}
diff --git a/www-apps/baikal/files/postinstall-en.txt b/www-apps/baikal/files/postinstall-en.txt
index aafca857472d..4f1ed823e03b 100644
--- a/www-apps/baikal/files/postinstall-en.txt
+++ b/www-apps/baikal/files/postinstall-en.txt
@@ -2,3 +2,4 @@ In order to setup baïkal:
- create /etc/${PN}/ENABLE_INSTALL owner apache:apache
- point your browser at the instal's URL and follow the setup
To upgrade baïkal, you have to follow the setup instructions
+If you're upgrading from 0.2.7, see http://sabre.io/baikal/upgrade/