summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2023-01-30 13:31:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2023-01-30 13:32:40 +0000
commitcfdd47749fcfed9d3fd5b20ebc9f00c975303cee (patch)
tree9937e5d705a52c648bf8957c4db02c938826323d /www-apps
parentmedia-sound/fluidsynth: Stabilize 2.3.1 amd64, #892581 (diff)
downloadgentoo-cfdd47749fcfed9d3fd5b20ebc9f00c975303cee.tar.gz
gentoo-cfdd47749fcfed9d3fd5b20ebc9f00c975303cee.tar.bz2
gentoo-cfdd47749fcfed9d3fd5b20ebc9f00c975303cee.zip
www-apps/moodle: drop 3.9.17
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/moodle/Manifest1
-rw-r--r--www-apps/moodle/moodle-3.9.17.ebuild120
2 files changed, 0 insertions, 121 deletions
diff --git a/www-apps/moodle/Manifest b/www-apps/moodle/Manifest
index 1abc7bf5aacf..401051f514bb 100644
--- a/www-apps/moodle/Manifest
+++ b/www-apps/moodle/Manifest
@@ -1,3 +1,2 @@
DIST moodle-3.11.10.tgz 60320974 BLAKE2B 32de17a625742bc33e75d662c550682a45099b7af1e86411eecc0d8a745dbfeef2361eca3cea2d048e21dd75af40e9143534ab09db24162089f2ad404b4b54a4 SHA512 10c1e450dee96a1261b25882238381930297aa4e4f9a993e3932908ed2356d65facb5e06500dbd98c83a4022514c0ad1ad6305911241412985758fa29b5dd7a8
-DIST moodle-3.9.17.tgz 56753985 BLAKE2B 695ba04f2d2158c3528e0ffdbe09b6c7237a8a79d65a4bf673d6d677d18c8731a1034c403e1f2315922d3b4090645dcfc6df4b857a1e8352d89037e9497df4c2 SHA512 42f23bc97e7e78668a046b11a72b346d1188d92340ade0cb55ea6a391d8174f443d2b89d646c67a778b9dff33dcac8cf5b2b0a3dead84bc6cdecdaa3bdc83143
DIST moodle-4.0.4.tgz 61899291 BLAKE2B 82c18a8c89e7eb09a942f236640f49c414310c138d7cf2a9951c9759bea67f943f53257cefd5d693ec58a6af1e8eb6ae57a864d7772ea35a7592111d7be67cb0 SHA512 4284c05946dd07e43dbc7c584d7b3a69f62cfebf3cf6b2d049c6dea72ce184aaa0b4e6efb49817c8967ac8ff9dbce0ab2cf5fb2e96033d4368ed617ee258ffd8
diff --git a/www-apps/moodle/moodle-3.9.17.ebuild b/www-apps/moodle/moodle-3.9.17.ebuild
deleted file mode 100644
index 6663660f3cdc..000000000000
--- a/www-apps/moodle/moodle-3.9.17.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit webapp
-
-MY_BRANCH="stable$(ver_cut 1)$(ver_cut 2)"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="https://moodle.org"
-SRC_URI="https://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-3+"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,mssql?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS="ctype,curl,iconv,json(+),session,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-
-# No forced dependency on
-# mssql? - lives on a windows server
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-9* )
-# which may live on another server. These USE flags affect the configuration
-# file and the dependency on php. However other dbs are possible. See config.php
-# and the moodle documentation for other possibilities.
-DEPEND=""
-RDEPEND="
- dev-lang/php:7.4[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- if [[ ${DB_COUNT} -eq 0 ]]; then
- eerror
- eerror "No database selected in your USE flags,"
- eerror "You must select at least one."
- eerror
- die
- fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config-r1.php config.php
-
- # Moodle expect pgsql, not postgres
- MYDB=${MYDB/postgres/pgsql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-
- eapply_user
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT}
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo
-}