summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-02 15:02:48 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-02 15:03:08 -0500
commitd605ed17f4ec7261dca8521a1b6901e08c3a6c29 (patch)
tree577e4f31569a5346a98bd2cc6f5ebd4b3c087c7d /www-apps
parentx11-wm/xmonad: Remove NoDisplay (diff)
downloadgentoo-d605ed17f4ec7261dca8521a1b6901e08c3a6c29.tar.gz
gentoo-d605ed17f4ec7261dca8521a1b6901e08c3a6c29.tar.bz2
gentoo-d605ed17f4ec7261dca8521a1b6901e08c3a6c29.zip
www-apps/icingaweb2: 2.6.1 bup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.6.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 570d781e498e..3e19855ba7ec 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1,3 @@
DIST icingaweb2-2.5.3.tar.gz 8124667 BLAKE2B 43f9e47d670aaeffb15a8dbca6794d72436b195d4a19491d31f548a57ef9d2d0c411f16276be5355700e8dc863b8ef84821c68759d65ef2e97688a88d92605ca SHA512 d11d4f90f0cb54ab6fc5412151d412fc7827c895e81f6c91806090c364b3df4f2999bbc5f65cd4007406a3e7a7c9e0d48fb8f8362f3d7780681ac8702cfcb572
DIST icingaweb2-2.6.0.tar.gz 8165659 BLAKE2B 9e66a583cdec58b8eb2be7c86363d0154786eb7289ffbbc2b8c2978907537f56ef345313b9b916b3029793812431842ce88c525b29ed226f43bdeefc4af59c97 SHA512 a4788a40e87fa5a388acd6d87890cd5066c1622ba13ddb161beacf16d0765fd224c551c37ed83ef0a6059dd277a63c5c62427a411ccaae9b9deb7c7c88db8cb9
+DIST icingaweb2-2.6.1.tar.gz 8165384 BLAKE2B ea9b499f7da9fbdbe8340443f02b5a9fc348549bbffc7777ad63ac1e04c12ff45e5337418f1714b1d76af3818e9733bb0eb51a6bfbc39a7d1eb4820af8747392 SHA512 f2ac728abde9795e578b7d512f5b87e3307faed35a5413aaa2d3a958b57389c5297a124b530667aa248ee368aafaf3875097fa8e27b4c3090bb64badc7c329b7
diff --git a/www-apps/icingaweb2/icingaweb2-2.6.1.ebuild b/www-apps/icingaweb2/icingaweb2-2.6.1.ebuild
new file mode 100644
index 000000000000..d4db7e02c018
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.6.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx pdf postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.2[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.2[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}