summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2016-04-16 08:04:51 -0400
committerRichard Freeman <rich0@gentoo.org>2016-04-16 08:05:17 -0400
commite9d0a2e6022ce310ba727ee4391a8bcaaa21dea6 (patch)
treeabc988c71bf6715b675374113c5112f5bb29e4dd /www-apps
parentmedia-plugins/mythplugins: Major update to 0.28 (diff)
downloadgentoo-e9d0a2e6022ce310ba727ee4391a8bcaaa21dea6.tar.gz
gentoo-e9d0a2e6022ce310ba727ee4391a8bcaaa21dea6.tar.bz2
gentoo-e9d0a2e6022ce310ba727ee4391a8bcaaa21dea6.zip
www-apps/mythweb: Major update to 0.28
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/Manifest1
-rw-r--r--www-apps/mythweb/mythweb-0.28.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/www-apps/mythweb/Manifest b/www-apps/mythweb/Manifest
index fb066c9c4d81..4d9330271055 100644
--- a/www-apps/mythweb/Manifest
+++ b/www-apps/mythweb/Manifest
@@ -1 +1,2 @@
DIST mythweb-0.27.5.tar.gz 1686597 SHA256 5dc3fd9e60f59dea4264fb064b40d73f2534c99d0399da6223a42d2f563e9d13 SHA512 effa5f9cab6b40423a819f0307aecd1faa397da7d859503162b6229e5da2d4cd0d95d793326768335518cd397fa58ba71ad98c14247feda10e7930f7e023f1af WHIRLPOOL 8721398611db0572f475f5642c397a5d3f0fbe352f0f3ea23dc21cc0ea94e0e6876a713cf0f99331c6fc1f585a62525dc64510737a85667c0e2a14b6f1c6bb10
+DIST mythweb-0.28.tar.gz 1705475 SHA256 92253f4eb11331da64cff50926fbced3477d244c201675c177be4f5838cd4ed7 SHA512 58887f6d3823f137b252cf546ada134ebafa3e0142240ba9474868300add7ab00ee39f8cd0d56e91be0571837bea7110e8b3cca38a8a1a47b055d76dccf2a3fe WHIRLPOOL f130933ea6a5c20fa67668eb830cb094be9449ce4f21ff45041055cd91fda11be3752482ce04d066e90cfba9af97c741d4c67368900e4887bd7e726a22fe4540
diff --git a/www-apps/mythweb/mythweb-0.28.ebuild b/www-apps/mythweb/mythweb-0.28.ebuild
new file mode 100644
index 000000000000..367ff5b1e06c
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.28.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils webapp
+
+#BACKPORTS="4f6ac2a60b"
+# Release version
+MY_PV="${PV%_p*}"
+MY_P="mythweb-${MY_PV}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
+HOMEPAGE="http://www.mythtv.org"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz
+ ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-lang/php:*[json,mysql,session,posix]
+ virtual/httpd-php:*
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP"
+
+DEPEND="${RDEPEND}"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cd "${S}"/../
+
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
+ epatch
+
+ eapply_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Install docs
+ cd "${S}"
+ dodoc README INSTALL
+
+ # Install htdocs files
+ insinto "${MY_HTDOCSDIR}"
+ doins mythweb.php
+ doins -r classes
+ doins -r configuration
+ doins -r data
+ doins -r includes
+ doins -r js
+ doins -r modules
+ doins -r skins
+ doins -r tests
+ exeinto "${MY_HTDOCSDIR}"
+ doexe mythweb.pl
+
+ # Install our server config files
+ webapp_server_configfile apache mythweb.conf.apache mythweb.conf
+ webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
+ webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
+ mythweb.include
+
+ # Data needs to be writable and modifiable by the web server
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ # Message to display after install
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
+
+ # Script to set the correct defaults on install
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}