summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-30 08:07:27 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-30 08:07:57 +0200
commitf7afecbd75e3e89f539128e2ad5431ba3da1a949 (patch)
treec6df78b68f2e3a49ff079862f321021cb26f2a19 /www-apps
parentwww-apps/nanoc-core: add 4.11.7 (diff)
downloadgentoo-f7afecbd75e3e89f539128e2ad5431ba3da1a949.tar.gz
gentoo-f7afecbd75e3e89f539128e2ad5431ba3da1a949.tar.bz2
gentoo-f7afecbd75e3e89f539128e2ad5431ba3da1a949.zip
www-apps/nanoc: add 4.11.7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nanoc/Manifest1
-rw-r--r--www-apps/nanoc/nanoc-4.11.7.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index 9c78b06d5c1c..f9dd37236e54 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -3,3 +3,4 @@ DIST nanoc-4.11.0.tar.gz 291654 BLAKE2B ab88bf36b472106f356ae67782dac61f691e0d64
DIST nanoc-4.11.2.tar.gz 302927 BLAKE2B 206142cc13468c3456dfd141bb031791c3d6aa31b81cca04493519e8b44d7bc82d6837d266a0edecc58c0e635cee7428bfdf0d5428de7d5e6fb6eacebb09d45e SHA512 842703e5218c06e817ce188458ee0e9267467b92219dd566fda9d58cd21ec9842bbc011b8f2faa7854caf39af1379c2eae16a3e3b73c53f2c8af6b8851c7c8b9
DIST nanoc-4.11.5.tar.gz 305078 BLAKE2B d86fc1991f7aa1d0459c0a8b30053a97065f23a7c088fe739db6362ad2692622fe08c715b05b156d44e5bcdc1283e2bce2deeb562e61dc0933e3444f421d9113 SHA512 65285a0ddd822d15b788e824fc114c4c5f89d94221b6c7379eb8037519afd85d5131c571e0fbae4a447723448f61cdd4cdb8543de98f3bfdb1ac669a59ad64b8
DIST nanoc-4.11.6.tar.gz 306875 BLAKE2B dbb949572d22c6acb3ba7acf94712966a4105024f51f3e3df74f4ef010577d75be7859ad3eb2e877837c0fa38fbb384f00bd756466a23804d4b0e3167c22a12b SHA512 3735c374c302258ebc22f52e0044727de1fb283ed4c4f0075aad351b4645935d58aa04638f90c3e29e0c5270db148f83768aef41881c6fb5b53fe9efcf2b29a2
+DIST nanoc-4.11.7.tar.gz 307042 BLAKE2B b1144c80ea80ccf5bf713f93469061fbfb8a74890c3b9563ee8d88cd85375810fa6161a53d9221d817985b870426cafb52257403d05245b735855aecd76356a3 SHA512 d82d89dcd9f056e711cb722b6fbe22045eecf9fd61e3541529b89c8eb916ca850ef498148f1065b792e1a1d786e6d2f1477b41713753ff9d7b283ecc3cf2649c
diff --git a/www-apps/nanoc/nanoc-4.11.7.ebuild b/www-apps/nanoc/nanoc-4.11.7.ebuild
new file mode 100644
index 000000000000..de28a28b1206
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.11.7.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="nanoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.ws/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/colored-1.2:0
+ >=dev-ruby/cri-2.15:0
+ ~www-apps/nanoc-core-${PV}
+ >=dev-ruby/parallel-1.12:1
+ >=dev-ruby/tomlrb-1.2:1
+ >=dev-ruby/tty-command-0.8:0
+ >=dev-ruby/tty-file-0.7:0
+ >=dev-ruby/tty-platform-0.2:0
+ >=dev-ruby/tty-which-0.4:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/haml
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/mustache
+ dev-ruby/pry
+ dev-ruby/rdoc
+ >=dev-ruby/rouge-3.5.1:2
+ dev-ruby/rubypants
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' test/helper.rb || die
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid basepath issues when generating gemspec
+ sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests requiring a network connection or make assumptions
+ # about the local network environment.
+ rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests for unpackaged dependencies
+ rm spec/nanoc/deploying/fog_spec.rb \
+ spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{markaby,rainpress}.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -i -e '145askip "gentoo"' spec/nanoc/cli/error_handler_spec.rb || die
+ sed -i -e '/watches with --watch/askip "gentoo"' spec/nanoc/cli/commands/compile_spec.rb || die
+ sed -i -e '124askip "ordering issues"' -e '168askip "ordering issues"' spec/nanoc/data_sources/filesystem_spec.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}