summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <stha09@googlemail.com>2020-03-20 17:06:03 +0100
committerMike Gilbert <floppym@gentoo.org>2020-03-24 09:48:03 -0400
commit74bedae1b414b74fe8db58cf4848a3683b41fa09 (patch)
tree4c310b772ea2da863acbded3f2a37f7ce6306cc9 /www-client/chromium
parentnet-mail/serialmail: fix bad sed delimiter (diff)
downloadgentoo-74bedae1b414b74fe8db58cf4848a3683b41fa09.tar.gz
gentoo-74bedae1b414b74fe8db58cf4848a3683b41fa09.tar.bz2
gentoo-74bedae1b414b74fe8db58cf4848a3683b41fa09.zip
www-client/chromium: dev channel bump to 82.0.4085.12
Drop dependency on deprecated libgnome-keyring. Closes: https://bugs.gentoo.org/713012 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Stephan Hartmann <stha09@googlemail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15085
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/Manifest2
-rw-r--r--www-client/chromium/chromium-82.0.4085.12.ebuild (renamed from www-client/chromium/chromium-82.0.4083.0.ebuild)7
-rw-r--r--www-client/chromium/files/chromium-82-gcc-noexcept.patch22
-rw-r--r--www-client/chromium/files/chromium-compiler-r12.patch42
4 files changed, 45 insertions, 28 deletions
diff --git a/www-client/chromium/Manifest b/www-client/chromium/Manifest
index 6d1cb4e7052c..c3748fe76b80 100644
--- a/www-client/chromium/Manifest
+++ b/www-client/chromium/Manifest
@@ -1,3 +1,3 @@
DIST chromium-80.0.3987.149.tar.xz 797049332 BLAKE2B 679efd45a48fb064e2fda9b751b112ef26f9c3419ab46d28e1490729a80b18908078bd260060656199700c391f0664e7a4d1e919ee8eb71d9c8c12b6535269f2 SHA512 5abbf8ff754937a3af566474457b5cd9bbcac0e8b1a52fd95180fcf69b12515278423887668512b3136de72ebe15048c4bd79572511f68189d1e86ace4ca30cb
DIST chromium-81.0.4044.69.tar.xz 785953544 BLAKE2B 1e9f0e0560c08ffa77568f16cf57a0de82c737e7517b27da1b925cfaa9a5797a189e2280891acba46373d3fc4e1798fae9d3367508fe5f1315b945a1aa3e5bac SHA512 77f8d922d9c84f72d562b37fe787ad1e92e64dc0b3755402c5024f94559f4731888dccdaa0fbe52a7b3f68692918dfa43a369b54f7b0ea71ead319261e89b5c4
-DIST chromium-82.0.4083.0.tar.xz 794521032 BLAKE2B 5437aaed6c81bab1bd6495db0665fe6c3fbd1058535272d19a6d6c9d34db0102ff3464e1f210461c0944dd84257bc036004aed412f91590a6ff951c1e3fb7925 SHA512 412757cd004ceb7946bd4b8f30afd9589f6b33595a9f231c4a43a7a6328547fec8bdf42d751ec4babc244c16d7b9bbd2448adeb155e4ac354d714180a69c0709
+DIST chromium-82.0.4085.12.tar.xz 795107540 BLAKE2B 419f6e927b340679cec069c7f274d86c2d66f26f32e3d9c95501b9433888dd16dbae4104afde1f3d285730a263a5837a7ef4e9a5e30fb4876dae56db5a1d955d SHA512 d371b6a941af877d2444591f3af9f6458e6beaee99af686a92c282b6ebcd3c560113941dedf215106af57eea201890fa95dee776d5a188ee2ac5686629336410
diff --git a/www-client/chromium/chromium-82.0.4083.0.ebuild b/www-client/chromium/chromium-82.0.4085.12.ebuild
index e93d8f46ddbd..26b64de9437e 100644
--- a/www-client/chromium/chromium-82.0.4083.0.ebuild
+++ b/www-client/chromium/chromium-82.0.4085.12.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="+closure-compile component-build cups cpu_flags_arm_neon gnome-keyring +hangouts kerberos pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
+IUSE="+closure-compile component-build cups cpu_flags_arm_neon +hangouts kerberos pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
REQUIRED_USE="component-build? ( !suid )"
@@ -34,7 +34,6 @@ COMMON_DEPEND="
dev-libs/nspr:=
>=dev-libs/nss-3.26:=
>=dev-libs/re2-0.2019.08.01:=
- gnome-keyring? ( >=gnome-base/libgnome-keyring-3.12:= )
>=media-libs/alsa-lib-1.0.19:=
media-libs/fontconfig:=
media-libs/freetype:=
@@ -498,12 +497,14 @@ src_configure() {
# See dependency logic in third_party/BUILD.gn
myconf_gn+=" use_system_harfbuzz=true"
+ # Disable deprecated libgnome-keyring dependency, bug #713012
+ myconf_gn+=" use_gnome_keyring=false"
+
# Optional dependencies.
myconf_gn+=" closure_compile=$(usex closure-compile true false)"
myconf_gn+=" enable_hangout_services_extension=$(usex hangouts true false)"
myconf_gn+=" enable_widevine=$(usex widevine true false)"
myconf_gn+=" use_cups=$(usex cups true false)"
- myconf_gn+=" use_gnome_keyring=$(usex gnome-keyring true false)"
myconf_gn+=" use_kerberos=$(usex kerberos true false)"
myconf_gn+=" use_pulseaudio=$(usex pulseaudio true false)"
diff --git a/www-client/chromium/files/chromium-82-gcc-noexcept.patch b/www-client/chromium/files/chromium-82-gcc-noexcept.patch
index db66934d883e..1c7de53d8eff 100644
--- a/www-client/chromium/files/chromium-82-gcc-noexcept.patch
+++ b/www-client/chromium/files/chromium-82-gcc-noexcept.patch
@@ -11,3 +11,25 @@ index 56564d7..2798a3c 100644
ColorSet::~ColorSet() = default;
+diff --git a/third_party/blink/public/platform/cross_variant_mojo_util.h b/third_party/blink/public/platform/cross_variant_mojo_util.h
+index dee0b95..0c83580 100644
+--- a/third_party/blink/public/platform/cross_variant_mojo_util.h
++++ b/third_party/blink/public/platform/cross_variant_mojo_util.h
+@@ -124,7 +124,7 @@ class CrossVariantMojoAssociatedReceiver {
+ ~CrossVariantMojoAssociatedReceiver() = default;
+
+ CrossVariantMojoAssociatedReceiver(
+- CrossVariantMojoAssociatedReceiver&&) noexcept = default;
++ CrossVariantMojoAssociatedReceiver&&) = default;
+ CrossVariantMojoAssociatedReceiver& operator=(
+ CrossVariantMojoAssociatedReceiver&&) noexcept = default;
+
+@@ -155,7 +155,7 @@ class CrossVariantMojoAssociatedRemote {
+ ~CrossVariantMojoAssociatedRemote() = default;
+
+ CrossVariantMojoAssociatedRemote(
+- CrossVariantMojoAssociatedRemote&&) noexcept = default;
++ CrossVariantMojoAssociatedRemote&&) = default;
+ CrossVariantMojoAssociatedRemote& operator=(
+ CrossVariantMojoAssociatedRemote&&) noexcept = default;
+
diff --git a/www-client/chromium/files/chromium-compiler-r12.patch b/www-client/chromium/files/chromium-compiler-r12.patch
index 840059b4f57d..a17cc4b52c8d 100644
--- a/www-client/chromium/files/chromium-compiler-r12.patch
+++ b/www-client/chromium/files/chromium-compiler-r12.patch
@@ -1,14 +1,14 @@
-From c2a95e376474298b01cb04f1d5b2c6e3c76ba268 Mon Sep 17 00:00:00 2001
+From 907b74447f4a35d5a8e851c73c15cc951a2e446b Mon Sep 17 00:00:00 2001
From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 13 Mar 2020 20:20:06 +0000
+Date: Fri, 20 Mar 2020 09:14:25 +0000
Subject: [PATCH] Disable various compiler configs
---
- build/config/compiler/BUILD.gn | 67 ++++++++++++----------------------
- 1 file changed, 23 insertions(+), 44 deletions(-)
+ build/config/compiler/BUILD.gn | 61 +++++++++++++---------------------
+ 1 file changed, 23 insertions(+), 38 deletions(-)
diff --git a/build/config/compiler/BUILD.gn b/build/config/compiler/BUILD.gn
-index 8f7fcc3..d27e71e 100644
+index 9573394..d35e736 100644
--- a/build/config/compiler/BUILD.gn
+++ b/build/config/compiler/BUILD.gn
@@ -261,8 +261,6 @@ config("compiler") {
@@ -20,7 +20,7 @@ index 8f7fcc3..d27e71e 100644
":compiler_codegen",
":compiler_deterministic",
]
-@@ -487,26 +485,6 @@ config("compiler") {
+@@ -487,20 +485,6 @@ config("compiler") {
}
}
@@ -36,18 +36,12 @@ index 8f7fcc3..d27e71e 100644
- "-Xclang",
- "-instcombine-lower-dbg-declare=0",
- ]
--
-- if (!is_chromeos && default_toolchain != "//build/toolchain/cros:target") {
-- # TODO(https://crbug.com/1049161): Remove '-DCLANG_SPAWN_CC1=ON' from build.py instead
-- # once this change has marinated a bit.
-- cflags += [ "-fintegrated-cc1" ]
-- }
- }
-
# C11/C++11 compiler flags setup.
# ---------------------------
if (is_linux || is_android || (is_nacl && is_clang) || current_os == "aix") {
-@@ -1437,6 +1415,12 @@ config("default_warnings") {
+@@ -1431,6 +1415,12 @@ config("default_warnings") {
cflags_cc += [ "-Wno-class-memaccess" ]
}
@@ -60,7 +54,7 @@ index 8f7fcc3..d27e71e 100644
# -Wunused-local-typedefs is broken in gcc,
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63872
cflags += [ "-Wno-unused-local-typedefs" ]
-@@ -1558,7 +1542,7 @@ config("chromium_code") {
+@@ -1559,7 +1549,7 @@ config("chromium_code") {
defines = [ "_HAS_NODISCARD" ]
}
} else {
@@ -69,7 +63,7 @@ index 8f7fcc3..d27e71e 100644
if (treat_warnings_as_errors) {
cflags += [ "-Werror" ]
-@@ -1567,10 +1551,6 @@ config("chromium_code") {
+@@ -1568,10 +1558,6 @@ config("chromium_code") {
# well.
ldflags = [ "-Werror" ]
}
@@ -80,7 +74,7 @@ index 8f7fcc3..d27e71e 100644
# In Chromium code, we define __STDC_foo_MACROS in order to get the
# C99 macros on Mac and Linux.
-@@ -1579,15 +1559,6 @@ config("chromium_code") {
+@@ -1580,15 +1566,6 @@ config("chromium_code") {
"__STDC_FORMAT_MACROS",
]
@@ -96,7 +90,7 @@ index 8f7fcc3..d27e71e 100644
if (is_mac) {
cflags_objc = [ "-Wobjc-missing-property-synthesis" ]
cflags_objcc = [ "-Wobjc-missing-property-synthesis" ]
-@@ -1979,7 +1950,8 @@ config("default_stack_frames") {
+@@ -1980,7 +1957,8 @@ config("default_stack_frames") {
}
# Default "optimization on" config.
@@ -106,7 +100,7 @@ index 8f7fcc3..d27e71e 100644
if (is_win) {
# Favor size over speed, /O1 must be before the common flags.
# /O1 implies /Os and /GF.
-@@ -2000,7 +1972,8 @@ config("optimize") {
+@@ -2001,7 +1979,8 @@ config("optimize") {
}
# Turn off optimizations.
@@ -116,7 +110,7 @@ index 8f7fcc3..d27e71e 100644
if (is_win) {
cflags = [
"/Od", # Disable optimization.
-@@ -2034,7 +2007,8 @@ config("no_optimize") {
+@@ -2035,7 +2014,8 @@ config("no_optimize") {
# Turns up the optimization level. On Windows, this implies whole program
# optimization and link-time code generation which is very expensive and should
# be used sparingly.
@@ -126,7 +120,7 @@ index 8f7fcc3..d27e71e 100644
if (is_nacl && is_nacl_irt) {
# The NaCl IRT is a special case and always wants its own config.
# Various components do:
-@@ -2066,7 +2040,8 @@ config("optimize_max") {
+@@ -2067,7 +2047,8 @@ config("optimize_max") {
#
# TODO(crbug.com/621335) - rework how all of these configs are related
# so that we don't need this disclaimer.
@@ -136,7 +130,7 @@ index 8f7fcc3..d27e71e 100644
if (is_nacl && is_nacl_irt) {
# The NaCl IRT is a special case and always wants its own config.
# Various components do:
-@@ -2091,7 +2066,8 @@ config("optimize_speed") {
+@@ -2092,7 +2073,8 @@ config("optimize_speed") {
}
}
@@ -146,7 +140,7 @@ index 8f7fcc3..d27e71e 100644
cflags = [ "-O1" ] + common_optimize_on_cflags
ldflags = common_optimize_on_ldflags
visibility = [ ":default_optimization" ]
-@@ -2207,7 +2183,8 @@ config("win_pdbaltpath") {
+@@ -2208,7 +2190,8 @@ config("win_pdbaltpath") {
}
# Full symbols.
@@ -156,7 +150,7 @@ index 8f7fcc3..d27e71e 100644
if (is_win) {
if (is_clang) {
cflags = [ "/Z7" ] # Debug information in the .obj files.
-@@ -2313,7 +2290,8 @@ config("symbols") {
+@@ -2314,7 +2297,8 @@ config("symbols") {
# Minimal symbols.
# This config guarantees to hold symbol for stack trace which are shown to user
# when crash happens in unittests running on buildbot.
@@ -166,7 +160,7 @@ index 8f7fcc3..d27e71e 100644
if (is_win) {
# Functions, files, and line tables only.
cflags = []
-@@ -2370,7 +2348,8 @@ config("minimal_symbols") {
+@@ -2371,7 +2355,8 @@ config("minimal_symbols") {
# This configuration contains function names only. That is, the compiler is
# told to not generate debug information and the linker then just puts function
# names in the final debug information.