summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-09 12:45:04 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-09 12:45:16 +0100
commit53ed3f4ea63a057ec33b9ad5221b435850f3ff7a (patch)
tree7b3003d955ab9bcafe6ac2a28ee625984e94f922 /www-client/dillo
parentwww-client/dillo: Fix compiling against >dev-libs/openssl-1.1 (diff)
downloadgentoo-53ed3f4ea63a057ec33b9ad5221b435850f3ff7a.tar.gz
gentoo-53ed3f4ea63a057ec33b9ad5221b435850f3ff7a.tar.bz2
gentoo-53ed3f4ea63a057ec33b9ad5221b435850f3ff7a.zip
www-client/dillo: Old
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/dillo-3.0.5-r1.ebuild68
-rw-r--r--www-client/dillo/dillo-3.0.5-r2.ebuild64
2 files changed, 0 insertions, 132 deletions
diff --git a/www-client/dillo/dillo-3.0.5-r1.ebuild b/www-client/dillo/dillo-3.0.5-r1.ebuild
deleted file mode 100644
index 655d5ad63cd5..000000000000
--- a/www-client/dillo/dillo-3.0.5-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Lean FLTK based web browser"
-HOMEPAGE="https://www.dillo.org/"
-SRC_URI="https://www.dillo.org/download/${P}.tar.bz2
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc +gif ipv6 +jpeg libressl +png ssl"
-
-RDEPEND="
- >=x11-libs/fltk-1.3
- sys-libs/zlib
- jpeg? ( virtual/jpeg:0 )
- png? ( >=media-libs/libpng-1.2:0 )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- )
-"
-DEPEND="
- ${RDEPEND}
- doc? ( app-doc/doxygen )
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}2-inbuf.patch
-}
-
-src_configure() {
- econf \
- $(use_enable gif) \
- $(use_enable ipv6) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable ssl) \
- --docdir="/usr/share/doc/${PF}"
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- dodir /etc
- default
-
- use doc && dohtml html/*
- dodoc AUTHORS ChangeLog README NEWS
- dodoc doc/*.txt doc/README
-
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} Dillo
-}
-
-pkg_postinst() {
- elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
- elog "You can copy this to ~/.dillo/ and customize it"
-}
diff --git a/www-client/dillo/dillo-3.0.5-r2.ebuild b/www-client/dillo/dillo-3.0.5-r2.ebuild
deleted file mode 100644
index 14d9e245482d..000000000000
--- a/www-client/dillo/dillo-3.0.5-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit desktop multilib toolchain-funcs
-
-DESCRIPTION="Lean FLTK based web browser"
-HOMEPAGE="https://www.dillo.org/"
-SRC_URI="
- https://www.dillo.org/download/${P}.tar.bz2
- mirror://gentoo/${PN}.png
-"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc +gif ipv6 +jpeg libressl +png ssl"
-
-RDEPEND="
- >=x11-libs/fltk-1.3
- sys-libs/zlib
- jpeg? ( virtual/jpeg:0 )
- png? ( >=media-libs/libpng-1.2:0 )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
- )
-"
-BDEPEND="
- ${RDEPEND}
- doc? ( app-doc/doxygen )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}2-inbuf.patch
- "${FILESDIR}"/${PN}-3.0.5-fno-common.patch
-)
-DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
-
-src_configure() {
- econf \
- $(use_enable gif) \
- $(use_enable ipv6) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable ssl) \
- --docdir="/usr/share/doc/${PF}"
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- dodir /etc
- default
-
- use doc && dodoc -r html
-
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} Dillo
-}