summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-31 12:31:57 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-31 12:39:50 +0100
commitcebb9304294041396e5a8295266864a30bcdb78e (patch)
treeb059026b89ea8e010ebc0430b9f8119372e1aa0a /www-client/dillo
parentdev-util/debhelper: Version 12.9 (diff)
downloadgentoo-cebb9304294041396e5a8295266864a30bcdb78e.tar.gz
gentoo-cebb9304294041396e5a8295266864a30bcdb78e.tar.bz2
gentoo-cebb9304294041396e5a8295266864a30bcdb78e.zip
www-client/dillo: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707398 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/dillo-3.0.5-r2.ebuild64
-rw-r--r--www-client/dillo/dillo-9999.ebuild13
-rw-r--r--www-client/dillo/files/dillo-3.0.5-fno-common.patch100
3 files changed, 166 insertions, 11 deletions
diff --git a/www-client/dillo/dillo-3.0.5-r2.ebuild b/www-client/dillo/dillo-3.0.5-r2.ebuild
new file mode 100644
index 000000000000..14d9e245482d
--- /dev/null
+++ b/www-client/dillo/dillo-3.0.5-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop multilib toolchain-funcs
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://www.dillo.org/"
+SRC_URI="
+ https://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/${PN}.png
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +gif ipv6 +jpeg libressl +png ssl"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg:0 )
+ png? ( >=media-libs/libpng-1.2:0 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}2-inbuf.patch
+ "${FILESDIR}"/${PN}-3.0.5-fno-common.patch
+)
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_configure() {
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl) \
+ --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ dodir /etc
+ default
+
+ use doc && dodoc -r html
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Dillo
+}
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
index 2cf816aa62b4..7134cc059e28 100644
--- a/www-client/dillo/dillo-9999.ebuild
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
inherit autotools desktop mercurial toolchain-funcs
DESCRIPTION="Lean FLTK based web browser"
@@ -28,8 +27,8 @@ DEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}2-inbuf.patch
+ "${FILESDIR}"/${PN}-3.0.5-fno-common.patch
)
-
DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
src_prepare() {
@@ -57,16 +56,8 @@ src_compile() {
src_install() {
default
- if use doc; then
- docinto html
- dodoc -r html/
- fi
+ use doc && dodoc -r html
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry ${PN} Dillo
}
-
-pkg_postinst() {
- elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
- elog "You can copy this to ~/.dillo/ and customize it"
-}
diff --git a/www-client/dillo/files/dillo-3.0.5-fno-common.patch b/www-client/dillo/files/dillo-3.0.5-fno-common.patch
new file mode 100644
index 000000000000..df80f55afaf8
--- /dev/null
+++ b/www-client/dillo/files/dillo-3.0.5-fno-common.patch
@@ -0,0 +1,100 @@
+--- a/dpid/dpid.c
++++ b/dpid/dpid.c
+@@ -41,6 +41,26 @@
+ volatile sig_atomic_t caught_sigchld = 0;
+ char *SharedKey = NULL;
+
++char *srs_name;
++
++/*! dpid's service request socket file descriptor */
++int srs_fd;
++
++/*! Number of available plugins */
++int numdpis;
++
++/*! Number of sockets being watched */
++int numsocks;
++
++/*! State information for each plugin. */
++struct dp *dpi_attr_list;
++
++/*! service served for each plugin */
++Dlist *services_list;
++
++/*! Set of sockets watched for connections */
++fd_set sock_set;
++
+ /*! Remove dpid_comm_keys file.
+ * This avoids that dillo instances connect to a stale port after dpid
+ * has exited (e.g. after a reboot).
+--- a/dpid/dpid.h
++++ b/dpid/dpid.h
+@@ -25,10 +25,10 @@
+
+ /*! \TODO: Should read this from dillorc */
+ #define SRS_NAME "dpid.srs"
+-char *srs_name;
++extern char *srs_name;
+
+ /*! dpid's service request socket file descriptor */
+-int srs_fd;
++extern int srs_fd;
+
+ /*! plugin state information
+ */
+@@ -49,19 +49,19 @@
+ };
+
+ /*! Number of available plugins */
+-int numdpis;
++extern int numdpis;
+
+ /*! Number of sockets being watched */
+-int numsocks;
++extern int numsocks;
+
+ /*! State information for each plugin. */
+-struct dp *dpi_attr_list;
++extern struct dp *dpi_attr_list;
+
+ /*! service served for each plugin */
+-Dlist *services_list;
++extern Dlist *services_list;
+
+ /*! Set of sockets watched for connections */
+-fd_set sock_set;
++extern fd_set sock_set;
+
+ /*! Set to 1 by the SIGCHLD handler dpi_sigchld */
+ extern volatile sig_atomic_t caught_sigchld;
+--- a/dpid/dpid_common.c
++++ b/dpid/dpid_common.c
+@@ -14,6 +14,9 @@
+ #include <unistd.h>
+ #include "dpid_common.h"
+
++/*! Error codes for dpid */
++dpi_errno_t dpi_errno;
++
+ /*
+ * Send a verbose error message.
+ */
+--- a/dpid/dpid_common.h
++++ b/dpid/dpid_common.h
+@@ -35,12 +35,13 @@
+ #define CKD_WRITE(fd, msg) ckd_write(fd, msg, __FILE__, __LINE__)
+ #define CKD_CLOSE(fd) ckd_close(fd, __FILE__, __LINE__)
+
+-
+ /*! Error codes for dpid */
+-enum {
++typedef enum {
+ no_errors,
+ dpid_srs_addrinuse /* dpid service request socket address already in use */
+-} dpi_errno;
++} dpi_errno_t;
++
++extern dpi_errno_t dpi_errno;
+
+ /*! Intended for identifying dillo plugins
+ * and related files