summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2018-02-25 17:27:31 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-03 15:45:26 +0100
commitad9db2b262b939a552911b304eb95e53710c0bde (patch)
treead2913cae0a6d92f7431dbde0e08ee282fe2d8de /www-client/elinks/elinks-0.13_pre_pre20180225.ebuild
parentwww-client/elinks: update live ebuild (diff)
downloadgentoo-ad9db2b262b939a552911b304eb95e53710c0bde.tar.gz
gentoo-ad9db2b262b939a552911b304eb95e53710c0bde.tar.bz2
gentoo-ad9db2b262b939a552911b304eb95e53710c0bde.zip
www-client/elinks: add snapshotted version
Closes: https://github.com/gentoo/gentoo/pull/7281
Diffstat (limited to 'www-client/elinks/elinks-0.13_pre_pre20180225.ebuild')
-rw-r--r--www-client/elinks/elinks-0.13_pre_pre20180225.ebuild138
1 files changed, 138 insertions, 0 deletions
diff --git a/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild b/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild
new file mode 100644
index 000000000000..a0b8366f1210
--- /dev/null
+++ b/www-client/elinks/elinks-0.13_pre_pre20180225.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+inherit autotools python-any-r1
+
+EGIT_COMMIT="0dd3aaabe61fbc5ed0d9a74915678d11d00c2a1c"
+
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+SRC_URI="https://github.com/rkd77/felinks/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/felinks-${EGIT_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm guile idn ipv6
+ javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
+ idn? ( net-dns/libidn )
+ javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
+ lua? ( >=dev-lang/lua-5:0= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
+ samba? ( net-fs/samba )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ tre? ( dev-libs/tre )
+ X? ( x11-libs/libX11 x11-libs/libXt )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-parallel-make.patch
+ )
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-Werror//' configure* || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}"/etc/elinks
+ --enable-leds
+ --enable-88-colors
+ --enable-256-colors
+ --enable-true-color
+ --enable-html-highlight
+ $(use_with gpm)
+ $(use_with brotli)
+ $(use_with bzip2 bzlib)
+ $(use_with guile)
+ $(use_with idn)
+ $(use_with javascript spidermonkey)
+ $(use_with lua)
+ $(use_with perl)
+ $(use_with ruby)
+ $(use_with tre)
+ $(use_with X x)
+ $(use_with zlib)
+ $(use_enable bittorrent)
+ $(use_enable finger)
+ $(use_enable ftp)
+ $(use_enable gopher)
+ $(use_enable ipv6)
+ $(use_enable mouse)
+ $(use_enable nls)
+ $(use_enable nntp)
+ $(use_enable samba smb)
+ $(use_enable xml xbel)
+ )
+
+ if use debug ; then
+ myconf+=( --enable-debug )
+ else
+ myconf+=( --enable-fastmem )
+ fi
+
+ # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
+ # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
+ # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
+ if use ssl ; then
+ myconf+=( --with-openssl="${EPREFIX}"/usr )
+ else
+ myconf+=( --without-openssl --without-gnutls )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake V=1 DESTDIR="${D}" install
+
+ insinto /etc/elinks
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
+
+ # elinks uses an internal copy of gettext which ships files that may
+ # collide with the system's gettext (https://bugs.gentoo.org/635090)
+ rm -f "${ED}"/usr/{share/locale/locale,lib/charset}.alias || die
+}
+
+pkg_postinst() {
+ elog "You may want to convert your html.cfg and links.cfg of"
+ elog "Links or older ELinks versions to the new ELinks elinks.conf"
+ elog "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ elog
+ elog "Please have a look at /etc/elinks/keybind-full.sample and"
+ elog "/etc/elinks/keybind.conf.sample for some bindings examples."
+ elog
+ elog "You will have to set your TERM variable to 'xterm-256color'"
+ elog "to be able to use 256 colors in elinks."
+}