summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2017-10-14 20:53:29 -0400
committerPatrice Clement <monsieurp@gentoo.org>2017-10-22 18:55:19 +0200
commitf6c9ef19a22b679ef1b1a503b73631ca0d26e0ba (patch)
tree4e0162f678074df6713a6880a0c03c6e960be8ae /www-client/elinks
parentwww-client/elinks: add Felix Janda to list of maintainers. (diff)
downloadgentoo-f6c9ef19a22b679ef1b1a503b73631ca0d26e0ba.tar.gz
gentoo-f6c9ef19a22b679ef1b1a503b73631ca0d26e0ba.tar.bz2
gentoo-f6c9ef19a22b679ef1b1a503b73631ca0d26e0ba.zip
www-client/elinks: bump live ebuild to EAPI 6.
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/elinks-9999.ebuild47
-rw-r--r--www-client/elinks/files/elinks-0.10.4.conf-syscharset.diff4
2 files changed, 26 insertions, 25 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index ca4b6b2466cc..0cd779031302 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit autotools eutils git-r3 flag-o-matic python-any-r1
+inherit autotools git-r3 python-any-r1
EGIT_REPO_URI="git://repo.or.cz/elinks.git"
@@ -42,36 +42,39 @@ DEPEND="
javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-parallel-make.patch
+ )
+
src_unpack() {
default
git-r3_src_unpack
}
src_prepare() {
- mv "${WORKDIR}/${PN}-0.10.4.conf" "${WORKDIR}/${PN}.conf"
+ default
+
+ cd "${WORKDIR}" || die
+ eapply "${FILESDIR}"/${PN}-0.10.4.conf-syscharset.diff
+ mv ${PN}-0.10.4.conf ${PN}.conf || die
if ! use ftp ; then
- sed -i -e 's/\(.*protocol.ftp.*\)/# \1/' "${WORKDIR}"/${PN}.conf
+ sed -i -e 's/\(.*protocol.ftp.*\)/# \1/' ${PN}.conf || die
fi
- sed -i -e 's/\(.*set protocol.ftp.use_epsv.*\)/# \1/' "${WORKDIR}"/${PN}.conf
- epatch "${FILESDIR}"/${P}-parallel-make.patch
-
- epatch_user
+ sed -i -e 's/\(.*set protocol.ftp.use_epsv.*\)/# \1/' ${PN}.conf || die
+ cd "${S}" || die
# Regenerate acinclude.m4 - based on autogen.sh.
- cat > acinclude.m4 <<- _EOF
+ cat > acinclude.m4 <<- _EOF || die
dnl Automatically generated from config/m4/ files.
dnl Do not modify!
_EOF
- cat config/m4/*.m4 >> acinclude.m4
- sed -i -e 's/-Werror//' configure*
+ cat config/m4/*.m4 >> acinclude.m4 || die
+ sed -i -e 's/-Werror//' configure* || die
eautoreconf
}
src_configure() {
- # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
- # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
- # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
local myconf=""
if use debug ; then
@@ -80,6 +83,9 @@ src_configure() {
myconf="--enable-fastmem"
fi
+ # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
+ # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
+ # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
if use ssl ; then
myconf="${myconf} --with-openssl=${EPREFIX}/usr"
else
@@ -125,20 +131,16 @@ src_compile() {
src_install() {
emake V=1 DESTDIR="${D}" install
- insopts -m 644 ; insinto /etc/elinks
+ insinto /etc/elinks
doins "${WORKDIR}"/elinks.conf
newins contrib/keybind-full.conf keybind-full.sample
newins contrib/keybind.conf keybind.conf.sample
dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
- insinto /usr/share/doc/${PF}/contrib/lua ; doins contrib/lua/{*.lua,elinks-remote}
- insinto /usr/share/doc/${PF}/contrib/conv ; doins contrib/conv/*.*
- insinto /usr/share/doc/${PF}/contrib/guile ; doins contrib/guile/*.scm
-
- # Remove some conflicting files on OSX. The files provided by OSX 10.4
- # are more or less the same. -- Fabian Groffen (2005-06-30)
- rm -f "${ED}"/usr/share/locale/locale.alias "${ED}"/usr/lib/charset.alias || die
+ docinto contrib/lua ; dodoc contrib/lua/{*.lua,elinks-remote}
+ docinto contrib/conv ; dodoc contrib/conv/*.*
+ docinto contrib/guile ; dodoc contrib/guile/*.scm
}
pkg_postinst() {
@@ -154,5 +156,4 @@ pkg_postinst() {
einfo
einfo "You will have to set your TERM variable to 'xterm-256color'"
einfo "to be able to use 256 colors in elinks."
- echo
}
diff --git a/www-client/elinks/files/elinks-0.10.4.conf-syscharset.diff b/www-client/elinks/files/elinks-0.10.4.conf-syscharset.diff
index dc64712b29a8..83accf4c2d95 100644
--- a/www-client/elinks/files/elinks-0.10.4.conf-syscharset.diff
+++ b/www-client/elinks/files/elinks-0.10.4.conf-syscharset.diff
@@ -1,5 +1,5 @@
---- elinks-0.10.4.conf 2005-04-08 15:29:49.000000000 -0700
-+++ elinks-0.10.4-syscharset.conf 2006-11-04 00:26:26.000000000 -0800
+--- a/elinks-0.10.4.conf 2005-04-08 15:29:49.000000000 -0700
++++ b/elinks-0.10.4-syscharset.conf 2006-11-04 00:26:26.000000000 -0800
@@ -12,8 +12,6 @@
# obsolete config.saving_style. You shouldn't touch it.
set config.saving_style_w = 1