summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-22 18:48:21 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-22 18:49:16 +0200
commitc014e39082e4611503673be4741771aa37974679 (patch)
tree5af6dd93485ace77c7ac4bdcfc051815e30c9164 /www-client/epiphany
parentgames-arcade/gnome-robots: bump to 3.36.0 (diff)
downloadgentoo-c014e39082e4611503673be4741771aa37974679.tar.gz
gentoo-c014e39082e4611503673be4741771aa37974679.tar.bz2
gentoo-c014e39082e4611503673be4741771aa37974679.zip
www-client/epiphany: bump to 3.34.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.34.4.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 6d5e4709a6a5..4627f7cdc3a6 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.30.5.tar.xz 4532136 BLAKE2B 7c42e7ff5624bd85c380da97b2ca057b59d4dc77bec85f33bab755032b519db10ee52aa93c503e5b1f57c5acfce5a9b3decc7dddfacc3d68ea620eb884ec2da3 SHA512 1d31022e91a5ac79a032ebf988d4f8828cfa38a2b67e06b9432e479d7ebc93d3a08338261b92dfe3f37b6f745aeb5286b4acc65c537d935c1ace61ad9a494b7d
DIST epiphany-3.32.6.tar.xz 5469624 BLAKE2B 96e35001482c4062917d160d4b3e851ebf83850cc6d9d449e8c62c5d5c44d3fbab4ff0121c265ed363fa1e686d2ff9797a7dff8fe100a138aa72217fb8ba4183 SHA512 2d2fc57deb798c7666e2b7f9859318c1e9ae5477a79ccc3bb4f6de79edfc34c6096493306047ad2134a466da932e825d59881e896136ea7a0586fbd36177b0c4
+DIST epiphany-3.34.4.tar.xz 5295624 BLAKE2B c1867f62f1a0675466e2679d7f9e568abac6a4f3f56c498abfdc3d4ca4510696c4e9cbcab99a8be90bb50c77b04bcb86456a82dbefa76a2a7ec2c6b373ce9c39 SHA512 d9700196e0397032dd84d1fbf14d193f4212dd8dc054320267b4dfc8a59246de9c93fb786ba76463f0c09e7997b26efa17288cc06eddd0fb4aad2e4bdd4276ce
diff --git a/www-client/epiphany/epiphany-3.34.4.ebuild b/www-client/epiphany/epiphany-3.34.4.ebuild
new file mode 100644
index 000000000000..390434aa1b89
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.34.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.61.2:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.26.0:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=dev-libs/libdazzle-3.31.90
+ >=gui-libs/libhandy-0.0.10:0.0=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}