summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-08 13:03:35 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 13:03:35 +0300
commitc66debbf2d77f83a1a2fe20aae8cfca3921fab1f (patch)
treebef2f8d04d693686a84fa1f18af40a6ffae7a134 /www-client/epiphany
parentacct-user/git: Add git user, UID 196 (diff)
downloadgentoo-c66debbf2d77f83a1a2fe20aae8cfca3921fab1f.tar.gz
gentoo-c66debbf2d77f83a1a2fe20aae8cfca3921fab1f.tar.bz2
gentoo-c66debbf2d77f83a1a2fe20aae8cfca3921fab1f.zip
www-client/epiphany: bump to 3.32.5
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.32.5.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index cfbb3ae297b6..2296bbabf46f 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.30.4.tar.xz 4531732 BLAKE2B a4741d353800517c0233456e513a974ecd7641799395df7cafe6940cbfa49402836484010634ef3c59e36bd3bb2ced331d19a4ed05d1630c00d7ee385961227b SHA512 8574a26a22a24db7e65254f65723f6e4405fccd783bb7e122f8a5f6aff62d3ef1dd0b3ce903eb1f750e7ae28c2f1154a2c1c15970892216211d51edee318bd47
DIST epiphany-3.32.4.tar.xz 5468576 BLAKE2B 8d9ed9f522a7f18c1e9b0fa6aea043c11e69eda8ee779e8cb05cbef1920154ee7e307ea92eac713c74f7a81a08d9fc31dfd3ba8fad59d5697f4aa652e12a6e8e SHA512 34f9f4267862b494cbeb225ce63cd7767851f1cca16b4c8e03057b074999954477f2ed891c60f20910abcc7a553371f8f03e59fc9da4cf459dd5cbfde8a6d67c
+DIST epiphany-3.32.5.tar.xz 5468976 BLAKE2B 7e15eccbf48e7d2ada7b7a4ee4643219149f0d81c8c1767e5871fbed023bf53cd548822eabe5c9e0a26fd62a255ec69efdbd5efd05faef0e0374cedb473f5978 SHA512 e14a2626071460ddf8493a765d877f7683ba51e572778bb03f83ce31170856c6de91327955bd2d3b43e9016457da35a966014019d8837cd85765f948a7d1e5d2
diff --git a/www-client/epiphany/epiphany-3.32.5.ebuild b/www-client/epiphany/epiphany-3.32.5.ebuild
new file mode 100644
index 000000000000..07cf82ff5039
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.32.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.24.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=dev-libs/libdazzle-3.31.90
+ >=gui-libs/libhandy-0.0.9:0.0=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}