summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-30 21:38:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-30 22:05:41 +0200
commit01612f827733459b9d378e60ad895d1365fac20d (patch)
treeb207b1d267f41d27f1f1f317d228d0932c93b297 /www-client/firefox
parentmozconfig-v6.60.eclass: disable elf-hack when USE=clang (diff)
downloadgentoo-01612f827733459b9d378e60ad895d1365fac20d.tar.gz
gentoo-01612f827733459b9d378e60ad895d1365fac20d.tar.bz2
gentoo-01612f827733459b9d378e60ad895d1365fac20d.zip
www-client/firefox: disable elf-hack when USE=clang
Bug: https://bugs.gentoo.org/667216 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-60.2.1-r1.ebuild5
-rw-r--r--www-client/firefox/firefox-62.0.2.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-60.2.1-r1.ebuild b/www-client/firefox/firefox-60.2.1-r1.ebuild
index 944c98fcc47a..731dc4e13cec 100644
--- a/www-client/firefox/firefox-60.2.1-r1.ebuild
+++ b/www-client/firefox/firefox-60.2.1-r1.ebuild
@@ -240,6 +240,11 @@ src_configure() {
mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ if use clang ; then
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1423822
+ mozconfig_annotate 'elf-hack is broken when using Clang' --disable-elf-hack
+ fi
+
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig
echo "mk_add_options XARGS=/usr/bin/xargs" >> "${S}"/.mozconfig
diff --git a/www-client/firefox/firefox-62.0.2.ebuild b/www-client/firefox/firefox-62.0.2.ebuild
index e83a43676a44..6390b7d12352 100644
--- a/www-client/firefox/firefox-62.0.2.ebuild
+++ b/www-client/firefox/firefox-62.0.2.ebuild
@@ -421,6 +421,11 @@ src_configure() {
mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ if use clang ; then
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1423822
+ mozconfig_annotate 'elf-hack is broken when using Clang' --disable-elf-hack
+ fi
+
echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig
echo "mk_add_options XARGS=/usr/bin/xargs" >> "${S}"/.mozconfig