summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-28 13:59:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-28 14:00:09 +0200
commit1a9acbce822f8f8459f2cc8dfe187fd036cf116b (patch)
tree4772664c42e12cc568bf45fe40287271097c0d6c /www-client/firefox
parentnet-print/cndrvcups-lb: amd64 stable wrt bug #666276 (diff)
downloadgentoo-1a9acbce822f8f8459f2cc8dfe187fd036cf116b.tar.gz
gentoo-1a9acbce822f8f8459f2cc8dfe187fd036cf116b.tar.bz2
gentoo-1a9acbce822f8f8459f2cc8dfe187fd036cf116b.zip
www-client/firefox: add missing "errno.h" include in SandboxOpenedFiles.cpp
In addition, patch "firefox-60.0-rust-1.29-comp.patch" was dropped from firefox-62.x wchi was added in previous commit b1e7185593b8d3f4c46481d4 because patch is already present. Closes: https://bugs.gentoo.org/667096 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/firefox-60.0-missing-errno_h-in-SandboxOpenedFiles_cpp.patch27
-rw-r--r--www-client/firefox/firefox-60.2.1-r1.ebuild1
-rw-r--r--www-client/firefox/firefox-62.0.2.ebuild2
3 files changed, 29 insertions, 1 deletions
diff --git a/www-client/firefox/files/firefox-60.0-missing-errno_h-in-SandboxOpenedFiles_cpp.patch b/www-client/firefox/files/firefox-60.0-missing-errno_h-in-SandboxOpenedFiles_cpp.patch
new file mode 100644
index 000000000000..c746c73940ef
--- /dev/null
+++ b/www-client/firefox/files/firefox-60.0-missing-errno_h-in-SandboxOpenedFiles_cpp.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/667096
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1480554
+--- a/security/sandbox/linux/SandboxOpenedFiles.cpp
++++ b/security/sandbox/linux/SandboxOpenedFiles.cpp
+@@ -4,16 +4,17 @@
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+ #include "SandboxOpenedFiles.h"
+
+ #include "mozilla/Move.h"
+ #include "SandboxLogging.h"
+
++#include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+
+ namespace mozilla {
+
+ // The default move constructor almost works, but Atomic isn't
+ // move-constructable and the fd needs some special handling.
+ SandboxOpenedFile::SandboxOpenedFile(SandboxOpenedFile&& aMoved)
+
+
+
+
diff --git a/www-client/firefox/firefox-60.2.1-r1.ebuild b/www-client/firefox/firefox-60.2.1-r1.ebuild
index 89ad061bccf9..36964cc42d08 100644
--- a/www-client/firefox/firefox-60.2.1-r1.ebuild
+++ b/www-client/firefox/firefox-60.2.1-r1.ebuild
@@ -127,6 +127,7 @@ src_prepare() {
eapply "${FILESDIR}"/bug_1461221.patch
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch
+ eapply "${FILESDIR}"/${PN}-60.0-missing-errno_h-in-SandboxOpenedFiles_cpp.patch
# Enable gnomebreakpad
if use debug ; then
diff --git a/www-client/firefox/firefox-62.0.2.ebuild b/www-client/firefox/firefox-62.0.2.ebuild
index 82a6728b4eea..bee2af624194 100644
--- a/www-client/firefox/firefox-62.0.2.ebuild
+++ b/www-client/firefox/firefox-62.0.2.ebuild
@@ -187,7 +187,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
eapply "${FILESDIR}"/${PN}-60.0-do-not-force-lld.patch
eapply "${FILESDIR}"/${PN}-60.0-sandbox-lto.patch # 666580
- eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch
+ eapply "${FILESDIR}"/${PN}-60.0-missing-errno_h-in-SandboxOpenedFiles_cpp.patch
# Enable gnomebreakpad
if use debug ; then