summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-27 23:38:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 13:45:08 +0200
commit23e30a18cc929a37f50e38b5d5671d58cbc3506a (patch)
treeebc71601ef9c6cd947d8820a4d900e0ae92b607c /www-client/firefox
parentwww-client/firefox: allow building with >=media-sound/apulse-0.1.12-r4[sdk] (diff)
downloadgentoo-23e30a18cc929a37f50e38b5d5671d58cbc3506a.tar.gz
gentoo-23e30a18cc929a37f50e38b5d5671d58cbc3506a.tar.bz2
gentoo-23e30a18cc929a37f50e38b5d5671d58cbc3506a.zip
www-client/firefox: disable Normandy service by default
Bug: https://bugs.gentoo.org/713782 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/gentoo-default-prefs.js-31
-rw-r--r--www-client/firefox/firefox-68.6.0-r2.ebuild (renamed from www-client/firefox/firefox-68.6.0-r1.ebuild)33
-rw-r--r--www-client/firefox/firefox-74.0-r2.ebuild26
3 files changed, 58 insertions, 2 deletions
diff --git a/www-client/firefox/files/gentoo-default-prefs.js-3 b/www-client/firefox/files/gentoo-default-prefs.js-3
index d2a4dc82c94a..073ea77e5117 100644
--- a/www-client/firefox/files/gentoo-default-prefs.js-3
+++ b/www-client/firefox/files/gentoo-default-prefs.js-3
@@ -16,3 +16,4 @@ pref("intl.locale.requested", "");
pref("extensions.autoDisableScopes", 0);
pref("layout.css.dpi", 0);
pref("network.trr.mode", 5);
+pref("app.normandy.enabled", false);
diff --git a/www-client/firefox/firefox-68.6.0-r1.ebuild b/www-client/firefox/firefox-68.6.0-r2.ebuild
index c59249a49534..d610d428cc59 100644
--- a/www-client/firefox/firefox-68.6.0-r1.ebuild
+++ b/www-client/firefox/firefox-68.6.0-r2.ebuild
@@ -775,6 +775,39 @@ pkg_postinst() {
elog "media-sound/apulse."
elog
fi
+
+ local show_normandy_information
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ # New install
+ show_normandy_information=yes
+ else
+ local replacing_version
+ for replacing_version in ${REPLACING_VERSIONS} ; do
+ if ver_test "${replacing_version}" -lt 68.6.0-r2 ; then
+ # Tell user only once about our Normandy default
+ show_normandy_information=yes
+ break
+ fi
+ done
+ fi
+
+ # bug 713782
+ if [[ -n "${show_normandy_information}" ]] ; then
+ elog
+ elog "Upstream operates a service named Normandy which allows Mozilla to"
+ elog "push changes for default settings or even install new add-ons remotely."
+ elog "While this can be useful to address problems like 'Armagadd-on 2.0' or"
+ elog "revert previous decisions to disable TLS 1.0/1.1, privacy and security"
+ elog "concerns prevail, which is why we have switched off the use of this"
+ elog "service by default."
+ elog
+ elog "To re-enable this service set"
+ elog
+ elog " app.normandy.enabled=true"
+ elog
+ elog "in about:config."
+ fi
}
pkg_postrm() {
diff --git a/www-client/firefox/firefox-74.0-r2.ebuild b/www-client/firefox/firefox-74.0-r2.ebuild
index 11e72681132c..739761cdb2f2 100644
--- a/www-client/firefox/firefox-74.0-r2.ebuild
+++ b/www-client/firefox/firefox-74.0-r2.ebuild
@@ -793,18 +793,23 @@ pkg_postinst() {
elog
fi
- local show_doh_information
+ local show_doh_information show_normandy_information
if [[ -z "${REPLACING_VERSIONS}" ]] ; then
# New install; Tell user that DoH is disabled by default
show_doh_information=yes
+ show_normandy_information=yes
else
local replacing_version
for replacing_version in ${REPLACING_VERSIONS} ; do
if ver_test "${replacing_version}" -lt 70 ; then
# Tell user only once about our DoH default
show_doh_information=yes
- break
+ fi
+
+ if ver_test "${replacing_version}" -lt 74.0-r2 ; then
+ # Tell user only once about our Normandy default
+ show_normandy_information=yes
fi
done
fi
@@ -818,6 +823,23 @@ pkg_postinst() {
elog "(\"Off by choice\") by default."
elog "You can enable DNS-over-HTTPS in ${PN^}'s preferences."
fi
+
+ # bug 713782
+ if [[ -n "${show_normandy_information}" ]] ; then
+ elog
+ elog "Upstream operates a service named Normandy which allows Mozilla to"
+ elog "push changes for default settings or even install new add-ons remotely."
+ elog "While this can be useful to address problems like 'Armagadd-on 2.0' or"
+ elog "revert previous decisions to disable TLS 1.0/1.1, privacy and security"
+ elog "concerns prevail, which is why we have switched off the use of this"
+ elog "service by default."
+ elog
+ elog "To re-enable this service set"
+ elog
+ elog " app.normandy.enabled=true"
+ elog
+ elog "in about:config."
+ fi
}
pkg_postrm() {