summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-23 13:32:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-23 13:32:49 +0200
commit3dae3ce96ca7551c241d05236d8af7c66eb0bd2f (patch)
tree07fad40309be307ca665ee57bc346831536ddb0e /www-client/firefox
parentdev-vcs/git-lfs: update 9999 (diff)
downloadgentoo-3dae3ce96ca7551c241d05236d8af7c66eb0bd2f.tar.gz
gentoo-3dae3ce96ca7551c241d05236d8af7c66eb0bd2f.tar.bz2
gentoo-3dae3ce96ca7551c241d05236d8af7c66eb0bd2f.zip
www-client/firefox: add information about TERM to output (build.log)
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-60.2.1.ebuild8
-rw-r--r--www-client/firefox/firefox-62.0.2.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-60.2.1.ebuild b/www-client/firefox/firefox-60.2.1.ebuild
index ef8d57e983f1..94ea29cb744f 100644
--- a/www-client/firefox/firefox-60.2.1.ebuild
+++ b/www-client/firefox/firefox-60.2.1.ebuild
@@ -189,6 +189,14 @@ src_configure() {
# get your own set of keys.
_google_api_key=AIzaSyDEAOvatFo0eTgsV_ZlEzx0ObmepsMzfAc
+ # Add information about TERM to output (build.log) to aid debugging
+ # blessings problems
+ if [[ -n "${TERM}" ]] ; then
+ einfo "TERM is set to: \"${TERM}\""
+ else
+ einfo "TERM is unset."
+ fi
+
####################################
#
# mozconfig, CFLAGS and CXXFLAGS setup
diff --git a/www-client/firefox/firefox-62.0.2.ebuild b/www-client/firefox/firefox-62.0.2.ebuild
index 778dbe170f98..398628a49d71 100644
--- a/www-client/firefox/firefox-62.0.2.ebuild
+++ b/www-client/firefox/firefox-62.0.2.ebuild
@@ -248,6 +248,14 @@ src_configure() {
# get your own set of keys.
_google_api_key=AIzaSyDEAOvatFo0eTgsV_ZlEzx0ObmepsMzfAc
+ # Add information about TERM to output (build.log) to aid debugging
+ # blessings problems
+ if [[ -n "${TERM}" ]] ; then
+ einfo "TERM is set to: \"${TERM}\""
+ else
+ einfo "TERM is unset."
+ fi
+
if use clang && ! tc-is-clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."