summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-28 13:39:43 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-28 13:43:51 +0200
commitb1e7185593b8d3f4c46481d43da41176c5628126 (patch)
tree4ee98f21d9ab442acae2a25f86076085b8489ed1 /www-client/firefox
parentnet-im/pidgin: amd64 stable wrt bug #666858 (diff)
downloadgentoo-b1e7185593b8d3f4c46481d43da41176c5628126.tar.gz
gentoo-b1e7185593b8d3f4c46481d43da41176c5628126.tar.bz2
gentoo-b1e7185593b8d3f4c46481d43da41176c5628126.zip
www-client/firefox: add rust-1.29+ support
Closes: https://bugs.gentoo.org/666898 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/firefox-60.0-rust-1.29-comp.patch37
-rw-r--r--www-client/firefox/firefox-60.2.1-r1.ebuild1
-rw-r--r--www-client/firefox/firefox-62.0.2.ebuild1
3 files changed, 39 insertions, 0 deletions
diff --git a/www-client/firefox/files/firefox-60.0-rust-1.29-comp.patch b/www-client/firefox/files/firefox-60.0-rust-1.29-comp.patch
new file mode 100644
index 000000000000..6fbd13fe639a
--- /dev/null
+++ b/www-client/firefox/files/firefox-60.0-rust-1.29-comp.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/666898
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1479540
+--- a/build/moz.configure/init.configure
++++ b/build/moz.configure/init.configure
+@@ -572,17 +572,26 @@ option('--target', nargs=1,
+ @imports(_from='__builtin__', _import='KeyError')
+ @imports(_from='__builtin__', _import='ValueError')
+ def split_triplet(triplet, allow_unknown=False):
+ # The standard triplet is defined as
+ # CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM
+ # There is also a quartet form:
+ # CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
+ # But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
+- cpu, manufacturer, os = triplet.split('-', 2)
++ # Additionally, some may omit "unknown" when the manufacturer
++ # is not specified and emit
++ # CPU_TYPE-OPERATING_SYSTEM
++ parts = triplet.split('-', 2)
++ if len(parts) == 3:
++ cpu, _, os = parts
++ elif len(parts) == 2:
++ cpu, os = parts
++ else:
++ die("Unexpected triplet string: %s" % triplet)
+
+ # Autoconf uses config.sub to validate and canonicalize those triplets,
+ # but the granularity of its results has never been satisfying to our
+ # use, so we've had our own, different, canonicalization. We've also
+ # historically not been very consistent with how we use the canonicalized
+ # values. Hopefully, this will help us make things better.
+ # The tests are inherited from our decades-old autoconf-based configure,
+ # which can probably be improved/cleaned up because they are based on a
+
+
+
+
diff --git a/www-client/firefox/firefox-60.2.1-r1.ebuild b/www-client/firefox/firefox-60.2.1-r1.ebuild
index 03ffedb5a69b..89ad061bccf9 100644
--- a/www-client/firefox/firefox-60.2.1-r1.ebuild
+++ b/www-client/firefox/firefox-60.2.1-r1.ebuild
@@ -126,6 +126,7 @@ src_prepare() {
eapply "${FILESDIR}"/bug_1461221.patch
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
+ eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch
# Enable gnomebreakpad
if use debug ; then
diff --git a/www-client/firefox/firefox-62.0.2.ebuild b/www-client/firefox/firefox-62.0.2.ebuild
index 426d2ba9bc02..82a6728b4eea 100644
--- a/www-client/firefox/firefox-62.0.2.ebuild
+++ b/www-client/firefox/firefox-62.0.2.ebuild
@@ -187,6 +187,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
eapply "${FILESDIR}"/${PN}-60.0-do-not-force-lld.patch
eapply "${FILESDIR}"/${PN}-60.0-sandbox-lto.patch # 666580
+ eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch
# Enable gnomebreakpad
if use debug ; then