summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-25 22:59:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-25 23:00:01 +0200
commitc24e20dbdb0c87824f3c37d9df42dceb2ceb2cf9 (patch)
treed260958157c75da04cf76933ec273a761f89f25a /www-client/firefox
parentnet-fs/minio: do not remove go.mod (diff)
downloadgentoo-c24e20dbdb0c87824f3c37d9df42dceb2ceb2cf9.tar.gz
gentoo-c24e20dbdb0c87824f3c37d9df42dceb2ceb2cf9.tar.bz2
gentoo-c24e20dbdb0c87824f3c37d9df42dceb2ceb2cf9.zip
www-client/firefox: USE=pgo requires FEATURES=userpriv
Closes: https://bugs.gentoo.org/682668 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-68.0.1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-68.0.1.ebuild b/www-client/firefox/firefox-68.0.1.ebuild
index 9a45c46f6d72..29ca61b95dbf 100644
--- a/www-client/firefox/firefox-68.0.1.ebuild
+++ b/www-client/firefox/firefox-68.0.1.ebuild
@@ -354,6 +354,12 @@ src_configure() {
# Must pass release in order to properly select linker
mozconfig_annotate 'Enable by Gentoo' --enable-release
+ if use pgo ; then
+ if ! has userpriv $FEATURES ; then
+ eerror "Building firefox with USE=pgo and FEATURES=-userpriv is not supported!"
+ fi
+ fi
+
# Don't let user's LTO flags clash with upstream's flags
filter-flags -flto*