summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/google-chrome-unstable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/google-chrome-unstable')
-rw-r--r--www-client/google-chrome-unstable/Manifest2
-rw-r--r--www-client/google-chrome-unstable/google-chrome-unstable-46.0.2471.2_p1.ebuild160
-rw-r--r--www-client/google-chrome-unstable/metadata.xml20
3 files changed, 182 insertions, 0 deletions
diff --git a/www-client/google-chrome-unstable/Manifest b/www-client/google-chrome-unstable/Manifest
new file mode 100644
index 000000000000..1baabe72e3ab
--- /dev/null
+++ b/www-client/google-chrome-unstable/Manifest
@@ -0,0 +1,2 @@
+DIST google-chrome-unstable_46.0.2471.2-1_amd64.deb 47352022 SHA256 13f5c6cfece24c849f743a797556cf11ea10f6dc36aad030dedde47a065d11f7 SHA512 3e435573cdad1f7972893f14748e497311a67f450f81244c2620d841909eba4d27926a79b5a438ece7bf5a9c14ce44cdbc2a93219e35c622a858dd0ba3692936 WHIRLPOOL 0187f601db519cccd02f2e14be556bc4ac31f0100e4b049955aebd6c2ead7281393d608f5e0d3ac40ef8690ba4c25422cf8375894ec4cc6cda7181c79670b81f
+DIST google-chrome-unstable_46.0.2471.2-1_i386.deb 46699784 SHA256 a9e332ef3d16601ae3481793d7754d3c119f8a05c8d07869dffb27c467262f87 SHA512 8f1e502214dbea7650a2221589f488c6cd1bd4532469ab6ed00bacbf823795a11815c21413031e7f54452f0fd905587b104fb4fb01b2ae58997ecab830822aa1 WHIRLPOOL 9b85a2f5b676e6cb7500d679c0b0184b0f7cfdacb8b1e364f01f42b10035ffcea74cdd4058a4c8108b259773435640e5e981a979dd0b24afeab243211e43d240
diff --git a/www-client/google-chrome-unstable/google-chrome-unstable-46.0.2471.2_p1.ebuild b/www-client/google-chrome-unstable/google-chrome-unstable-46.0.2471.2_p1.ebuild
new file mode 100644
index 000000000000..1834b22d6552
--- /dev/null
+++ b/www-client/google-chrome-unstable/google-chrome-unstable-46.0.2471.2_p1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+CHROMIUM_LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he
+ hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr
+ sv sw ta te th tr uk vi zh_CN zh_TW"
+
+inherit readme.gentoo chromium eutils multilib pax-utils unpacker
+
+DESCRIPTION="The web browser from Google"
+HOMEPAGE="http://www.google.com/chrome"
+
+if [[ ${PN} == google-chrome ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+MY_P="${MY_PN}_${PV/_p/-}"
+
+SRC_URI="
+ amd64? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
+ )
+ x86? (
+ http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
+ )
+"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+plugins"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ app-arch/bzip2
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype:2
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/libcap
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ >=x11-libs/libX11-1.5.0
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+CHROME_HOME="opt/google/chrome${PN#google-chrome}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+Some web pages may require additional fonts to display properly.
+Try installing some of the following packages if some characters
+are not displayed properly:
+- media-fonts/arphicfonts
+- media-fonts/bitstream-cyberbit
+- media-fonts/droid
+- media-fonts/ipamonafont
+- media-fonts/ja-ipafonts
+- media-fonts/takao-fonts
+- media-fonts/wqy-microhei
+- media-fonts/wqy-zenhei
+
+Depending on your desktop environment, you may need
+to install additional packages to get icons on the Downloads page.
+
+For KDE, the required package is kde-apps/oxygen-icons.
+
+For other desktop environments, try one of the following:
+- x11-themes/gnome-icon-theme
+- x11-themes/tango-icon-theme
+
+Please notice the bundled flash player (PepperFlash).
+You can (de)activate all flash plugins via chrome://plugins
+"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for google-chrome fetch failures."
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_install() {
+ rm -r usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ pushd "${CHROME_HOME}/locales" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ if use plugins ; then
+ local plugins="--extra-plugin-dir=/usr/$(get_libdir)/nsbrowser/plugins"
+ sed -e "/^exec/ i set -- \"${plugins}\" \"\$@\"" \
+ -i "${CHROME_HOME}/${PN}" || die
+ fi
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${CHROME_HOME}/product_logo_${size}.png" ${PN}.png
+ done
+
+ insinto /
+ doins -r opt usr
+
+ find "${ED}" -type d -empty -delete || die
+ chmod 755 "${ED}${CHROME_HOME}"/{chrome,${PN},nacl_helper{,_bootstrap},xdg-{mime,settings}} || die
+ chmod 4755 "${ED}${CHROME_HOME}/chrome-sandbox" || die
+ pax-mark m "${ED}${CHROME_HOME}/chrome"
+
+ readme.gentoo_create_doc
+}
+
+any_cpu_missing_flag() {
+ local value=$1
+ grep '^flags' /proc/cpuinfo | grep -qv "$value"
+}
+
+pkg_preinst() {
+ chromium_pkg_preinst
+ if any_cpu_missing_flag sse2; then
+ ewarn "The bundled PepperFlash plugin requires a CPU that supports the"
+ ewarn "SSE2 instruction set, and at least one of your CPUs does not"
+ ewarn "support this feature. Disabling PepperFlash."
+ sed -e "/^exec/ i set -- --disable-bundled-ppapi-flash \"\$@\"" \
+ -i "${ED}${CHROME_HOME}/google-chrome" || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+}
diff --git a/www-client/google-chrome-unstable/metadata.xml b/www-client/google-chrome-unstable/metadata.xml
new file mode 100644
index 000000000000..b6a2d8a0f044
--- /dev/null
+++ b/www-client/google-chrome-unstable/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>chromium</herd>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription>
+ Google Chrome is a browser that combines a minimal design with
+ sophisticated technology to make the web faster, safer, and easier.
+ </longdescription>
+ <use>
+ <flag name="plugins">Add system plugins path to launcher</flag>
+ </use>
+</pkgmetadata>