summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-08-06 21:47:08 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-08-06 21:47:08 +0900
commitd93be79561a120db88087a6ebe1733ad98041c5a (patch)
treeeea28e13c2b091d226bbce97fed95eaae4333772 /www-client/jd
parentwww-client/jd: update to EAPI 6 (diff)
downloadgentoo-d93be79561a120db88087a6ebe1733ad98041c5a.tar.gz
gentoo-d93be79561a120db88087a6ebe1733ad98041c5a.tar.bz2
gentoo-d93be79561a120db88087a6ebe1733ad98041c5a.zip
www-client/jd: fix build with >=sys-devel/gcc-5
Closes: https://bugs.gentoo.org/600802 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-client/jd')
-rw-r--r--www-client/jd/files/jd-gcc-5.patch15
-rw-r--r--www-client/jd/jd-2.8.5_p120826.ebuild2
2 files changed, 17 insertions, 0 deletions
diff --git a/www-client/jd/files/jd-gcc-5.patch b/www-client/jd/files/jd-gcc-5.patch
new file mode 100644
index 000000000000..4e6a74f4d79d
--- /dev/null
+++ b/www-client/jd/files/jd-gcc-5.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/600802
+
+Author: nanikata@gmail.com
+
+--- a/src/article/drawareabase.h
++++ b/src/article/drawareabase.h
+@@ -330,7 +330,7 @@
+
+ // リアライズしたか
+ // Gtk::Widget::is_realized() はうまく動作しない
+- const bool is_drawarea_realized(){ return m_window; }
++ const bool is_drawarea_realized(){ return static_cast<bool>(m_window); }
+
+ // 文字色のID( colorid.h にある ID を指定)
+ const int get_colorid_text() const{ return m_colorid_text; }
diff --git a/www-client/jd/jd-2.8.5_p120826.ebuild b/www-client/jd/jd-2.8.5_p120826.ebuild
index 05dd4ad5f84b..c05782e16ca6 100644
--- a/www-client/jd/jd-2.8.5_p120826.ebuild
+++ b/www-client/jd/jd-2.8.5_p120826.ebuild
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-gcc-5.patch )
+
src_prepare() {
default
append-cxxflags -std=c++11