summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-23 11:18:46 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-23 11:33:20 +0200
commit6b0667243f39d4c4b8a2a51ccd80ed7158e5b011 (patch)
treebb1c71e65d762783f535f559280737324e7d1721 /www-client/opera-beta
parentmedia-libs/libmatroska: arm64 stable (bug #689690) (diff)
downloadgentoo-6b0667243f39d4c4b8a2a51ccd80ed7158e5b011.tar.gz
gentoo-6b0667243f39d4c4b8a2a51ccd80ed7158e5b011.tar.bz2
gentoo-6b0667243f39d4c4b8a2a51ccd80ed7158e5b011.zip
www-client/opera-beta: Version 63.0.3368.14
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/opera-beta')
-rw-r--r--www-client/opera-beta/Manifest1
-rw-r--r--www-client/opera-beta/opera-beta-63.0.3368.14.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/www-client/opera-beta/Manifest b/www-client/opera-beta/Manifest
index 290c93b92404..6a8a78448f9f 100644
--- a/www-client/opera-beta/Manifest
+++ b/www-client/opera-beta/Manifest
@@ -1 +1,2 @@
+DIST opera-beta_63.0.3368.14_amd64.deb 61543128 BLAKE2B e76ce03da696994e738aee961b9cce06c7225103a7de8cc67c5b40b7383ed429f22ca4018028fc0cdd12f345ab579b0807419e0bf12ce1323d245ffe571f580c SHA512 f4ef9a9ab3d2508c085a7a2d625c3d3e2bb691046037971b2c9fbab3ef272fdc1df6cf80695c4b81ce9109b7cbd53ceb94fcf47cb3f423d17f4a56ea472e6680
DIST opera-beta_63.0.3368.8_amd64.deb 60832818 BLAKE2B 45a6da9342efe9a2a8511364edbcd4eacde1ee0f3ef20830d959ecf4bc652f475c5cc4dcc3b1e35b07d359066e38d8daab3b911e27e8477ad39cb869d0f4f7bf SHA512 b53affde2eae29e9cb9aaddce9340857beffe0ea28fcb2d5bcee16cb90acb02869b060c0a0af8aeaea62e289e7c7bb94b7ec78960f9e5a3e0a19e3f0e4a0ee87
diff --git a/www-client/opera-beta/opera-beta-63.0.3368.14.ebuild b/www-client/opera-beta/opera-beta-63.0.3368.14.ebuild
new file mode 100644
index 000000000000..59a8587ec4bd
--- /dev/null
+++ b/www-client/opera-beta/opera-beta-63.0.3368.14.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
+ ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+ https://download1.operacdn.com/pub/
+ https://download2.operacdn.com/pub/
+ https://download3.operacdn.com/pub/
+ https://download4.operacdn.com/pub/
+"
+SRC_URI="amd64? ("
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+ "${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
+"
+done
+SRC_URI+=")"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libnotify
+ x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+pkg_setup() {
+ OPERA_HOME="usr/$(get_libdir)/${PN}"
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+
+ case ${ARCH} in
+ amd64)
+ mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+ rm -r usr/lib || die
+ ;;
+ x86)
+ mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
+ ;;
+ esac
+
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ rm usr/bin/${PN} || die
+
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+ mv * "${D}" || die
+ dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+ fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}