summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2018-02-05 09:41:47 +0000
committerTony Vroon <chainsaw@gentoo.org>2018-02-05 09:42:02 +0000
commite0c46dce61069b7f7dfdce18e3fabe6fb9384d2e (patch)
treefd502ee639b3f9e5b058b46f28b0ce6a256c89bb /www-client/phantomjs
parentmedia-sound/xmms2: use virtual/jack instead of media-sound/jack (diff)
downloadgentoo-e0c46dce61069b7f7dfdce18e3fabe6fb9384d2e.tar.gz
gentoo-e0c46dce61069b7f7dfdce18e3fabe6fb9384d2e.tar.bz2
gentoo-e0c46dce61069b7f7dfdce18e3fabe6fb9384d2e.zip
www-client/phantomjs: ICU 59/60 compatibility
Scavenged patches originally by Ervin Peters in bug #621532 address a build issue with ICU 59 and newer. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'www-client/phantomjs')
-rw-r--r--www-client/phantomjs/Manifest1
-rw-r--r--www-client/phantomjs/phantomjs-2.1.1-r1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/www-client/phantomjs/Manifest b/www-client/phantomjs/Manifest
index 3409760e9ed2..b8f6ea3a3841 100644
--- a/www-client/phantomjs/Manifest
+++ b/www-client/phantomjs/Manifest
@@ -1,4 +1,5 @@
DIST gentoo-phantomjs-patchset-0.01.tar.bz2 7537 BLAKE2B 4a0fe19ae338ebb1846e2f04c3a6ea2f790d3835044d089304f7eba1d1f3bf0af41148d87b6f4a32103a5613cb1b470a8572189653bb3c38a64fb0c12e475feb SHA512 3e85fe068da41fa620ad89f9b0450fa7aa405778c2011d4b0f046edd9c921702125adf01075cd90d70cd21d9704081a67be18c1f9eece4070a26407a6a56a5df
+DIST gentoo-phantomjs-patchset-0.02.tar.bz2 8017 BLAKE2B 0bde29dab19ced08afeab0484e0d88f9fee35306ddba0aeda3cef158ad0f818a7f93f6d1462766399231513d1279dc1071bde4e82d82c67e156eaeb0c52d6f87 SHA512 88e8acb47842b108c4f01bc778c25d95011462b9d6732e6cca20372824a93321731d1976b19736a87d6e51737dffa0c76a15983d4b0739e97c7dc55ea065e791
DIST phantomjs-1.9.8-source.zip 40965044 BLAKE2B f0ba4e7684539daf19b3f4c012ca680cbce8858ec1639714d14726e8234e4392d7239cd9f797471bdf3fdcf46ee81b006548891f645f5d71783a28a749c32616 SHA512 3692268a2706b097484ade500a2b24ce33d243b8ebbdf5ae8dea4b5e37adea5a84c11528e2862b9da71deb53cd14a985f1878d190a91c440632dd22cbfaf78fb
DIST phantomjs-2.0.0-source.zip 110092872 BLAKE2B cbd27e1803801cfd8316effcf532f68fe03ce3ebee2b972c8ad2c909522e362b28d0054e73272d0eb0a1cb68a68a1942f2d04072b3e0524a8fa0fe84092ff6a9 SHA512 c8262353ee4daa842ef891b41e006baccf1815a99cf3262aeba457cfc37bbef6cb2ca234e69bd33a5446014fe802b3e35591e2eb0d49d8483c1f75bacf9d6f42
DIST phantomjs-2.1.1.tar.gz 1880406 BLAKE2B e54e8a1d42cdbf6fb98c90283a0ebcb4145350bc34d76b8a0d01163fcca15b7e6bbf7043e2d17bbf21c5d01e7fd0e76a4386f9c01dfc8727998f8d0f17da9291 SHA512 07b769133957c5194c9afdaa347bd9a019ebe47653f98adf17a35d3dd12714d2f8e3773ced91d7d99f31cb18d7f73167022d5b0a3906d9aac0732ef96341f5ec
diff --git a/www-client/phantomjs/phantomjs-2.1.1-r1.ebuild b/www-client/phantomjs/phantomjs-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..c9a611bdeb3e
--- /dev/null
+++ b/www-client/phantomjs/phantomjs-2.1.1-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+QTB_PV="5.5.1"
+QTB_P="qtbase-opensource-src-${QTB_PV}"
+QTW_PV="5.7.1"
+QTW_P="qtwebkit-opensource-src-${QTW_PV}"
+
+DESCRIPTION="A headless WebKit scriptable with a JavaScript API"
+HOMEPAGE="http://phantomjs.org/"
+SRC_URI="https://github.com/ariya/phantomjs/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://download.qt.io/archive/qt/${QTB_PV%.*}/${QTB_PV}/submodules/${QTB_P}.tar.xz
+ https://download.qt.io/community_releases/${QTW_PV%.*}/${QTW_PV}/${QTW_P}.tar.xz
+ mirror://gentoo/gentoo-${PN}-patchset-0.02.tar.bz2"
+
+inherit eutils toolchain-funcs pax-utils multiprocessing
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples fontconfig libressl truetype"
+RESTRICT="mirror"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+EPATCH_SUFFIX="patch"
+PATCHES=( "${WORKDIR}/${PN}-patchset" )
+
+RDEPEND="dev-libs/icu:=
+ fontconfig? ( media-libs/fontconfig )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ truetype? ( media-libs/freetype )
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ net-misc/openssh[-bindist]
+ app-arch/unzip
+ dev-lang/ruby
+ virtual/pkgconfig"
+
+src_prepare() {
+ ebegin "Moving third-party libraries into position for build"
+ mv -T "${WORKDIR}/${QTB_P}" "${S}/src/qt/qtbase/" || die "QT base ${QTB_PV} failed"
+ mv -T "${WORKDIR}/${QTW_P}" "${S}/src/qt/qtwebkit/" || die "QT webkit ${QTW_PV} failed"
+ eend "$?"
+
+ ebegin "Instilling C/CXX/LDFLAGS respect in main source"
+ # Respect CC, CXX, {C,CXX,LD}FLAGS in .qmake.cache
+ sed -i \
+ -e "/^SYSTEM_VARIABLES=/i \
+ CC='$(tc-getCC)'\n\
+ CXX='$(tc-getCXX)'\n\
+ CFLAGS='${CFLAGS}'\n\
+ CXXFLAGS='${CXXFLAGS}'\n\
+ LDFLAGS='${LDFLAGS}'\n\
+ QMakeVar set QMAKE_CFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_CFLAGS_DEBUG\n\
+ QMakeVar set QMAKE_CXXFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_CXXFLAGS_DEBUG\n\
+ QMakeVar set QMAKE_LFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_LFLAGS_DEBUG\n"\
+ src/qt/qtbase/configure \
+ || die
+ eend $?
+
+ ebegin "Instilling C/CXX/LDFLAGS respect in test suite"
+ # Respect CC, CXX, LINK and *FLAGS in config.tests
+ find src/qt/qtbase/config.tests/unix -name '*.test' -type f -exec \
+ sed -i -e "/bin\/qmake/ s: \"\$SRCDIR/: \
+ 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \
+ 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \
+ {} + || die
+ eend $?
+
+ default
+}
+
+src_compile() {
+ ./build.py \
+ --confirm \
+ --jobs $(makeopts_jobs) \
+ || die
+}
+
+src_test() {
+ ./bin/phantomjs test/run-tests.js || die
+}
+
+src_install() {
+ pax-mark m bin/phantomjs || die
+ dobin bin/phantomjs
+ dodoc ChangeLog README.md
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}