summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-05-04 08:53:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-05-04 10:30:08 +0200
commita011bebd36d41b5ab277a0354723895a2b8a2c99 (patch)
tree83ceb8f6d43473741fde81a337dea0faf7d5921b /www-client/seamonkey
parentmedia-libs/harfbuzz: Bump to version 2.8.1 (diff)
downloadgentoo-a011bebd36d41b5ab277a0354723895a2b8a2c99.tar.gz
gentoo-a011bebd36d41b5ab277a0354723895a2b8a2c99.tar.bz2
gentoo-a011bebd36d41b5ab277a0354723895a2b8a2c99.zip
www-client/seamonkey: Revbump to fix installation of extensions
Thanks-to: Petr Cerny [:hrosik] <p.c-bugzilla@black-net.org> Closes: https://bugs.gentoo.org/788004 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/seamonkey-2.53.7.1-r1.ebuild (renamed from www-client/seamonkey/seamonkey-2.53.7.1.ebuild)13
1 files changed, 6 insertions, 7 deletions
diff --git a/www-client/seamonkey/seamonkey-2.53.7.1.ebuild b/www-client/seamonkey/seamonkey-2.53.7.1-r1.ebuild
index 79cd3a849a6e..c3a2e4925ffa 100644
--- a/www-client/seamonkey/seamonkey-2.53.7.1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.7.1-r1.ebuild
@@ -388,19 +388,18 @@ src_configure() {
# Linking fails without this due to memory exhaustion
use x86 && append-ldflags "-Wl,--no-keep-memory"
- if ! use chatzilla ; then
- MEXTENSIONS+=",-irc"
- fi
if ! use roaming ; then
MEXTENSIONS+=",-sroaming"
fi
# Setup api key for location services
- echo -n "${_google_api_key}" > "${S}"/google-api-key
+ printf '%s' "${_google_api_key}" > "${S}"/google-api-key
mozconfig_annotate '' --with-google-location-service-api-keyfile="${S}/google-api-key"
mozconfig_annotate '' --with-google-safebrowsing-api-keyfile="${S}/google-api-key"
mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ mozconfig_use_enable chatzilla irc
+ mozconfig_annotate '' --enable-dominspector
# use startup-cache for faster startup time
mozconfig_annotate '' --enable-startupcache
@@ -504,8 +503,8 @@ src_install() {
emid='{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}'
# remove the en_US-only xpi file so a version with all requested locales can be installed
- if [[ -e "${ED}"/${MOZILLA_FIVE_HOME}/distribution/extensions/${emid}.xpi ]] ; then
- rm -f "${ED}"/${MOZILLA_FIVE_HOME}/distribution/extensions/${emid}.xpi || die
+ if [[ -e "${ED}"/${MOZILLA_FIVE_HOME}/extensions/${emid}.xpi ]] ; then
+ rm -f "${ED}"/${MOZILLA_FIVE_HOME}/extensions/${emid}.xpi || die
fi
# merge the extra locales into the main extension
@@ -514,7 +513,7 @@ src_install() {
# install the merged extension
mkdir -p "${T}/${emid}" || die
cp -RLp -t "${T}/${emid}" dist/xpi-stage/chatzilla/* || die
- insinto ${MOZILLA_FIVE_HOME}/distribution/extensions
+ insinto ${MOZILLA_FIVE_HOME}/extensions
doins -r "${T}/${emid}"
fi