summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-28 08:36:18 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-28 08:38:46 +0100
commit83e529a3c3b7f7c6ad88338e0211a9c680718c4a (patch)
tree11d7e1978143b5bacd258368b507626662bcac93 /www-client/surf/surf-0.7.ebuild
parentwww-client/opera-developer: Version bump. (diff)
downloadgentoo-83e529a3c3b7f7c6ad88338e0211a9c680718c4a.tar.gz
gentoo-83e529a3c3b7f7c6ad88338e0211a9c680718c4a.tar.bz2
gentoo-83e529a3c3b7f7c6ad88338e0211a9c680718c4a.zip
www-client/surf: Version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-client/surf/surf-0.7.ebuild')
-rw-r--r--www-client/surf/surf-0.7.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/www-client/surf/surf-0.7.ebuild b/www-client/surf/surf-0.7.ebuild
new file mode 100644
index 000000000000..834dd702061b
--- /dev/null
+++ b/www-client/surf/surf-0.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ !savedconfig? (
+ net-misc/curl
+ x11-terms/st
+ )
+"
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7-gentoo.patch
+
+ epatch_user
+
+ restore_config config.h
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+ save_config config.h
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+ fi
+}