summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/xombrero
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/xombrero')
-rw-r--r--www-client/xombrero/Manifest1
-rw-r--r--www-client/xombrero/metadata.xml9
-rw-r--r--www-client/xombrero/xombrero-1.6.3.ebuild96
-rw-r--r--www-client/xombrero/xombrero-9999.ebuild95
4 files changed, 201 insertions, 0 deletions
diff --git a/www-client/xombrero/Manifest b/www-client/xombrero/Manifest
new file mode 100644
index 000000000000..47f4bdaec139
--- /dev/null
+++ b/www-client/xombrero/Manifest
@@ -0,0 +1 @@
+DIST xombrero-1.6.3.tgz 290478 SHA256 481011c136206f7aa3ab4cdf49ad77f81df4d5585f9e9a20c651bfaaaa537f79 SHA512 420fdbb8c90e1009c7db41a6f3e6c77e03b70a8df732d1c6d37b83d7c8c873cbddf0ec9ed1fe95f3a8d62744a22d6bfcdde95b446d499aa4dc6d47d59d202e88 WHIRLPOOL 775157008fcc2cd12d42da35320f0f536fb6335dfd4c4c230b6824863e3c8eb94bd6415f80526df46eedc85eb2d27002b13949754e149f402788ac5c5ddb54dc
diff --git a/www-client/xombrero/metadata.xml b/www-client/xombrero/metadata.xml
new file mode 100644
index 000000000000..4e77b4b7ea2c
--- /dev/null
+++ b/www-client/xombrero/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/www-client/xombrero/xombrero-1.6.3.ebuild b/www-client/xombrero/xombrero-1.6.3.ebuild
new file mode 100644
index 000000000000..ac883c47970d
--- /dev/null
+++ b/www-client/xombrero/xombrero-1.6.3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS=git-2
+fi
+
+inherit eutils fdo-mime toolchain-funcs ${GIT_ECLASS}
+
+DESCRIPTION="A minimalist web browser with sophisticated security features designed-in"
+HOMEPAGE="http://opensource.conformal.com/wiki/xombrero"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://opensource.conformal.com/${PN}.git
+ https://opensource.conformal.com/git/${PN}.git"
+ EGIT_SOURCEDIR="${WORKDIR}/${P}"
+ KEYWORDS=""
+else
+ SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0
+ net-libs/libsoup
+ net-libs/gnutls
+ net-libs/webkit-gtk:3
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/groff
+ dev-libs/atk
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:0
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/pixman"
+
+S="${WORKDIR}/${P}/linux"
+
+src_prepare() {
+ sed -i \
+ -e 's/-O2//' \
+ -e 's/-ggdb3//' \
+ -e 's,install: all,install: all\n\tinstall -m 755 -d $(DESTDIR)$(PREFIX)/share/applications,g' \
+ Makefile || die 'sed Makefile failed.'
+ sed -i \
+ -e 's#https://www\.cyphertite\.com#http://www.gentoo.org/#' \
+ -e "s#/usr/local#/usr#" \
+ ../xombrero.h || die 'sed ../xombrero.c failed.'
+ sed -i \
+ "s#Icon=#Icon=/usr/share/${PN}/#" \
+ ../xombrero.desktop || die 'sed ../xombrero.desktop failed.'
+ sed -i "s:Application;::" ../xombrero.desktop || die
+}
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDADD="${LDFLAGS}" emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ install
+
+ if use examples;then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins \
+ ../${PN}.conf \
+ ../playflash.sh \
+ ../favorites
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/www-client/xombrero/xombrero-9999.ebuild b/www-client/xombrero/xombrero-9999.ebuild
new file mode 100644
index 000000000000..684d17490d73
--- /dev/null
+++ b/www-client/xombrero/xombrero-9999.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS=git-2
+fi
+
+inherit eutils fdo-mime toolchain-funcs ${GIT_ECLASS}
+
+DESCRIPTION="A minimalist web browser with sophisticated security features designed-in"
+HOMEPAGE="http://opensource.conformal.com/wiki/xombrero"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://opensource.conformal.com/${PN}.git
+ https://opensource.conformal.com/git/${PN}.git"
+ EGIT_SOURCEDIR="${WORKDIR}/${P}"
+ KEYWORDS=""
+else
+ SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libbsd
+ dev-libs/libgcrypt:0
+ net-libs/libsoup
+ net-libs/gnutls
+ net-libs/webkit-gtk:3
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/groff
+ dev-libs/atk
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:0
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/pixman"
+
+S="${WORKDIR}/${P}/linux"
+
+src_prepare() {
+ sed -i \
+ -e 's/-O2//' \
+ -e 's/-ggdb3//' \
+ Makefile || die 'sed Makefile failed.'
+ sed -i \
+ -e 's#https://www\.cyphertite\.com#http://www.gentoo.org/#' \
+ -e "s#/usr/local#/usr#" \
+ ../xombrero.h || die 'sed ../xombrero.c failed.'
+ sed -i \
+ "s#Icon=#Icon=/usr/share/${PN}/#" \
+ ../xombrero.desktop || die 'sed ../xombrero.desktop failed.'
+ sed -i "s:Application;::" ../xombrero.desktop || die
+}
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDADD="${LDFLAGS}" emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ install
+
+ if use examples;then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins \
+ ../${PN}.conf \
+ ../playflash.sh \
+ ../favorites
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}