summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-01-06 17:50:38 -0500
committerMike Gilbert <floppym@gentoo.org>2018-01-06 17:50:38 -0500
commit121cd55193eda4a31bd6e95a6e61d60072fe4abe (patch)
tree8d576bd4ca5376711bf51472039831c797d8b024 /www-client
parentwww-client/chromium: beta channel bump (64.0.3282.71) (diff)
downloadgentoo-121cd55193eda4a31bd6e95a6e61d60072fe4abe.tar.gz
gentoo-121cd55193eda4a31bd6e95a6e61d60072fe4abe.tar.bz2
gentoo-121cd55193eda4a31bd6e95a6e61d60072fe4abe.zip
www-client/chromium: add jumbo-build USE flag
Closes: https://bugs.gentoo.org/641786 Package-Manager: Portage-2.3.19_p3, Repoman-2.3.6_p37
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-64.0.3282.71.ebuild5
-rw-r--r--www-client/chromium/chromium-65.0.3298.3.ebuild5
-rw-r--r--www-client/chromium/metadata.xml1
3 files changed, 9 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-64.0.3282.71.ebuild b/www-client/chromium/chromium-64.0.3282.71.ebuild
index 176c6981bdd0..8ea5262c2e60 100644
--- a/www-client/chromium/chromium-64.0.3282.71.ebuild
+++ b/www-client/chromium/chromium-64.0.3282.71.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="component-build cups gnome-keyring +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
+IUSE="component-build cups gnome-keyring +hangouts jumbo-build kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
COMMON_DEPEND="
@@ -375,6 +375,9 @@ src_configure() {
# for development and debugging.
myconf_gn+=" is_component_build=$(usex component-build true false)"
+ # https://chromium.googlesource.com/chromium/src/+/lkcr/docs/jumbo.md
+ myconf_gn+=" use_jumbo_build=$(usex jumbo-build true false)"
+
myconf_gn+=" use_allocator=$(usex tcmalloc \"tcmalloc\" \"none\")"
# Disable nacl, we can't build without pnacl (http://crbug.com/269560).
diff --git a/www-client/chromium/chromium-65.0.3298.3.ebuild b/www-client/chromium/chromium-65.0.3298.3.ebuild
index 331308682ad9..8094adaa8b14 100644
--- a/www-client/chromium/chromium-65.0.3298.3.ebuild
+++ b/www-client/chromium/chromium-65.0.3298.3.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="component-build cups gnome-keyring +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
+IUSE="component-build cups gnome-keyring +hangouts jumbo-build kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
COMMON_DEPEND="
@@ -378,6 +378,9 @@ src_configure() {
# for development and debugging.
myconf_gn+=" is_component_build=$(usex component-build true false)"
+ # https://chromium.googlesource.com/chromium/src/+/lkcr/docs/jumbo.md
+ myconf_gn+=" use_jumbo_build=$(usex jumbo-build true false)"
+
myconf_gn+=" use_allocator=$(usex tcmalloc \"tcmalloc\" \"none\")"
# Disable nacl, we can't build without pnacl (http://crbug.com/269560).
diff --git a/www-client/chromium/metadata.xml b/www-client/chromium/metadata.xml
index abb4eb267003..9cfaf6c4be53 100644
--- a/www-client/chromium/metadata.xml
+++ b/www-client/chromium/metadata.xml
@@ -9,6 +9,7 @@
<use>
<flag name="component-build">Split build into more shared libraries to speed up linking. Mostly intended for debugging and development, NOT RECOMMENDED for general use.</flag>
<flag name="hangouts">Enable support for Google Hangouts features such as screen sharing</flag>
+ <flag name="jumbo-build">Combine source files to speed up build process.</flag>
<flag name="pic">Disable optimized assembly code that is not PIC friendly</flag>
<flag name="proprietary-codecs">Enable proprietary codecs like H.264, MP3</flag>
<flag name="suid">Build the SUID sandbox, which is only needed on CONFIG_USER_NS=n kernels</flag>