summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-10-25 18:16:56 +0300
committerMart Raudsepp <leio@gentoo.org>2018-10-25 18:27:33 +0300
commit15446efe6573deb73bee6b53a1a85fde732faad5 (patch)
tree3f09c6e5b3690c74b152ba11ba219f37ad390522 /www-client
parentmedia-plugins/gst-plugins-opus: build opusparse from gst-plugins-bad too (diff)
downloadgentoo-15446efe6573deb73bee6b53a1a85fde732faad5.tar.gz
gentoo-15446efe6573deb73bee6b53a1a85fde732faad5.tar.bz2
gentoo-15446efe6573deb73bee6b53a1a85fde732faad5.zip
www-client/epiphany: bump to 3.30.2, handle youtube crasher better
If MSE works (webkit-gtk[gstreamer]), but opusparse is not present, then youtube will crash. Given that we can't yet just depend on new enough opus plugin package revision, add a temporary blocker on the problematic one. Hopefully this will avoid crashers for most people, so we can unmask all this without widespread crashing of epiphany tabs. Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.30.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 981ca3bece21..da35050959ed 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,3 +1,4 @@
DIST epiphany-3.26.7.tar.xz 4429308 BLAKE2B cdd8cf084631891e97585307c90bd67f45e71deb6564f54711deb8dfd39c09007732efeb22ad5be45c1b0af6af7be30cf13a9d90aa1e9506a2e997f6f3f8d854 SHA512 686c8825d476a4c6675dadd7a68bf72727714bc6fe01b4dbf67d39b2dc7e3f21d4f630417865800664a716d6316df8a97fde5201ec72c90f448fd6f0af4b49a0
DIST epiphany-3.30.0.tar.xz 4528508 BLAKE2B 75d605a1117131bebaf0e0a7013ae4e9599b7058e26f4acf84140a6e345255cccac910cc9d5a2f90be0835f7dbaa6c77d16e127dfb5b1ae139ef179a20795444 SHA512 80ba03c67bd467e31e572afd4e8632232bc002c63e584e87bc6c3b74d23cd470f14e696080fd952a8617c6c07202eafff01bc97f72d9a06f0121d75565e667f3
DIST epiphany-3.30.1.tar.xz 4528876 BLAKE2B 1dbb630128a9af975939d386b3113a41ef92ce1bb756a5407a216fa8f25f1dfcd051a11c54a034aeafd8ca5aa5ada7da83f3ecf825370801b04b10b7ef794c80 SHA512 37d6814d9dfb1f70e6cfd3395179b9e213eb79773c1fed238999d5c6ae34c0b93b6f93dff695eb959cb46e89a2cd6b705c1a294d1424c82137ba26d0b7a37503
+DIST epiphany-3.30.2.tar.xz 4528100 BLAKE2B 3b711df8aa3166c26f639658de188e730f346be7c9bdfc65a5064804c1b0e22a744aec6c559c4131125e8fb34e7bb80636f559c7257cca3ad044c6b810bbe657 SHA512 4edaa042357ad44f2069412508cff9524e6e397da868b78768b493d03d77d16807d78f074eb1a4b18fcc1143d3a63d21f3eb1c0f126a31290320016c76c5130e
diff --git a/www-client/epiphany/epiphany-3.30.2.ebuild b/www-client/epiphany/epiphany-3.30.2.ebuild
new file mode 100644
index 000000000000..995b38606697
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.30.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.52.0:2
+ >=x11-libs/gtk+-3.22.13:3
+ >=dev-libs/nettle-3.2:=
+ >=net-libs/webkit-gtk-2.21.92:4=
+ >=x11-libs/cairo-1.2
+ >=dev-libs/libdazzle-3.28.0
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+ !<media-plugins/gst-plugins-opus-1.14.4-r1
+" # Ensure opusparse is present, if gstreamer support is included in webkit
+# paxctl needed for bug #407085
+# appstream-glib needed for appdata.xml gettext translation
+DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-apps/paxctl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Ddistributor_name=Gentoo
+ -Dtech_preview=false
+ $(meson_use test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}