summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-02-21 15:30:10 -0500
committerMike Gilbert <floppym@gentoo.org>2018-02-21 15:31:22 -0500
commit1b8e99b3b294c5df232d8de988c86e90fedbbd16 (patch)
tree7ad5de5db95254073d70d7748b9eba06f3011799 /www-client
parentprofiles/arch/amd64-fbsd: Mask more media-video/ffmpeg flags (diff)
downloadgentoo-1b8e99b3b294c5df232d8de988c86e90fedbbd16.tar.gz
gentoo-1b8e99b3b294c5df232d8de988c86e90fedbbd16.tar.bz2
gentoo-1b8e99b3b294c5df232d8de988c86e90fedbbd16.zip
www-client/chromium: beta channel bump (65.0.3325.73)
Package-Manager: Portage-2.3.24_p18, Repoman-2.3.6_p99
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/Manifest2
-rw-r--r--www-client/chromium/chromium-65.0.3325.73.ebuild (renamed from www-client/chromium/chromium-65.0.3298.3.ebuild)87
-rw-r--r--www-client/chromium/files/chromium-clang-r3.patch11
-rw-r--r--www-client/chromium/files/chromium-math.h-r0.patch29
-rw-r--r--www-client/chromium/files/chromium-stdint.patch21
5 files changed, 110 insertions, 40 deletions
diff --git a/www-client/chromium/Manifest b/www-client/chromium/Manifest
index d4015acc90ea..cddedc5b6dc2 100644
--- a/www-client/chromium/Manifest
+++ b/www-client/chromium/Manifest
@@ -1,3 +1,3 @@
DIST chromium-64.0.3282.167.tar.xz 482246360 BLAKE2B b4785c20f33081015ac31fed9dbd108dc78160d95c4ea7055b8fffdb714fe9ef120727cd6b88d4e4a15b0c429f04c7c512cca90c5313128e0001a4ae5b908b6f SHA512 1bee80d2e8d4332cfc307efdac8eb11a48e42f3927e63e7a9d5ff2bbad6c4534926669f21defbf0553160f5bb28596723be8bd0e3dfa19ca9a1e854bcf42fd77
-DIST chromium-65.0.3298.3.tar.xz 485716108 BLAKE2B 185b3f683b2a732343fa5f98b24171f1d3cf2cf8eeb63c56efa7699f6b038d2a7eea4f9277b0b7ee2fdfa207a4f13edbaf2cc9a591a79ec4d058a131ce44366b SHA512 f1ed9a403036e87da7897f173eeb1aa71fe2650efc5ef5b98f814c7d4d9c879971597f9ded11324c86d6edc7f12f3bcf2786a6fb022e9697dbdb8eae086e18b7
DIST chromium-65.0.3315.3.tar.xz 532475512 BLAKE2B 1a118ddd05f2b939ff0fd84f85e1c22789713351776d889bafb55ddb2b897b2921050a3df3b7d5e3224be84539d95dddce1a27a948c61b29c788ed9f8e194e02 SHA512 c7f0feda90c0df15058473d39482e9b9a9b3236dcb90ff8ba7ad53afde2fce4901b2cbd678d8470560cc0cb6e31c8d3caee9f0a9f100d82d95feacabcdb7f8ce
+DIST chromium-65.0.3325.73.tar.xz 570268564 BLAKE2B 8d1a9cf38f12ea3566463f42772671268de68d8c49170d60733be8eee7492850be739f19377365366740dcbad3414538eb00765281c966b6cedb85b74709448f SHA512 96ed3862c3fc21afac8d18f4b43f98d29a086e83dfe25af54b6358e139a8b3c9ec761cc463ce287b04a9082c5e62dbc605d4c97f8ec358599a24c7830c890418
diff --git a/www-client/chromium/chromium-65.0.3298.3.ebuild b/www-client/chromium/chromium-65.0.3325.73.ebuild
index 33ba5d9ef0ed..10515fc7b763 100644
--- a/www-client/chromium/chromium-65.0.3298.3.ebuild
+++ b/www-client/chromium/chromium-65.0.3325.73.ebuild
@@ -101,6 +101,7 @@ DEPEND="${COMMON_DEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
+ >=sys-devel/clang-5
virtual/pkgconfig
dev-vcs/git
$(python_gen_any_dep '
@@ -149,21 +150,24 @@ PATCHES=(
"${FILESDIR}/chromium-webrtc-r0.patch"
"${FILESDIR}/chromium-memcpy-r0.patch"
"${FILESDIR}/chromium-clang-r2.patch"
- "${FILESDIR}/chromium-gcc-u2f.patch"
+ "${FILESDIR}/chromium-gn-r0.patch"
+ "${FILESDIR}/chromium-math.h-r0.patch"
+ "${FILESDIR}/chromium-clang-r3.patch"
+ "${FILESDIR}/chromium-stdint.patch"
)
pre_build_checks() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- local -x CPP="$(tc-getCXX) -E"
- if tc-is-clang && ! version_is_at_least "3.9.1" "$(clang-fullversion)"; then
- # bugs: #601654
- die "At least clang 3.9.1 is required"
- fi
- if tc-is-gcc && ! version_is_at_least 5.0 "$(gcc-version)"; then
- # bugs: #535730, #525374, #518668, #600288, #627356
- die "At least gcc 5.0 is required"
- fi
- fi
+ #if [[ ${MERGE_TYPE} != binary ]]; then
+ # local -x CPP="$(tc-getCXX) -E"
+ # if tc-is-clang && ! version_is_at_least "3.9.1" "$(clang-fullversion)"; then
+ # # bugs: #601654
+ # die "At least clang 3.9.1 is required"
+ # fi
+ # if tc-is-gcc && ! version_is_at_least 5.0 "$(gcc-version)"; then
+ # # bugs: #535730, #525374, #518668, #600288, #627356
+ # die "At least gcc 5.0 is required"
+ # fi
+ #fi
# Check build requirements, bug #541816 and bug #471810 .
CHECKREQS_MEMORY="3G"
@@ -262,7 +266,6 @@ src_prepare() {
third_party/libXNVCtrl
third_party/libaddressinput
third_party/libaom
- third_party/libaom/source/libaom/third_party/x86inc
third_party/libjingle
third_party/libphonenumber
third_party/libsecret
@@ -271,6 +274,7 @@ src_prepare() {
third_party/libwebm
third_party/libxml/chromium
third_party/libyuv
+ third_party/llvm
third_party/lss
third_party/lzma_sdk
third_party/markupsafe
@@ -371,6 +375,32 @@ src_configure() {
local myconf_gn=""
+ # Make sure the build system will use the right tools, bug #340795.
+ tc-export AR CC CXX NM
+
+ if ! tc-is-clang; then
+ # Force clang since gcc is pretty broken at the moment.
+ CC=clang
+ CXX=clang++
+ fi
+
+ if tc-is-clang; then
+ myconf_gn+=" is_clang=true clang_use_chrome_plugins=false"
+ else
+ myconf_gn+=" is_clang=false"
+ fi
+
+ # Define a custom toolchain for GN
+ myconf_gn+=" custom_toolchain=\"//build/toolchain/linux/unbundle:default\""
+
+ if tc-is-cross-compiler; then
+ tc-export BUILD_{AR,CC,CXX,NM}
+ myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:host\""
+ myconf_gn+=" v8_snapshot_toolchain=\"//build/toolchain/linux/unbundle:host\""
+ else
+ myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:default\""
+ fi
+
# GN needs explicit config for Debug/Release as opposed to inferring it from build directory.
myconf_gn+=" is_debug=false"
@@ -431,7 +461,6 @@ src_configure() {
myconf_gn+=" enable_hangout_services_extension=$(usex hangouts true false)"
myconf_gn+=" enable_widevine=$(usex widevine true false)"
myconf_gn+=" use_cups=$(usex cups true false)"
- myconf_gn+=" use_gconf=false"
myconf_gn+=" use_gnome_keyring=$(usex gnome-keyring true false)"
myconf_gn+=" use_kerberos=$(usex kerberos true false)"
myconf_gn+=" use_pulseaudio=$(usex pulseaudio true false)"
@@ -440,12 +469,6 @@ src_configure() {
myconf_gn+=" fieldtrial_testing_like_official_build=true"
- if tc-is-clang; then
- myconf_gn+=" is_clang=true clang_use_chrome_plugins=false"
- else
- myconf_gn+=" is_clang=false"
- fi
-
# Never use bundled gold binary. Disable gold linker flags for now.
# Do not use bundled clang.
# Trying to use gold results in linker crash.
@@ -510,22 +533,8 @@ src_configure() {
fi
fi
- # Make sure the build system will use the right tools, bug #340795.
- tc-export AR CC CXX NM
-
- # Define a custom toolchain for GN
- myconf_gn+=" custom_toolchain=\"//build/toolchain/linux/unbundle:default\""
-
- if tc-is-cross-compiler; then
- tc-export BUILD_{AR,CC,CXX,NM}
- myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:host\""
- myconf_gn+=" v8_snapshot_toolchain=\"//build/toolchain/linux/unbundle:host\""
- else
- myconf_gn+=" host_toolchain=\"//build/toolchain/linux/unbundle:default\""
- fi
-
# https://bugs.gentoo.org/588596
- append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+ #append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
# Bug 491582.
export TMPDIR="${WORKDIR}/temp"
@@ -559,6 +568,8 @@ src_compile() {
# Calling this here supports resumption via FEATURES=keepwork
python_setup
+ #"${EPYTHON}" tools/clang/scripts/update.py --force-local-build --gcc-toolchain /usr --skip-checkout --use-system-cmake --without-android || die
+
# Build mksnapshot and pax-mark it.
local x
for x in mksnapshot v8_context_snapshot_generator; do
@@ -632,10 +643,8 @@ src_install() {
doins -r out/Release/locales
doins -r out/Release/resources
- if [[ -d out/Release/swiftshader ]]; then
- insinto "${CHROMIUM_HOME}/swiftshader"
- doins out/Release/swiftshader/*.so
- fi
+ insinto "${CHROMIUM_HOME}/swiftshader"
+ doins out/Release/swiftshader/*.so
# Install icons and desktop entry.
local branding size
diff --git a/www-client/chromium/files/chromium-clang-r3.patch b/www-client/chromium/files/chromium-clang-r3.patch
new file mode 100644
index 000000000000..3905a5f03ffc
--- /dev/null
+++ b/www-client/chromium/files/chromium-clang-r3.patch
@@ -0,0 +1,11 @@
+--- a/device/u2f/u2f_ble_transaction.cc
++++ b/device/u2f/u2f_ble_transaction.cc
+@@ -131,7 +131,7 @@
+
+ void U2fBleTransaction::OnError() {
+ request_frame_.reset();
+- request_cont_fragments_ = {};
++ request_cont_fragments_ = base::queue<U2fBleFrameContinuationFragment>();
+ response_frame_assembler_.reset();
+ std::move(callback_).Run(base::nullopt);
+ }
diff --git a/www-client/chromium/files/chromium-math.h-r0.patch b/www-client/chromium/files/chromium-math.h-r0.patch
new file mode 100644
index 000000000000..6c7c747053a1
--- /dev/null
+++ b/www-client/chromium/files/chromium-math.h-r0.patch
@@ -0,0 +1,29 @@
+From 9f63f94a11abc34d40ede8b8712fa15b5844a8c0 Mon Sep 17 00:00:00 2001
+From: Tom Anderson <thomasanderson@chromium.org>
+Date: Sat, 27 Jan 2018 20:03:37 +0000
+Subject: [PATCH] Fix build with glibc 2.27
+
+BUG=806340
+TBR=hamelphi@chromium.org
+
+Change-Id: Ib4e5091212d874d9ad88f3e9a1fdfee3ed7e0d5e
+Reviewed-on: https://chromium-review.googlesource.com/890059
+Reviewed-by: Thomas Anderson <thomasanderson@chromium.org>
+Reviewed-by: Philippe Hamel <hamelphi@chromium.org>
+Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#532249}
+---
+
+diff --git a/components/assist_ranker/ranker_example_util.cc b/components/assist_ranker/ranker_example_util.cc
+index 54d4dbd..ceedd8f 100644
+--- a/components/assist_ranker/ranker_example_util.cc
++++ b/components/assist_ranker/ranker_example_util.cc
+@@ -2,6 +2,8 @@
+ // Use of this source code is governed by a BSD-style license that can be
+ // found in the LICENSE file.
+
++#include <math.h>
++
+ #include "components/assist_ranker/ranker_example_util.h"
+ #include "base/bit_cast.h"
+ #include "base/format_macros.h"
diff --git a/www-client/chromium/files/chromium-stdint.patch b/www-client/chromium/files/chromium-stdint.patch
new file mode 100644
index 000000000000..877443954faa
--- /dev/null
+++ b/www-client/chromium/files/chromium-stdint.patch
@@ -0,0 +1,21 @@
+From 0235c2b657d936f3cdb09053776e5929fc84704b Mon Sep 17 00:00:00 2001
+From: Tomas Popela <tomas.popela@gmail.com>
+Date: Wed, 31 Jan 2018 18:57:07 +0000
+Subject: [PATCH] Add missing stdint include
+
+diff --git a/chrome/browser/vr/sample_queue.cc b/chrome/browser/vr/sample_queue.cc
+index c2ca777ce90c..53cb3aab1576 100644
+--- a/chrome/browser/vr/sample_queue.cc
++++ b/chrome/browser/vr/sample_queue.cc
+@@ -2,6 +2,8 @@
+ // Use of this source code is governed by a BSD-style license that can be
+ // found in the LICENSE file.
+
++#include <stdint.h>
++
+ #include "chrome/browser/vr/sample_queue.h"
+
+ namespace vr {
+--
+2.16.2
+