summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDion Moult <moult@gentoo.org>2015-09-27 09:28:19 +1000
committerDion Moult <moult@gentoo.org>2015-09-27 09:28:19 +1000
commit29576cc6a591b109f32119dd8e2240dd863b9d05 (patch)
treeb4d3a9d9ec736e6c8b4a88e602fec144b0997d68 /www-client
parentRevert "profiles: mask app-cdr/nero for removal. Bug #510594" (diff)
downloadgentoo-29576cc6a591b109f32119dd8e2240dd863b9d05.tar.gz
gentoo-29576cc6a591b109f32119dd8e2240dd863b9d05.tar.bz2
gentoo-29576cc6a591b109f32119dd8e2240dd863b9d05.zip
www-client/phantomjs: Add GCC compilation patch
Package-Manager: portage-2.2.15
Diffstat (limited to 'www-client')
-rw-r--r--www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch14
-rw-r--r--www-client/phantomjs/phantomjs-2.0.0.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch b/www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch
new file mode 100644
index 000000000000..7191050f265b
--- /dev/null
+++ b/www-client/phantomjs/files/phantomjs-gcc5-compile-fix.patch
@@ -0,0 +1,14 @@
+--- a/src/qt/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp 2015-01-24 08:19:52.000000000 +0600
++++ b/src/qt/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp 2015-09-24 18:18:45.598322592 +0600
+@@ -1909,6 +1909,11 @@
+ }
+ }
+
++// Used in JSArray.cpp so we must instantiate explicit
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<Int32Shape>(ExecState* exec, unsigned i, JSValue value);
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<DoubleShape>(ExecState* exec, unsigned i, JSValue value);
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<ContiguousShape>(ExecState* exec, unsigned i, JSValue value);
++
+ void JSObject::putByIndexBeyondVectorLengthWithArrayStorage(ExecState* exec, unsigned i, JSValue value, bool shouldThrow, ArrayStorage* storage)
+ {
+ VM& vm = exec->vm();
diff --git a/www-client/phantomjs/phantomjs-2.0.0.ebuild b/www-client/phantomjs/phantomjs-2.0.0.ebuild
index 6b6a81d69de6..e52d78f5893c 100644
--- a/www-client/phantomjs/phantomjs-2.0.0.ebuild
+++ b/www-client/phantomjs/phantomjs-2.0.0.ebuild
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/phantomjs-python3-udis86-itab.patch"
+ epatch "${FILESDIR}/phantomjs-gcc5-compile-fix.patch"
# Respect CC, CXX, {C,CXX,LD}FLAGS in .qmake.cache
sed -i \