summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 13:42:59 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 13:42:59 +0100
commit3e12336e466da295ad761f4c9c29418a44110376 (patch)
treea5c3f8c57b5c025342e28acde0a0ae7323dcf0ea /www-client
parentwww-client/uget: Port to EAPI 7 (diff)
downloadgentoo-3e12336e466da295ad761f4c9c29418a44110376.tar.gz
gentoo-3e12336e466da295ad761f4c9c29418a44110376.tar.bz2
gentoo-3e12336e466da295ad761f4c9c29418a44110376.zip
www-client/uget: sync live ebuild
Closes: https://github.com/gentoo/gentoo/pull/18471 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/uget/uget-9999.ebuild31
1 files changed, 9 insertions, 22 deletions
diff --git a/www-client/uget/uget-9999.ebuild b/www-client/uget/uget-9999.ebuild
index a713a776b893..15ba6ecf8dde 100644
--- a/www-client/uget/uget-9999.ebuild
+++ b/www-client/uget/uget-9999.ebuild
@@ -1,24 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
-inherit gnome2-utils xdg-utils git-r3 autotools
+inherit autotools git-r3 xdg
DESCRIPTION="Download manager using gtk+ and libcurl"
HOMEPAGE="http://www.ugetdm.com"
-SRC_URI=""
EGIT_REPO_URI="git://git.code.sf.net/p/urlget/uget2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
IUSE="aria2 appindicator control-socket +gnutls gstreamer libnotify nls openssl rss"
RDEPEND="
- >=net-misc/curl-7.19.1
+ dev-libs/glib:2
dev-libs/libpcre
- >=dev-libs/glib-2.32:2
+ net-misc/curl
>=x11-libs/gtk+-3.4:3
gnutls? (
net-libs/gnutls
@@ -27,16 +25,15 @@ RDEPEND="
aria2? ( net-misc/aria2[xmlrpc] )
appindicator? ( dev-libs/libappindicator:3 )
gstreamer? ( media-libs/gstreamer:1.0 )
- libnotify? ( x11-libs/libnotify )
- "
-DEPEND="${RDEPEND}
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/intltool
virtual/pkgconfig
- sys-devel/gettext
- "
+ sys-devel/gettext"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
@@ -55,13 +52,3 @@ src_configure() {
econf "${myconf[@]}"
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}