summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-19 12:18:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-19 12:29:51 +0100
commit54235cf970c83542185f9091b242d1685f4da885 (patch)
tree0919c1758f0baac1605c53938a9e58b90d8ce7bb /www-client
parentwww-client/weboob: EAPI 6, switch to PyQt5, git-r3, add USE=deprecated (diff)
downloadgentoo-54235cf970c83542185f9091b242d1685f4da885.tar.gz
gentoo-54235cf970c83542185f9091b242d1685f4da885.tar.bz2
gentoo-54235cf970c83542185f9091b242d1685f4da885.zip
www-client/weboob: 1.3 version bump
Thanks-to: Laurent Bachelier <laurent@bachelier.name> Bug: https://bugs.gentoo.org/510810 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-client')
-rw-r--r--www-client/weboob/Manifest1
-rw-r--r--www-client/weboob/weboob-1.3.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/www-client/weboob/Manifest b/www-client/weboob/Manifest
index 7042dc2313fe..848c92bf0a38 100644
--- a/www-client/weboob/Manifest
+++ b/www-client/weboob/Manifest
@@ -1,2 +1,3 @@
DIST weboob-0.g.tar.gz 1465176 BLAKE2B 8b6efeb14e2233957844319de55c3f78665f89f95e88017bbbec983d1dc9525035a5d83fe5465d817d75267b1a8e5abcda5f0bc2c8c687100194f5c1d49ec03b SHA512 802b0f4cb10d1c2a13dc183d59aa642a9642b3b8f9417ce7bf66835a5f7028bc3fde9a8f3048b01cd5601585d37e6c95fa277b768723d05ab1b8eb4cb74a40bc
DIST weboob-0.h.tar.gz 1700259 BLAKE2B e6971c8b498dd0478177334c42a39e871ee79c0171e33e7e7c8401cebfe7ea38dd7ca013b6eaa705ba5e422cf55292b8db8bc5deddce007827b3ef3af3ec7c0f SHA512 9ec34d184f965ec9124e7cb7e40e9337f781e2d79171fdc2f48b20d68bc21b8cabb349b56229b97f86257edb1d9f24886cbe3576a0fc80ed4440168119ea7e2b
+DIST weboob-1.3.tar.gz 2688899 BLAKE2B a75a854137b117fd228959a6c5d19e93c5a0520a8e88227e2d6e8bf13795b2d3ba51173307563b5704be68fe680dd3573fc3b7308e29d422bc9ee6e3d4adaaa7 SHA512 c56704b9fc0d21c5d2b4d297f677f01d25d523c3d45acf7ed0b241fccd4b2477ddb60e58d2dd68886858dc8a50faa43d533c808b106546180552babf9c07543c
diff --git a/www-client/weboob/weboob-1.3.ebuild b/www-client/weboob/weboob-1.3.ebuild
new file mode 100644
index 000000000000..13f4e208d435
--- /dev/null
+++ b/www-client/weboob/weboob-1.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2010-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl"
+
+EGIT_BASE="devel"
+if [[ ${PV} == *999* ]]; then
+ [[ ${PV} == 9998 ]] && EGIT_BASE="stable"
+ GIT_SCM=git-r3
+ SRC_URI=""
+else
+ REDMINE_ID="356"
+ SRC_URI="https://symlink.me/attachments/download/${REDMINE_ID}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+EGIT_REPO_URI="https://git.weboob.org/${PN}/${EGIT_BASE}.git"
+inherit distutils-r1 gnome2-utils ${GIT_SCM}
+unset EGIT_BASE GIT_SCM
+
+DESCRIPTION="Consume lots of websites without a browser (Web Outside Of Browsers)"
+HOMEPAGE="http://weboob.org/"
+
+LICENSE="AGPL-3"
+SLOT="0"
+IUSE="+deprecated fast-libs +secure-updates X"
+
+COMMON_DEPEND="
+ X? ( dev-python/PyQt5[multimedia,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/html2text[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP},ssl]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ deprecated? ( dev-python/mechanize[${PYTHON_USEDEP}] )
+ fast-libs? (
+ dev-python/pyyaml[libyaml,${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+ secure-updates? ( app-crypt/gnupg )
+ X? ( dev-python/google-api-python-client[${PYTHON_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+
+ if [[ -L contrib/webextension-session-importer/logo.png ]]; then
+ cp -L contrib/webextension-session-importer/logo.png logo.tmp.png || die
+ rm contrib/webextension-session-importer/logo.png || die
+ mv logo.tmp.png contrib/webextension-session-importer/logo.png || die
+ fi
+}
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex X '--qt' '--no-qt')
+ $(usex X '--xdg' '--no-xdg')
+ )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${PN}/
+ doins -r contrib
+}
+
+pkg_preinst() {
+ use X && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use X && gnome2_icon_cache_update
+ elog 'You should now run "weboob-config update" (as your login user).'
+}
+
+pkg_postrm() {
+ use X && gnome2_icon_cache_update
+}