summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-18 01:34:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-18 19:22:12 -0400
commit59f5a7a6520eafedacc453910fb7f5f13c5ccb9e (patch)
tree4fd616a6f1ad464affada8d82668df04768f82f8 /www-client
parentwww-client/qutebrowser: update live (diff)
downloadgentoo-59f5a7a6520eafedacc453910fb7f5f13c5ccb9e.tar.gz
gentoo-59f5a7a6520eafedacc453910fb7f5f13c5ccb9e.tar.bz2
gentoo-59f5a7a6520eafedacc453910fb7f5f13c5ccb9e.zip
www-client/qutebrowser: warn in 2.5.4 if downgrade from Qt6
Should have very few users actually using Qt6 (USE is masked, and ebuilds are unkeyworded), but given removed the _pre ebuild it's possible it'll cause an unexpected downgrade and it wouldn't hurt to warn (albeit should be fairly noticeable given the deps pulled are non-trivial). Switching will be less of a worry in qutebrowser-3.0.0 given it can detect a mismatch on startup, but the old 2.5.4 is oblivious. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.4.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.5.4.ebuild b/www-client/qutebrowser/qutebrowser-2.5.4.ebuild
index 30a3498c8cf8..59de8c56dd4a 100644
--- a/www-client/qutebrowser/qutebrowser-2.5.4.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.5.4.ebuild
@@ -131,6 +131,12 @@ python_install_all() {
einstalldocs
}
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ has_version "${CATEGORY}/${PN}[qt6]" && QUTEBROWSER_HAD_QT6=
+}
+
pkg_postinst() {
xdg_pkg_postinst
@@ -139,4 +145,13 @@ pkg_postinst() {
elog "have additional dependencies not covered by this ebuild, for example"
elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
fi
+
+ if [[ -v QUTEBROWSER_HAD_QT6 ]]; then
+ ewarn "This is a downgrade from Qt6-based ${PN} to Qt5-based, and this"
+ ewarn "older version of ${PN} will /not/ warn on startup that this is"
+ ewarn "going to destroy some browsing data (e.g. cookies) when older chromium"
+ ewarn "version tries to use the newer ~/.local/share/${PN}/webengine."
+ ewarn
+ ewarn "It is recommended to backup in case or go back to Qt6."
+ fi
}