summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-20 15:45:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-20 15:46:09 +0200
commit65deeb03c3f06717dd747889a076d14fc2356f63 (patch)
tree16e5ed36d4f9185f99a211a2c3e19e4f3e14fa70 /www-client
parentwww-client/firefox: check requirements only for non-binary merges (diff)
downloadgentoo-65deeb03c3f06717dd747889a076d14fc2356f63.tar.gz
gentoo-65deeb03c3f06717dd747889a076d14fc2356f63.tar.bz2
gentoo-65deeb03c3f06717dd747889a076d14fc2356f63.zip
www-client/firefox: check rust version in pkg_pretend
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-68.10.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-68.10.0.ebuild b/www-client/firefox/firefox-68.10.0.ebuild
index 87f57c81205d..9afc1bda5078 100644
--- a/www-client/firefox/firefox-68.10.0.ebuild
+++ b/www-client/firefox/firefox-68.10.0.ebuild
@@ -229,6 +229,15 @@ llvm_check_deps() {
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]] ; then
+ local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
+ rustc_version=${rustc_version[0]/rust-bin-/}
+ rustc_version=${rustc_version/rust-/}
+ [[ -z "${rustc_version}" ]] && die "Failed to determine rustc version!"
+
+ if ver_test "${rustc_version}" -ge "1.45.0" ; then
+ die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ fi
+
if use pgo ; then
if ! has usersandbox $FEATURES ; then
die "You must enable usersandbox as X server can not run as root!"