summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-13 16:06:17 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-13 16:06:17 -0500
commit78047b6f5c093fdfaa64c19f47798fcb1b5591d4 (patch)
treecaaa266a382ddb22ab9ef8def4d9a952ce7a35c2 /www-client
parentwww-client/chromium: depend on newer harfbuzz (diff)
downloadgentoo-78047b6f5c093fdfaa64c19f47798fcb1b5591d4.tar.gz
gentoo-78047b6f5c093fdfaa64c19f47798fcb1b5591d4.tar.bz2
gentoo-78047b6f5c093fdfaa64c19f47798fcb1b5591d4.zip
www-client/chromium: fix null pointer deref in V8 with gcc-6
Bug: https://bugs.gentoo.org/588596 Package-Manager: portage-2.3.2_p5
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-54.0.2840.100.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-54.0.2840.100.ebuild b/www-client/chromium/chromium-54.0.2840.100.ebuild
index ec95879295c9..3c2597fd1309 100644
--- a/www-client/chromium/chromium-54.0.2840.100.ebuild
+++ b/www-client/chromium/chromium-54.0.2840.100.ebuild
@@ -538,6 +538,9 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
+ # https://bugs.gentoo.org/588596
+ append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+
# Define a custom toolchain for GN
myconf_gn+=" custom_toolchain=\"${FILESDIR}/toolchain:default\""