summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-01-08 14:21:35 -0500
committerIan Stakenvicius <axs@gentoo.org>2018-01-08 14:21:55 -0500
commitda3156b09574679cf1fcb885dd5e441e21800905 (patch)
tree5da3b95b7b4a12c0e17936f55abe7830cfa3a1c4 /www-client
parentx11-terms/gnome-terminal: remove some unnecessary USE requirements on depende... (diff)
downloadgentoo-da3156b09574679cf1fcb885dd5e441e21800905.tar.gz
gentoo-da3156b09574679cf1fcb885dd5e441e21800905.tar.bz2
gentoo-da3156b09574679cf1fcb885dd5e441e21800905.zip
www-client/firefox-bin: don't hardcode 'lib/' in GTK_LIBS assignment
Until now, the 'firefox-bin' wrapper hard-coded the path to GTK_LIBS to /usr/lib/gtk-3.0 ; this patch uses get_libdir to ensure the proper value for 'lib' is assigned instead. Required for SYMLINK_LIB=no in the 17.1 profiles. Bug: http://bugs.gentoo.org/643798 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox-bin/firefox-bin-52.5.3-r1.ebuild (renamed from www-client/firefox-bin/firefox-bin-52.5.3.ebuild)2
-rw-r--r--www-client/firefox-bin/firefox-bin-57.0.4-r1.ebuild (renamed from www-client/firefox-bin/firefox-bin-57.0.4.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/www-client/firefox-bin/firefox-bin-52.5.3.ebuild b/www-client/firefox-bin/firefox-bin-52.5.3-r1.ebuild
index 76afcebbc277..fe974f2962aa 100644
--- a/www-client/firefox-bin/firefox-bin-52.5.3.ebuild
+++ b/www-client/firefox-bin/firefox-bin-52.5.3-r1.ebuild
@@ -140,7 +140,7 @@ src_install() {
#!/bin/sh
unset LD_PRELOAD
LD_LIBRARY_PATH="${apulselib}/opt/firefox/" \\
- GTK_PATH=/usr/lib/gtk-3.0/ \\
+ GTK_PATH=/usr/$(get_libdir)/gtk-3.0/ \\
exec /opt/${MOZ_PN}/${MOZ_PN} "\$@"
EOF
fperms 0755 /usr/bin/${PN}
diff --git a/www-client/firefox-bin/firefox-bin-57.0.4.ebuild b/www-client/firefox-bin/firefox-bin-57.0.4-r1.ebuild
index 67998ff7ceb0..e3d638ecc9df 100644
--- a/www-client/firefox-bin/firefox-bin-57.0.4.ebuild
+++ b/www-client/firefox-bin/firefox-bin-57.0.4-r1.ebuild
@@ -139,7 +139,7 @@ src_install() {
#!/bin/sh
unset LD_PRELOAD
LD_LIBRARY_PATH="${apulselib}/opt/firefox/" \\
- GTK_PATH=/usr/lib/gtk-3.0/ \\
+ GTK_PATH=/usr/$(get_libdir)/gtk-3.0/ \\
exec /opt/${MOZ_PN}/${MOZ_PN} "\$@"
EOF
fperms 0755 /usr/bin/${PN}