summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Hajdan, Jr <phajdan.jr@gentoo.org>2017-01-03 21:42:01 +0000
committerPawel Hajdan, Jr <phajdan.jr@gentoo.org>2017-01-03 22:45:15 +0100
commite7b214d802b93e71f715298bcaffc1590541bca6 (patch)
treefaf2137b9dc66d735f7112a213617f9139695746 /www-client
parentdev-python/path-py: unset XDG_CONFIG_HOME for tests (diff)
downloadgentoo-e7b214d802b93e71f715298bcaffc1590541bca6.tar.gz
gentoo-e7b214d802b93e71f715298bcaffc1590541bca6.tar.bz2
gentoo-e7b214d802b93e71f715298bcaffc1590541bca6.zip
www-client/chromium: add support for component build
This addresses bug #601590 by David Kredba .
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-57.0.2950.4.ebuild9
-rw-r--r--www-client/chromium/metadata.xml1
2 files changed, 8 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-57.0.2950.4.ebuild b/www-client/chromium/chromium-57.0.2950.4.ebuild
index 1da0e2c5115a..04ae77e145b0 100644
--- a/www-client/chromium/chromium-57.0.2950.4.ebuild
+++ b/www-client/chromium/chromium-57.0.2950.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,7 +18,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="cups gnome gnome-keyring gtk3 +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +tcmalloc widevine"
+IUSE="component-build cups gnome gnome-keyring gtk3 +hangouts kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -340,6 +340,10 @@ src_configure() {
# GN needs explicit config for Debug/Release as opposed to inferring it from build directory.
myconf_gn+=" is_debug=false"
+ # Component build isn't generally intended for use by end users. It's mostly useful
+ # for development and debugging.
+ myconf_gn+=" is_component_build=$(usex component-build true false)"
+
# Disable nacl, we can't build without pnacl (http://crbug.com/269560).
myconf_gn+=" enable_nacl=false"
@@ -579,6 +583,7 @@ src_install() {
insinto "${CHROMIUM_HOME}"
doins out/Release/*.bin
doins out/Release/*.pak
+ doins out/Release/*.so
# Needed by bundled icu
doins out/Release/icudtl.dat
diff --git a/www-client/chromium/metadata.xml b/www-client/chromium/metadata.xml
index 008a4e4a01de..cbab844193a6 100644
--- a/www-client/chromium/metadata.xml
+++ b/www-client/chromium/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<longdescription>Chromium is the open-source web browser project behind Google Chrome</longdescription>
<use>
+ <flag name="component-build">Split build into more shared libraries to speed up linking. Mostly intended for debugging and development, NOT RECOMMENDED for general use.</flag>
<flag name="gn">Use GN (generate ninja) instead of GYP for building</flag>
<flag name="gtk3">Use gtk3 instead of gtk2</flag>
<flag name="hangouts">Enable support for Google Hangouts features such as screen sharing</flag>