summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-18 05:02:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-18 05:25:48 -0400
commitef432eb511d6bf24fdf1385adc3545ea77f9bd67 (patch)
treea63602ac0014db28ad969ec4af7c6bc6e71e23b0 /www-client
parentx11-terms/kitty-shell-integration: drop 0.25.1 (diff)
downloadgentoo-ef432eb511d6bf24fdf1385adc3545ea77f9bd67.tar.gz
gentoo-ef432eb511d6bf24fdf1385adc3545ea77f9bd67.tar.bz2
gentoo-ef432eb511d6bf24fdf1385adc3545ea77f9bd67.zip
www-client/qutebrowser: drop 2.5.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/Manifest1
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.0.ebuild122
2 files changed, 0 insertions, 123 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index 3dde123518cc..6e8d0cec438b 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,2 +1 @@
-DIST qutebrowser-2.5.0.tar.gz 6086105 BLAKE2B c95afbbdfeebe4352e461cef78d499e9efa9de2e4acc2cedf350904bd617a4f238c34042369655030e53433f941288ff676f8ffd873683939ddd38ff01604aa1 SHA512 41ab6f6d2b72c94e0f66ba0a80999d820748d0f86dbec92583a2be88725f1ebd7517dd75edbaa0ce60bc029ed4dc0dd3e30a1cb25ab4ef940b968c87b4df2472
DIST qutebrowser-2.5.1.tar.gz 6089389 BLAKE2B e26be42742795b22c34d131a5c9046e0223cef2fd461d8aa3c656a8182bf0127e17e55a7e0a79e1ade76c883094d841a822864e995365b0217ef1b422272e6e0 SHA512 27eca3e987e4c2a662fc863840d3ea697da65f55c7b9180e892466aeb5a2753f1eca424bbf8705670fe8cd9363e3297e03f9f9cc0d4f85f0198a4e3312d32f3c
diff --git a/www-client/qutebrowser/qutebrowser-2.5.0.ebuild b/www-client/qutebrowser/qutebrowser-2.5.0.ebuild
deleted file mode 100644
index 7d651f4ce4d0..000000000000
--- a/www-client/qutebrowser/qutebrowser-2.5.0.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 optfeature xdg
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/qutebrowser/qutebrowser.git"
-else
- SRC_URI="https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~x86"
-fi
-
-DESCRIPTION="Keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
-HOMEPAGE="https://www.qutebrowser.org/"
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="+adblock widevine"
-
-RDEPEND="
- dev-qt/qtcore:5[icu]
- dev-qt/qtgui:5[png]
- $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
- $(python_gen_cond_dep '
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP},libyaml(+)]
- dev-python/zipp[${PYTHON_USEDEP}]
- adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )')
- widevine? ( www-plugins/chrome-binary-plugins )"
-BDEPEND="
- $(python_gen_cond_dep '
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-bdd[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xvfb[${PYTHON_USEDEP}]
- dev-python/tldextract[${PYTHON_USEDEP}]
- )')"
-[[ ${PV} != 9999 ]] || BDEPEND+=" app-text/asciidoc"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- if use widevine; then
- local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
- sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
- -i ${PN}/config/qtargs.py || die
- fi
-
- # let eclass handle python
- sed -i '/setup.py/d' misc/Makefile || die
-
- [[ ${PV} != 9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
-
- # these plugins/tests are unnecessary here and have extra dependencies
- sed -e '/pytest-benchmark/d;s/--benchmark[^ ]*//' \
- -e '/pytest-instafail/d;s/--instafail//' \
- -i pytest.ini || die
- [[ ${PV} == 9999 ]] || rm tests/unit/scripts/test_problemmatchers.py || die
- [[ ${PV} != 9999 ]] || rm tests/unit/scripts/test_run_vulture.py || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # end2end and other IPC tests are broken with "Name error" if
- # socket path is over 104 characters (=124 in /var/tmp/portage)
- # https://github.com/qutebrowser/qutebrowser/issues/888 (not just OSX)
- tests/end2end
- tests/unit/misc/test_ipc.py
- # tests that don't know about our newer qtwebengine
- tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
- tests/unit/utils/test_version.py::TestChromiumVersion
- # may misbehave depending on installed old python versions
- tests/unit/misc/test_checkpyver.py::test_old_python
- # bug 819393
- tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
- )
- use widevine && EPYTEST_DESELECT+=( tests/unit/config/test_qtargs.py )
-
- # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
- epytest -k 'not _bench and not _matches_tree and not _warning'
-}
-
-python_install_all() {
- emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
-
- rm "${ED}"/usr/share/${PN}/scripts/{mkvenv,utils}.py || die
- fperms -x /usr/share/${PN}/{scripts/cycle-inputs.js,userscripts/README.md}
- python_fix_shebang "${ED}"/usr/share/${PN}
-
- einstalldocs
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "PDF display support" www-plugins/pdfjs
-
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
- elog "have additional dependencies not covered by this ebuild, for example"
- elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
- fi
-}