summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-12-17 00:04:29 +0200
committerMart Raudsepp <leio@gentoo.org>2021-12-17 00:04:29 +0200
commitf58a6314f5c381734b3d5ad8a339344211db72a4 (patch)
treedb6560d075958ab7ee1dceed6e4056fa39899d1e /www-client
parentdev-util/cmake: Stabilize 3.21.4 ppc, #829333 (diff)
downloadgentoo-f58a6314f5c381734b3d5ad8a339344211db72a4.tar.gz
gentoo-f58a6314f5c381734b3d5ad8a339344211db72a4.tar.bz2
gentoo-f58a6314f5c381734b3d5ad8a339344211db72a4.zip
www-client/epiphany: security bump to 40.5
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-40.5.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 73522be10ea2..3fe12d06f036 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-40.2.tar.xz 5372180 BLAKE2B cd75f645980c37b0cdd92133505cf7961168bf5d67ad0bdf3140f155c737a070f7ffafa63bb8a0e5de175826b79b2ca380a2851e7f1f0454d4f372d48f48c9c7 SHA512 29a5b7e65f7e5decb3c370fc9ae654727cce30f397ffd3289a9f77f3527f0471c821e3bea0f1a5ab9c1ab44e670898b46e66e41de5cb8c76fabd23b135a4a1a9
DIST epiphany-40.3.tar.xz 5379072 BLAKE2B d0b2ecd5db6953261efe6658fe60798b93b6589e1c79032f659a3d69dcf1e2ed77156bf46768c2891916a48f9a28474f8690e451c8631a0455f06d525f9349b5 SHA512 86d896142171f50d0375c4efec370986741d89f341b613c137fb4719ba5359a9e5523e52635c4bcc9ac7acf96f2276486d878d5ed44a57bc1c8124a01af2d30d
+DIST epiphany-40.5.tar.xz 5380340 BLAKE2B 60dcdacd8fc199e68d2009c841e5d80e54c6246b9f39f9d6523fb8dcd837dba4a949911643c634abb5c53e08473e92b5bde90709ec8650cc23c4aceaeac14edd SHA512 939fc749723c87457a73b90fadb37e8c6db0996ada73d5c859ff3f9b8a2401bca369a8145336542a169b006a9c0e02f6642a1a39b3770654d30cb28b55e69972
diff --git a/www-client/epiphany/epiphany-40.5.ebuild b/www-client/epiphany/epiphany-40.5.ebuild
new file mode 100644
index 000000000000..8b06f903df9e
--- /dev/null
+++ b/www-client/epiphany/epiphany-40.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.31.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.1.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}