summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmertt3@gmail.com>2020-04-05 23:59:31 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-04-10 10:10:35 +0300
commit6648b5fe6394251059ebc8a4f2d3514b5ba252b4 (patch)
tree0211d4534a51187fd5b5b31692e26e6d29be5810 /www-misc/buku/buku-3.7.ebuild
parentapp-backup/mkstage4: call einstalldocs (diff)
downloadgentoo-6648b5fe6394251059ebc8a4f2d3514b5ba252b4.tar.gz
gentoo-6648b5fe6394251059ebc8a4f2d3514b5ba252b4.tar.bz2
gentoo-6648b5fe6394251059ebc8a4f2d3514b5ba252b4.zip
www-misc/buku: Remove versions 3.{5,6,7}
Signed-off-by: John Helmert III <jchelmertt3@gmail.com> Package-Manager: Portage-2.3.96, Repoman-2.3.22 Closes: https://github.com/gentoo/gentoo/pull/15245 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-misc/buku/buku-3.7.ebuild')
-rw-r--r--www-misc/buku/buku-3.7.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/www-misc/buku/buku-3.7.ebuild b/www-misc/buku/buku-3.7.ebuild
deleted file mode 100644
index dc409e690898..000000000000
--- a/www-misc/buku/buku-3.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Powerful command-line bookmark manager"
-HOMEPAGE="https://github.com/jarun/Buku"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.13.1[${PYTHON_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/zsh/site-functions
- doins auto-completion/zsh/_*
-
- newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
-
- doman buku.1
-}
-
-python_test() {
- py.test -v tests/test_* || die
-}