summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-06-18 09:06:44 -0700
committerMatt Turner <mattst88@gentoo.org>2017-06-18 09:22:36 -0700
commite06f72167be208c628d0c51c2d50ac541c2b73f4 (patch)
tree75635aacf3db0911ce397463f8d3de83aa84f3ed /www-misc/fcgiwrap
parentwww-misc/fcgiwrap: Sync ebuilds (diff)
downloadgentoo-e06f72167be208c628d0c51c2d50ac541c2b73f4.tar.gz
gentoo-e06f72167be208c628d0c51c2d50ac541c2b73f4.tar.bz2
gentoo-e06f72167be208c628d0c51c2d50ac541c2b73f4.zip
www-misc/fcgiwrap: Port to EAPI=6
Diffstat (limited to 'www-misc/fcgiwrap')
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
index 7f64c53a10a9..5158f96c498c 100644
--- a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
+++ b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
[[ ${PV} = *9999* ]] && VCS_ECLASS="git-r3" || VCS_ECLASS=""
inherit autotools systemd toolchain-funcs ${VCS_ECLASS}
@@ -46,13 +46,14 @@ src_prepare() {
sed -i -e '/User/d' systemd/fcgiwrap.service || die
sed -i -e '/Group/d' systemd/fcgiwrap.service || die
+ eapply_user
eautoreconf
}
src_configure() {
econf \
$(use_with systemd) \
- "$(systemd_with_unitdir)"
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
}
pkg_postinst() {