summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-05-10 12:22:24 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-05-10 12:26:37 +0200
commitc56dd0fb8e2dc30458b13e1366a9c1402d9c945a (patch)
tree5a883f0a30181f0cedadc5b20f6bc15ef8c741e0 /www-misc/urlwatch
parentapp-editors/e3: Call tc-getLD to determine the ld program. (diff)
downloadgentoo-c56dd0fb8e2dc30458b13e1366a9c1402d9c945a.tar.gz
gentoo-c56dd0fb8e2dc30458b13e1366a9c1402d9c945a.tar.bz2
gentoo-c56dd0fb8e2dc30458b13e1366a9c1402d9c945a.zip
www-misc/urlwatch: fix failure when pycodestyle is not installed
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-misc/urlwatch')
-rw-r--r--www-misc/urlwatch/files/urlwatch-2.18-pycodestyle-requirement.patch15
-rw-r--r--www-misc/urlwatch/urlwatch-2.18-r1.ebuild (renamed from www-misc/urlwatch/urlwatch-2.18.ebuild)4
2 files changed, 19 insertions, 0 deletions
diff --git a/www-misc/urlwatch/files/urlwatch-2.18-pycodestyle-requirement.patch b/www-misc/urlwatch/files/urlwatch-2.18-pycodestyle-requirement.patch
new file mode 100644
index 000000000000..587a55ab03c8
--- /dev/null
+++ b/www-misc/urlwatch/files/urlwatch-2.18-pycodestyle-requirement.patch
@@ -0,0 +1,15 @@
+diff --git a/setup.py b/setup.py
+index 5f85aaf..7466787 100644
+--- a/setup.py
++++ b/setup.py
+@@ -17,9 +17,7 @@ if sys.version_info < (3, 3):
+ m['name'] = 'urlwatch'
+ m['author'], m['author_email'] = re.match(r'(.*) <(.*)>', m['author']).groups()
+ m['description'], m['long_description'] = docs[0].strip().split('\n\n', 1)
+-m['install_requires'] = ['minidb', 'PyYAML', 'requests', 'keyring', 'pycodestyle', 'appdirs', 'lxml', 'cssselect']
+-if sys.version_info < (3, 4):
+- m['install_requires'].extend(['enum34'])
++m['install_requires'] = ['minidb', 'PyYAML', 'requests', 'keyring', 'appdirs', 'lxml', 'cssselect']
+ if sys.platform == 'win32':
+ m['install_requires'].extend(['colorama'])
+ m['entry_points'] = {"console_scripts": ["urlwatch=urlwatch.cli:main"]}
diff --git a/www-misc/urlwatch/urlwatch-2.18.ebuild b/www-misc/urlwatch/urlwatch-2.18-r1.ebuild
index 4c0c01c582b3..d8fcfd698a28 100644
--- a/www-misc/urlwatch/urlwatch-2.18.ebuild
+++ b/www-misc/urlwatch/urlwatch-2.18-r1.ebuild
@@ -36,6 +36,10 @@ BDEPEND="
)
"
+# This will be in the next release
+# https://github.com/thp/urlwatch/commit/44e862282d39a6e23f67c3c0240a93cccbb41a55
+PATCHES=( "${FILESDIR}/${P}-pycodestyle-requirement.patch" )
+
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests nose