summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-28 20:45:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-07 23:54:04 +0200
commitfeb0951935b74d3b375f7c57c0ebea2c1b953ffa (patch)
tree42a236d9b88a71852a78af952c29f9f59864d83a /www-misc
parentwww-misc/multisort: use HTTPs (diff)
downloadgentoo-feb0951935b74d3b375f7c57c0ebea2c1b953ffa.tar.gz
gentoo-feb0951935b74d3b375f7c57c0ebea2c1b953ffa.tar.bz2
gentoo-feb0951935b74d3b375f7c57c0ebea2c1b953ffa.zip
www-misc/multisort: add EAPI7 ebuild
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/multisort/multisort-1.1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-misc/multisort/multisort-1.1-r2.ebuild b/www-misc/multisort/multisort-1.1-r2.ebuild
new file mode 100644
index 000000000000..2e91afe31e88
--- /dev/null
+++ b/www-misc/multisort/multisort-1.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Merges httpd logfiles in the Common Log Format"
+HOMEPAGE="https://www.xach.com/multisort/"
+SRC_URI="https://www.xach.com/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ # respect LDFLAGS wrt bug #337359
+ sed -i -e 's/$(CFLAGS)/& \$(LDFLAGS)/' Makefile || die 'sed on Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin multisort
+}