summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild')
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild129
1 files changed, 129 insertions, 0 deletions
diff --git a/www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild
new file mode 100644
index 000000000000..fcbe3ee389ff
--- /dev/null
+++ b/www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib nsplugins unpacker
+
+if [ "${PV}" != "9999" ]; then
+ DEB_PATCH="1"
+ #http://dl.google.com/linux/talkplugin/deb/dists/stable/main/binary-i386/Packages
+ MY_URL="http://dl.google.com/linux/talkplugin/deb/pool/main/${P:0:1}/${PN}"
+ MY_PKG="${PN}_${PV}-${DEB_PATCH}_i386.deb"
+ SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
+ amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
+ KEYWORDS="-* ~amd64 ~x86"
+else
+ inherit cvs #hack to make it part of @live-rebuild
+ MY_URL="http://dl.google.com/linux/direct"
+ MY_PKG="${PN}_current_i386.deb"
+ SRC_URI=""
+fi
+
+DESCRIPTION="Video chat browser plug-in for Google Talk"
+
+HOMEPAGE="http://www.google.com/chat/video"
+IUSE="libnotify selinux"
+SLOT="0"
+
+#GoogleTalkPlugin binary contains openssl and celt
+LICENSE="Google-TOS openssl BSD"
+
+OBSOLETE="yes"
+[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
+
+RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/pango
+ sys-apps/lsb-release
+ selinux? ( sec-policy/selinux-googletalk )
+ libnotify? ( x11-libs/libnotify )"
+
+DEPEND=""
+
+INSTALL_BASE="opt/google/talkplugin"
+
+QA_PREBUILT="${INSTALL_BASE}/*"
+
+S="${WORKDIR}"
+
+LANGS="ar cs en et fr hu lt ms pl ru sv tl vi bg da fa gu id ja lv nl
+sk ta tr bn de es fi hi is kn ml no sl te uk ca el fil hr it ko mr or
+ro sr th ur"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+# nofetch means upstream bumped and thus needs version bump
+pkg_nofetch() {
+ if [[ ${OBSOLETE} = yes ]]; then
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems"
+ elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
+ use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
+ elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
+ elog "and copy the file ${MY_PKG} to ${DISTDIR}."
+ else
+ einfo "This version is no longer available from Google."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ fi
+}
+
+src_unpack() {
+ local pkg="${A:=${MY_PKG}}"
+ if [ "${PV}" = "9999" ]; then
+ use amd64 && pkg="${pkg/i386/amd64}"
+ einfo "Fetching ${pkg}"
+ wget "${MY_URL}/${pkg}" || die
+ fi
+ unpacker ${pkg}
+}
+
+src_install() {
+ local plugindir i l
+ local ppapi_plugindirs=( /opt/google/chrome{,-beta,-unstable}/pepper
+ /usr/$(get_libdir)/chromium-browser/pepper )
+
+ unpacker usr/share/doc/google-talkplugin/changelog.Debian.gz
+ dodoc changelog.Debian
+
+ exeinto "/${INSTALL_BASE}"
+ doexe "${INSTALL_BASE}"/GoogleTalkPlugin
+ for i in "${INSTALL_BASE}"/lib*.so; do
+ doexe "${i}"
+ [[ ${i##*/} = libnp* ]] && inst_plugin "/${i}"
+ if [[ ${i##*/} = libpp* ]] ; then
+ for plugindir in "${ppapi_plugindirs[@]}"; do
+ dosym "/${i}" "${plugindir}/${i##*/}"
+ done
+ fi
+ done
+
+ #install screen-sharing stuff - bug #397463
+ insinto "/${INSTALL_BASE}"
+ doins "${INSTALL_BASE}"/windowpicker.glade
+ doins "${INSTALL_BASE}"/remoting24x24.png
+ doins -r "${INSTALL_BASE}"/data
+
+ strip-linguas ${LANGS}
+ for l in ${LINGUAS}; do
+ insinto "/${INSTALL_BASE}"/locale/$l/LC_MESSAGES/
+ doins "${INSTALL_BASE}"/locale/$l/LC_MESSAGES/windowpicker.mo
+ done
+}