summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2016-11-23 20:13:38 -0700
committerChristoph Junghans <junghans@gentoo.org>2016-11-23 20:15:56 -0700
commitd8db5d3dd6a8a6c702498fb1fdc87ff5250eb1c0 (patch)
tree9c25250957eb45c892d750848b9b5940817e6ebc /www-plugins/google-talkplugin
parentdev-python/django-ldap-groups: replace googlecode links (diff)
downloadgentoo-d8db5d3dd6a8a6c702498fb1fdc87ff5250eb1c0.tar.gz
gentoo-d8db5d3dd6a8a6c702498fb1fdc87ff5250eb1c0.tar.bz2
gentoo-d8db5d3dd6a8a6c702498fb1fdc87ff5250eb1c0.zip
www-plugins/google-talkplugin: remove old
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-plugins/google-talkplugin')
-rw-r--r--www-plugins/google-talkplugin/Manifest6
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild129
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-5.4.2.0.ebuild125
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-5.40.2.0.ebuild127
4 files changed, 0 insertions, 387 deletions
diff --git a/www-plugins/google-talkplugin/Manifest b/www-plugins/google-talkplugin/Manifest
index 91d5a7ddf8a..40d8dcdc356 100644
--- a/www-plugins/google-talkplugin/Manifest
+++ b/www-plugins/google-talkplugin/Manifest
@@ -1,9 +1,3 @@
-DIST google-talkplugin_5.38.6.0-1_amd64.deb 7301206 SHA256 516c68c9f3bd0786e0d8ed03a36d2d82395d41b4c69342ba6879803f111ef332 SHA512 82b255ab8023d125c22a9b334c3ef98fe17e7cf657f173c35743bd06c397a11c59136d4e7ff9eeb352e72d745077882ea6ad7122ed33f2467dc8d32586c4290b WHIRLPOOL af52119b6b57699737cb8326b274625d731f28087586701a6ee24852220e89a482f49df7298d57ee26d527ea2a3ecb61c432e791e38a1dc8426a8911d01669d6
-DIST google-talkplugin_5.38.6.0-1_i386.deb 7175006 SHA256 c1752d2c76a1a93a0cc21783b5721a76b41da3cc92c9ba497f66a5e5175b5d84 SHA512 e06e987dbb48daadf18dd394e18e0203cefa787c17429079d0c448ca5a77517b79b2603078defbb52edaccb46a0dfeb56141d50a659ddb3511e83e3ca002de56 WHIRLPOOL cc85caa837e82e376d77d26735f213429c5abe46f4cded4d83164771df8eb200d03cea18a107ce0358fee17cbd6fc565794b125e0036794f87eb50423b69ae74
-DIST google-talkplugin_5.4.2.0-1_amd64.deb 8012042 SHA256 e5921ac2a1117358663d0603601d95770055de78cb2cc3a362bc50b04fa1bb93 SHA512 b6fa75d9e5d7dadc7d4bf5c732fe5587f3a5e2312a6ad0675f3b44f593b449e612aa0f9c72ab89afce9907363c4bbd48e19917ef3efb63e42c6dfbef71e6530f WHIRLPOOL b5b8cb2d6755da81e4fd487fa0962f96096b81b35a7633359a20a74fedb42b6148428a17f7a636d328109c4460987a344953b86bdfcd5fcf27f0829684aba3cd
-DIST google-talkplugin_5.4.2.0-1_i386.deb 7305310 SHA256 0942302742cc7f4d96a62c606765f3f4304a304987ebb44cc574fbd276fef8d9 SHA512 82cde8262d12ff9c36cbce57e5ebc55ffd30fd16e846af3433bf6cd8340b47b1c9784660468d271a5907beb50fba71917ad685d2212f92642f32dbbe170ae082 WHIRLPOOL dea482abb3b0d9c310ad7047a8951ce3589d5c247c565cb444051a22e5e38a71ffabee00dac2d5b4e76dd107c844339bbd0df6913c38674f6fa999748b4c3a2c
-DIST google-talkplugin_5.40.2.0-1_amd64.deb 7723806 SHA256 598874e41c2993e2a89c7ea1b063aef1b770c0ba6b34fb019dccb412ac7cb8d4 SHA512 a76760e7cad0584fb18aab065d1beae57c6f83681498643e09955f3f14bd0b0b3de8ca57cfe3f68641154a52f5d41840d51128aa1059eb342c56f662bab54e7d WHIRLPOOL ef671d05e36fbe1360ca7bd4f900404d295e69811c791f4b2ca231b2c9548becf4c02291c5e468801f7fde91b3ce5e0dee374b4eca78eb436fbbd80dbce9cc13
-DIST google-talkplugin_5.40.2.0-1_i386.deb 7621704 SHA256 7d0a0a0e7e7f375442b31d70feea96d0fbd573ce505ef6f32b8bb5d640e22486 SHA512 cb593a89de2129b5205f08382d5fe39f47351ed5c821e379bcbb0bdc2d62174e7c609c779ff5103795c8177862a9e8d017f2a7d711f5633f50a5b5fa2d251775 WHIRLPOOL 0e042dd1b9469cb7fce543cba2653602f8307d385dcdabb3405ff5591827eaed815812b994fe5b0c0c8a87a2e77da02b38d86fbb5f45a5b518a77f05d3515f38
DIST google-talkplugin_5.41.0.0-1_amd64.deb 7813320 SHA256 9d878736e0c7a386dcd1abba237d28cfc76c44b933943cb6e9c0bcf10d5fa11d SHA512 cfeed6384fee1f25c12a90c3b39081f058dbcc1043a4692450f143569ce1fe6b94f0978f76362eafac87a15820b806fd01cc9975d80c076d35456533f9486cb1 WHIRLPOOL 0f54965e30738e6fec274412c8d8bb38b3add28946cef1b9fe6acc2b4c5639cb6b1bf84f6a187bb3e4f1afdc00b311da0771610c6a56f12582efded7c88ddcbb
DIST google-talkplugin_5.41.0.0-1_i386.deb 7659028 SHA256 de1fcc0fc614a91df30a0a185a0b620abf44152e30a9ba5004f6b52abd0d8fd1 SHA512 ca5cd6b296791de471151710558d6fb501d584620703817ba5de769d639b653fd67ed30ae6d3aff3411b69c39a22232f2af9067d8b771677d26c561ffe958533 WHIRLPOOL 1cfef503cd74b3e814a528463f0a42865672efbb6faaad63aadbc538428b75fc8ce1520d2ef8a0e22505702da54b087ded94fb05a3d31086317821be4a8dce82
DIST google-talkplugin_5.41.3.0-1_amd64.deb 7800474 SHA256 af7e23d2b6215afc547f96615b99f04e0561557cc58c0c9302364b5a3840d97d SHA512 8802c1726c9b362db5302a8b2243c8d84c2b35b9ab55adacc08ed05a5fb98d2778c2ff516a5df13bcaa499ab9d902481957b119624467be69a2833e0b76ba218 WHIRLPOOL b5ef8da35ca051a9984558238120a136d0dd12c1c32191e5e754d61300bbaa71f7a9fba95dde77a9bef692a7605c6bcbf403389d9a4a75bde6de436b6bc8b9b7
diff --git a/www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild
deleted file mode 100644
index 5a7176e0e66..00000000000
--- a/www-plugins/google-talkplugin/google-talkplugin-5.38.6.0.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib nsplugins unpacker
-
-if [ "${PV}" != "9999" ]; then
- DEB_PATCH="1"
- #https://dl.google.com/linux/talkplugin/deb/dists/stable/main/binary-i386/Packages
- MY_URL="https://dl.google.com/linux/talkplugin/deb/pool/main/${P:0:1}/${PN}"
- MY_PKG="${PN}_${PV}-${DEB_PATCH}_i386.deb"
- SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
- amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
- KEYWORDS="-* ~amd64 ~x86"
-else
- inherit cvs #hack to make it part of @live-rebuild
- MY_URL="https://dl.google.com/linux/direct"
- MY_PKG="${PN}_current_i386.deb"
- SRC_URI=""
-fi
-
-DESCRIPTION="Video chat browser plug-in for Google Talk"
-
-HOMEPAGE="https://www.google.com/chat/video"
-IUSE="libnotify selinux"
-SLOT="0"
-
-#GoogleTalkPlugin binary contains openssl and celt
-LICENSE="Google-TOS openssl BSD"
-
-OBSOLETE="yes"
-[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
-
-RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/pango
- sys-apps/lsb-release
- selinux? ( sec-policy/selinux-googletalk )
- libnotify? ( x11-libs/libnotify )"
-
-DEPEND=""
-
-INSTALL_BASE="opt/google/talkplugin"
-
-QA_PREBUILT="${INSTALL_BASE}/*"
-
-S="${WORKDIR}"
-
-LANGS="ar cs en et fr hu lt ms pl ru sv tl vi bg da fa gu id ja lv nl
-sk ta tr bn de es fi hi is kn ml no sl te uk ca el fil hr it ko mr or
-ro sr th ur"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-# nofetch means upstream bumped and thus needs version bump
-pkg_nofetch() {
- if [[ ${OBSOLETE} = yes ]]; then
- elog "This version is no longer available from Google and the license prevents mirroring."
- elog "This ebuild is intended for users who already downloaded it previously and have problems"
- elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
- use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
- elog "it with google: https://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
- elog "and copy the file ${MY_PKG} to ${DISTDIR}."
- else
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on https://bugs.gentoo.org (search existing bugs for ${PN} first!)."
- fi
-}
-
-src_unpack() {
- local pkg="${A:=${MY_PKG}}"
- if [ "${PV}" = "9999" ]; then
- use amd64 && pkg="${pkg/i386/amd64}"
- einfo "Fetching ${pkg}"
- wget "${MY_URL}/${pkg}" || die
- fi
- unpacker ${pkg}
-}
-
-src_install() {
- local plugindir i l
- local ppapi_plugindirs=( /opt/google/chrome{,-beta,-unstable}/pepper
- /usr/$(get_libdir)/chromium-browser/pepper )
-
- unpacker usr/share/doc/google-talkplugin/changelog.Debian.gz
- dodoc changelog.Debian
-
- exeinto "/${INSTALL_BASE}"
- doexe "${INSTALL_BASE}"/GoogleTalkPlugin
- for i in "${INSTALL_BASE}"/lib*.so; do
- doexe "${i}"
- [[ ${i##*/} = libnp* ]] && inst_plugin "/${i}"
- if [[ ${i##*/} = libpp* ]] ; then
- for plugindir in "${ppapi_plugindirs[@]}"; do
- dosym "/${i}" "${plugindir}/${i##*/}"
- done
- fi
- done
-
- #install screen-sharing stuff - bug #397463
- insinto "/${INSTALL_BASE}"
- doins "${INSTALL_BASE}"/windowpicker.glade
- doins "${INSTALL_BASE}"/remoting24x24.png
- doins -r "${INSTALL_BASE}"/data
-
- strip-linguas ${LANGS}
- for l in ${LINGUAS}; do
- insinto "/${INSTALL_BASE}"/locale/$l/LC_MESSAGES/
- doins "${INSTALL_BASE}"/locale/$l/LC_MESSAGES/windowpicker.mo
- done
-}
diff --git a/www-plugins/google-talkplugin/google-talkplugin-5.4.2.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-5.4.2.0.ebuild
deleted file mode 100644
index 15234893797..00000000000
--- a/www-plugins/google-talkplugin/google-talkplugin-5.4.2.0.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib nsplugins unpacker
-
-if [ "${PV}" != "9999" ]; then
- DEB_PATCH="1"
- #https://dl.google.com/linux/talkplugin/deb/dists/stable/main/binary-i386/Packages
- MY_URL="https://dl.google.com/linux/talkplugin/deb/pool/main/${P:0:1}/${PN}"
- MY_PKG="${PN}_${PV}-${DEB_PATCH}_i386.deb"
- SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
- amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
-else
- inherit cvs #hack to make it part of @live-rebuild
- MY_URL="https://dl.google.com/linux/direct"
- MY_PKG="${PN}_current_i386.deb"
- SRC_URI=""
-fi
-
-DESCRIPTION="Video chat browser plug-in for Google Talk"
-
-HOMEPAGE="https://www.google.com/chat/video"
-IUSE="libnotify selinux"
-SLOT="0"
-
-KEYWORDS="-* amd64 x86"
-#GoogleTalkPlugin binary contains openssl and celt
-LICENSE="Google-TOS openssl BSD"
-
-OBSOLETE="yes"
-[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
-
-RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
- dev-libs/glib:2
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/pango
- sys-apps/lsb-release
- selinux? ( sec-policy/selinux-googletalk )
- libnotify? ( x11-libs/libnotify )"
-
-DEPEND=""
-
-INSTALL_BASE="opt/google/talkplugin"
-
-QA_PREBUILT="${INSTALL_BASE}/*"
-
-S="${WORKDIR}"
-
-LANGS="ar cs en et fr hu lt ms pl ru sv tl vi bg da fa gu id ja lv nl
-sk ta tr bn de es fi hi is kn ml no sl te uk ca el fil hr it ko mr or
-ro sr th ur"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-# nofetch means upstream bumped and thus needs version bump
-pkg_nofetch() {
- if [[ ${OBSOLETE} = yes ]]; then
- elog "This version is no longer available from Google and the license prevents mirroring."
- elog "This ebuild is intended for users who already downloaded it previously and have problems"
- elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
- use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
- elog "it with google: https://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
- elog "and copy the file ${MY_PKG} to ${DISTDIR}."
- else
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on https://bugs.gentoo.org (search existing bugs for ${PN} first!)."
- fi
-}
-
-src_unpack() {
- local pkg="${A:=${MY_PKG}}"
- if [ "${PV}" = "9999" ]; then
- use amd64 && pkg="${pkg/i386/amd64}"
- einfo "Fetching ${pkg}"
- wget "${MY_URL}/${pkg}" || die
- fi
- unpacker ${pkg}
-}
-
-src_install() {
- local plugindir i l
- local ppapi_plugindirs=( /opt/google/chrome{,-beta,-unstable}/pepper
- /usr/$(get_libdir)/chromium-browser/pepper )
-
- unpacker usr/share/doc/google-talkplugin/changelog.Debian.gz
- dodoc changelog.Debian
-
- exeinto "/${INSTALL_BASE}"
- doexe "${INSTALL_BASE}"/GoogleTalkPlugin
- for i in "${INSTALL_BASE}"/lib*.so; do
- doexe "${i}"
- [[ ${i##*/} = libnp* ]] && inst_plugin "/${i}"
- if [[ ${i##*/} = libpp* ]] ; then
- for plugindir in "${ppapi_plugindirs[@]}"; do
- dosym "/${i}" "${plugindir}/${i##*/}"
- done
- fi
- done
-
- #install screen-sharing stuff - bug #397463
- insinto "/${INSTALL_BASE}"
- doins "${INSTALL_BASE}"/windowpicker.glade
- doins "${INSTALL_BASE}"/remoting24x24.png
- doins -r "${INSTALL_BASE}"/data
-
- strip-linguas ${LANGS}
- for l in ${LINGUAS}; do
- insinto "/${INSTALL_BASE}"/locale/$l/LC_MESSAGES/
- doins "${INSTALL_BASE}"/locale/$l/LC_MESSAGES/windowpicker.mo
- done
-}
diff --git a/www-plugins/google-talkplugin/google-talkplugin-5.40.2.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-5.40.2.0.ebuild
deleted file mode 100644
index 8e895cd41dd..00000000000
--- a/www-plugins/google-talkplugin/google-talkplugin-5.40.2.0.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib nsplugins unpacker
-
-if [ "${PV}" != "9999" ]; then
- DEB_PATCH="1"
- #https://dl.google.com/linux/talkplugin/deb/dists/stable/main/binary-i386/Packages
- MY_URL="https://dl.google.com/linux/talkplugin/deb/pool/main/${P:0:1}/${PN}"
- MY_PKG="${PN}_${PV}-${DEB_PATCH}_i386.deb"
- SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
- amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
- KEYWORDS="-* ~amd64 ~x86"
-else
- inherit cvs #hack to make it part of @live-rebuild
- MY_URL="https://dl.google.com/linux/direct"
- MY_PKG="${PN}_current_i386.deb"
- SRC_URI=""
-fi
-
-DESCRIPTION="Video chat browser plug-in for Google Talk"
-
-HOMEPAGE="https://www.google.com/chat/video"
-IUSE="libnotify selinux"
-SLOT="0"
-
-#GoogleTalkPlugin binary contains openssl and celt
-LICENSE="Google-TOS openssl BSD"
-
-OBSOLETE="yes"
-[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
-
-RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
- dev-libs/expat
- dev-libs/glib:2
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/pango
- sys-apps/lsb-release
- selinux? ( sec-policy/selinux-googletalk )
- libnotify? ( x11-libs/libnotify )"
-
-DEPEND=""
-
-INSTALL_BASE="opt/google/talkplugin"
-
-QA_PREBUILT="${INSTALL_BASE}/*"
-
-S="${WORKDIR}"
-
-LANGS="ar cs en et fr hu lt ms pl ru sv tl vi bg da fa gu id ja lv nl
-sk ta tr bn de es fi hi is kn ml no sl te uk ca el fil hr it ko mr or
-ro sr th ur"
-
-for X in ${LANGS} ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
-# nofetch means upstream bumped and thus needs version bump
-pkg_nofetch() {
- if [[ ${OBSOLETE} = yes ]]; then
- elog "This version is no longer available from Google and the license prevents mirroring."
- elog "This ebuild is intended for users who already downloaded it previously and have problems"
- elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
- use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
- elog "it with google: https://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
- elog "and copy the file ${MY_PKG} to ${DISTDIR}."
- else
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on https://bugs.gentoo.org (search existing bugs for ${PN} first!)."
- fi
-}
-
-src_unpack() {
- local pkg="${A:=${MY_PKG}}"
- if [ "${PV}" = "9999" ]; then
- use amd64 && pkg="${pkg/i386/amd64}"
- einfo "Fetching ${pkg}"
- wget "${MY_URL}/${pkg}" || die
- fi
- unpacker ${pkg}
-}
-
-src_install() {
- local plugindir i l
- local ppapi_plugindirs=( /opt/google/chrome{,-beta,-unstable}/pepper
- /usr/$(get_libdir)/chromium-browser/pepper )
-
- unpacker usr/share/doc/google-talkplugin/changelog.Debian.gz
- dodoc changelog.Debian
-
- exeinto "/${INSTALL_BASE}"
- doexe "${INSTALL_BASE}"/GoogleTalkPlugin
- for i in "${INSTALL_BASE}"/lib*.so; do
- doexe "${i}"
- [[ ${i##*/} = libnp* ]] && inst_plugin "/${i}"
- if [[ ${i##*/} = libpp* ]] ; then
- for plugindir in "${ppapi_plugindirs[@]}"; do
- dosym "/${i}" "${plugindir}/${i##*/}"
- done
- fi
- done
-
- #install screen-sharing stuff - bug #397463
- insinto "/${INSTALL_BASE}"
- doins "${INSTALL_BASE}"/windowpicker.glade
- doins "${INSTALL_BASE}"/remoting24x24.png
- doins -r "${INSTALL_BASE}"/data
-
- strip-linguas ${LANGS}
- for l in ${LINGUAS}; do
- insinto "/${INSTALL_BASE}"/locale/$l/LC_MESSAGES/
- doins "${INSTALL_BASE}"/locale/$l/LC_MESSAGES/windowpicker.mo
- done
-}