summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-11-22 22:29:21 -0500
committerMatt Turner <mattst88@gentoo.org>2019-11-22 22:31:07 -0500
commit11219861d3cac6f8fb81ba5ee0c8f2b7e982f281 (patch)
treed373c649029d1e8e6aac5c9a684b1f2dd66e030b /www-plugins
parentdev-python/execne-1.7.1: Version bump, add py38 (diff)
downloadgentoo-11219861d3cac6f8fb81ba5ee0c8f2b7e982f281.tar.gz
gentoo-11219861d3cac6f8fb81ba5ee0c8f2b7e982f281.tar.bz2
gentoo-11219861d3cac6f8fb81ba5ee0c8f2b7e982f281.zip
www-plugins/passff-host: Version bump to 1.2.1
Closes: https://bugs.gentoo.org/696594 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/passff-host/Manifest2
-rw-r--r--www-plugins/passff-host/passff-host-1.2.1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/www-plugins/passff-host/Manifest b/www-plugins/passff-host/Manifest
index 1f70adbbc567..c67e81caa08d 100644
--- a/www-plugins/passff-host/Manifest
+++ b/www-plugins/passff-host/Manifest
@@ -1,2 +1,4 @@
DIST passff-host-1.2.0.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-host-1.2.0.py 3658 BLAKE2B 2b8fbd2c0e11cdc12804d4430b1028a45a7ff5abb1446d4c85d98b4b45b7cc78c86c0a801952f8810b8061abcbe1109d858d125717bc80f8194f510b39828c36 SHA512 8e3a61562b511895b07d6fe4edb6326d7cb6c14a8032dbcc4927b9a1c25a1a103042cd7dbbb6e417019fea768f30e32ff60fc4483b165968ec920fbfd40971b0
+DIST passff-host-1.2.1.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
+DIST passff-host-1.2.1.py 3666 BLAKE2B 6a95defc3b1abe91f95e83ab20e9d0e533da2ae0e2153d2b50abf0a77aeb426b6b0a0ed042c00912a434dadbf53a9091fa772df9b9f5c330982a9ab49b891bc8 SHA512 5fe848fe0d6a75b679ee18fd5d32fda963853b91ad382fc19780104d44d1052a7191188946af470722dab883f0318ec38980fc24f052aeb5c54cac98f810ee15
diff --git a/www-plugins/passff-host/passff-host-1.2.1.ebuild b/www-plugins/passff-host/passff-host-1.2.1.ebuild
new file mode 100644
index 000000000000..790ceb426225
--- /dev/null
+++ b/www-plugins/passff-host/passff-host-1.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_5 python3_6 python3_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Host app for the PassFF WebExtension"
+HOMEPAGE="https://github.com/passff/passff-host"
+
+SRC_URI="
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
+ https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome chromium firefox vivaldi"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( chrome chromium firefox vivaldi )
+"
+
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" . || die
+ cp "${DISTDIR}/${P}.py" . || die
+}
+
+src_prepare() {
+ default
+ python_fix_shebang "${P}.py"
+}
+
+src_install() {
+ local target_dirs=()
+
+ use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
+ use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
+ use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
+ use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
+
+ for target_dir in "${target_dirs[@]}"; do
+ sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
+
+ insinto "${target_dir}"
+ doins passff.json
+ exeinto "${target_dir}"
+ newexe "${P}.py" passff.py
+ done
+}