summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-08-29 19:12:20 -0400
committerBrian Evans <grknight@gentoo.org>2016-08-29 19:12:20 -0400
commit9c6483fca11590c6002e58f1607425eb5ce4eafd (patch)
treef2a218bcad9c125a1f4060141f5a32fb3b51f054 /www-plugins
parentdev-lang/scala: remove unused patch (diff)
downloadgentoo-9c6483fca11590c6002e58f1607425eb5ce4eafd.tar.gz
gentoo-9c6483fca11590c6002e58f1607425eb5ce4eafd.tar.bz2
gentoo-9c6483fca11590c6002e58f1607425eb5ce4eafd.zip
www-plugins/freshplayerplugin: Version bump wrt bug 581228
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/freshplayerplugin/Manifest1
-rw-r--r--www-plugins/freshplayerplugin/files/0.3.5-cmake.patch70
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.5.ebuild85
3 files changed, 156 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/Manifest b/www-plugins/freshplayerplugin/Manifest
index 097bfb444f94..2f5763a4c626 100644
--- a/www-plugins/freshplayerplugin/Manifest
+++ b/www-plugins/freshplayerplugin/Manifest
@@ -2,3 +2,4 @@ DIST freshplayerplugin-0.3.1.tar.gz 2711793 SHA256 4ed582896fff618d8025dd51bbf2f
DIST freshplayerplugin-0.3.2.tar.gz 2713241 SHA256 b3687b9d67ab88c64fea32b17f281f142bf861e33d9135b00da5d90d385d9ce5 SHA512 9c908ce1a168c0797dc3b0da8e98d722cc32d729acb1c4a8f38b7e95c23fe870baabe4b3f8790d021711578fdb9a61f44aba27cebb924fec9aabcf8cd91323e5 WHIRLPOOL 2e9b78bcc3605409ec6853caf31aab03658c044e0d05449a620b31261323856503db8db960db9992d6db4fd61df8f9feb05800124c2f4a450c4ff65b22fc7c34
DIST freshplayerplugin-0.3.3.tar.gz 2722467 SHA256 0dc20d6ca083b24225d8bbab88be1ed483034bde71eb360962de47cdb2e51f00 SHA512 ae85adb7e894adf8c1cd4228d15975c9d5fefdb6c6d3aa90e65d93865996c787f6378eb145f35ed348db67cec0adad794b78a0f77519236c28082630ad3756bc WHIRLPOOL 3e9694738d5e926b44588560b2a6bf50eeeefc35855722bda2494a9d08bd11c8ed844791cdd8a312592be0ef002d3ee6b1c7fc090bbd94ca438ccc8a148eac99
DIST freshplayerplugin-0.3.4.tar.gz 768318 SHA256 6f0009e64c59caa5c674b63eabb709ba8da6c85fc7cd45a1d66392e3a24da9a5 SHA512 d64fa3e6e38b4e17bef04b09c529ff03e86bb4b348e1e6b9a05f7ff4ee98327e288becd1cc6727db687ddca9e9ed04243c80c5e95e927cafad49a273d9c0d216 WHIRLPOOL 8fe0d582c25042b233d11fba83c50bd5a54e111c7f84b27ed28ba6cfc83c2101095e0460c67d122a3598d020d061f44e8de8bc922a164a251aeb589ac805291d
+DIST freshplayerplugin-0.3.5.tar.gz 781003 SHA256 b08f7c6690de13b1e358fef4cab41cb303b9e80b3504678e94c9646f44dd7104 SHA512 dd447db4cbfdb80b89ff42894099971c100023d19fe5fbad023d5ac1afa827fdc5a169a03f4702ffda3cf6e0dd9c63217b68d97d047ac43afc22f488020a0ba0 WHIRLPOOL cf22758e0ed947db27e8e6e053f17bafc425beebebd9314008eef105e828a0a51f73fd42f2d0c00e12e56f817e2b9078baeb55bd54a6c6a55e8ebd00d2e27ccc
diff --git a/www-plugins/freshplayerplugin/files/0.3.5-cmake.patch b/www-plugins/freshplayerplugin/files/0.3.5-cmake.patch
new file mode 100644
index 000000000000..f925dfa31eb9
--- /dev/null
+++ b/www-plugins/freshplayerplugin/files/0.3.5-cmake.patch
@@ -0,0 +1,70 @@
+diff -uarN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2015-04-25 11:17:24.000000000 -0400
++++ b/CMakeLists.txt 2015-04-26 20:14:43.152014529 -0400
+@@ -61,35 +61,36 @@
+ # optional dependencies
+ message(STATUS "checking for optional dependencies")
+
+-pkg_check_modules(PULSEAUDIO QUIET libpulse)
+-pkg_check_modules(JACK QUIET jack)
+-pkg_check_modules(SOXR QUIET soxr)
+ set(WITH_PULSEAUDIO TRUE CACHE STRING "enable PulseAudio support")
+ set(WITH_JACK TRUE CACHE STRING "enable JACK Audio Connection Kit")
+
+-if (PULSEAUDIO_FOUND AND WITH_PULSEAUDIO)
++if (WITH_PULSEAUDIO)
++ pkg_check_modules(PULSEAUDIO libpulse)
++ if (NOT PULSEAUDIO_FOUND)
++ message(FATAL_ERROR "PulseAudio requested but not found.")
++ endif()
+ add_definitions(-DHAVE_PULSEAUDIO=1)
+- message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION} (optional)")
++ message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION}")
+ list(APPEND REQ_LIBRARY_DIRS ${PULSEAUDIO_LIBRARY_DIRS})
+ list(APPEND REQ_INCLUDE_DIRS ${PULSEAUDIO_INCLUDE_DIRS})
+ list(APPEND REQ_LIBRARIES ${PULSEAUDIO_LIBRARIES})
+-else()
+- message(STATUS " no libpulse found (optional)")
+ endif()
+
+-if (JACK_FOUND AND WITH_JACK)
+- message(STATUS " found jack, version ${JACK_VERSION} (optional)")
+- if (SOXR_FOUND)
+- message(STATUS " found soxr, version ${SOXR_VERSION}")
+- add_definitions(-DHAVE_JACK=1)
+- list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
+- list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
+- list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
+- else()
+- message(STATUS " no soxr found, JACK output disabled")
++if (WITH_JACK)
++ pkg_check_modules(JACK QUIET jack)
++ if (NOT JACK_FOUND)
++ message(FATAL_ERROR "JACK support requested but not found.")
++ endif()
++ pkg_check_modules(SOXR QUIET soxr)
++ if (NOT SOXR_FOUND)
++ message(FATAL_ERROR "SOXR libray not found but needed for JACK support.")
+ endif()
+-else()
+- message(STATUS " no jack found (optional)")
++ message(STATUS " found jack, version ${JACK_VERSION}")
++ message(STATUS " found soxr, version ${SOXR_VERSION}")
++ add_definitions(-DHAVE_JACK=1)
++ list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
++ list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
++ list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
+ endif()
+
+ list(APPEND REQ_LIBRARIES img-resources)
+--- a/src/CMakeLists.txt 2015-12-20 08:38:33.000000000 -0500
++++ b/src/CMakeLists.txt 2015-12-26 20:45:07.000000000 -0500
+@@ -5,7 +5,7 @@
+
+ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+
+-set(MOZPLUGIN_INSTALL_DIR "lib${LIB_SUFFIX}/mozilla/plugins/" CACHE STRING "plugin install directory")
++set(MOZPLUGIN_INSTALL_DIR "lib${LIB_SUFFIX}/nsbrowser/plugins/" CACHE STRING "plugin install directory")
+
+ add_subdirectory(uri_parser)
+ add_subdirectory(config_parser)
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.5.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.5.ebuild
new file mode 100644
index 000000000000..c6b4a10ef8ee
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="2.8.8"
+
+inherit cmake-utils
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="gles2 gtk3 jack libav libressl pulseaudio v4l vaapi vdpau"
+
+KEYWORDS="~amd64"
+
+HWDEC_DEPEND="
+ libav? ( media-video/libav:0=[vaapi?,vdpau?] )
+ !libav? ( media-video/ffmpeg:0=[vaapi?,vdpau?] )
+ x11-libs/libva
+ x11-libs/libvdpau
+"
+
+COMMON_DEPEND="
+ dev-libs/glib:2=
+ dev-libs/icu:0=
+ dev-libs/libevent:=[threads]
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/mesa:=[egl,gles2?]
+ x11-libs/cairo:=[X]
+ x11-libs/libXcursor:=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/libdrm:=
+ x11-libs/pango:=[X]
+ jack? (
+ media-sound/jack-audio-connection-kit
+ media-libs/soxr
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ !gtk3? ( x11-libs/gtk+:2= )
+ gtk3? ( x11-libs/gtk+:3= )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ v4l? ( media-libs/libv4l:0= )
+ vaapi? ( ${HWDEC_DEPEND} )
+ vdpau? ( ${HWDEC_DEPEND} )
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${COMMON_DEPEND}
+ || (
+ www-plugins/chrome-binary-plugins[flash]
+ www-client/google-chrome
+ www-client/google-chrome-beta
+ www-client/google-chrome-unstable
+ )
+ "
+
+PATCHES=( "${FILESDIR}/0.3.5-cmake.patch" "${FILESDIR}/0.3.4-git-revision.patch" )
+DOCS=( ChangeLog data/freshwrapper.conf.example README.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_JACK=$(usex jack)
+ -DWITH_PULSEAUDIO=$(usex pulseaudio)
+ -DWITH_GTK=$(usex gtk3 3 2)
+ -DWITH_GLES2=$(usex gles2)
+ -DWITH_LIBV4L2=$(usex v4l)
+ -DCMAKE_SKIP_RPATH=1
+ )
+ if use vaapi || use vdpau ; then
+ mycmakeargs+=( -DWITH_HWDEC=1 )
+ else
+ mycmakeargs+=( -DWITH_HWDEC=0 )
+ fi
+ cmake-utils_src_configure
+}