summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/boa/boa-0.94.14_rc21-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/boa/boa-0.94.14_rc21-r1.ebuild')
-rw-r--r--www-servers/boa/boa-0.94.14_rc21-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-servers/boa/boa-0.94.14_rc21-r1.ebuild b/www-servers/boa/boa-0.94.14_rc21-r1.ebuild
new file mode 100644
index 000000000000..898373146388
--- /dev/null
+++ b/www-servers/boa/boa-0.94.14_rc21-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd
+
+MY_P=${P/_/}
+DESCRIPTION="A very small and very fast http daemon"
+SRC_URI="http://www.boa.org/${MY_P}.tar.gz"
+HOMEPAGE="http://www.boa.org/"
+
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ doc? ( virtual/latex-base )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-texi.patch
+ epatch "${FILESDIR}"/${P}-ENOSYS.patch
+}
+
+src_compile() {
+ default
+
+ use doc || sed -i -e '/^all:/s/boa.dvi //' docs/Makefile
+ emake docs
+}
+
+src_install() {
+ dosbin src/boa
+ doman docs/boa.8
+ doinfo docs/boa.info
+ if use doc; then
+ dodoc docs/boa.html
+ dodoc docs/boa_banner.png
+ dodoc docs/boa.dvi
+ fi
+
+ keepdir /var/log/boa
+ keepdir /var/www/localhost/htdocs
+ keepdir /var/www/localhost/cgi-bin
+ keepdir /var/www/localhost/icons
+
+ newinitd "${FILESDIR}"/boa.rc6 boa
+ newconfd "${FILESDIR}"/boa.conf.d boa
+
+ systemd_dounit "${FILESDIR}"/boa.service
+
+ exeinto /usr/lib/boa
+ doexe src/boa_indexer
+
+ insinto /etc/boa
+ doins "${FILESDIR}"/boa.conf
+ doins "${FILESDIR}"/mime.types
+}