summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2018-11-04 16:31:36 +0100
committerZac Medico <zmedico@gentoo.org>2018-11-05 00:55:33 -0800
commitdd20da991c23232cdf385de3083f7ecb921f5810 (patch)
treea66c04761ba9eb1b66b6e4494904ed42f60bfa41 /www-servers/civetweb
parentsys-apps/portage: stable 2.3.51 for ppc64, bug #670232 (diff)
downloadgentoo-dd20da991c23232cdf385de3083f7ecb921f5810.tar.gz
gentoo-dd20da991c23232cdf385de3083f7ecb921f5810.tar.bz2
gentoo-dd20da991c23232cdf385de3083f7ecb921f5810.zip
www-servers/civetweb: bump to 1.11, add cxx/server USE flags
- Version bump to latest version. - Add USE flags to enable/disable the optional C++ bindings and the standalone binary, which is not needed for development. - Add the new USE flags to metadata.xml. Closes: https://github.com/gentoo/gentoo/pull/10337 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'www-servers/civetweb')
-rw-r--r--www-servers/civetweb/Manifest1
-rw-r--r--www-servers/civetweb/civetweb-1.11.ebuild39
-rw-r--r--www-servers/civetweb/metadata.xml3
3 files changed, 43 insertions, 0 deletions
diff --git a/www-servers/civetweb/Manifest b/www-servers/civetweb/Manifest
index e2487744435a..d83660b0b200 100644
--- a/www-servers/civetweb/Manifest
+++ b/www-servers/civetweb/Manifest
@@ -1 +1,2 @@
DIST civetweb-1.10.tar.gz 11350512 BLAKE2B b0a2ef514a0d9f821a1e05e72000901092f722a5628b759401ef4118301ef79ee8b00f44a9fe9e9f64a14b4af6511419d1684cbe9d2b7c0eb18dbd9d98cd7cbe SHA512 54035883fbec590f339a2b4b5bf1b9a93591ea50bff056830d0c45b874cf6e46ce5af39e9dd9d4e0e6c82bec844aa0f159503f337998e9e10e59099b8ecc3f79
+DIST civetweb-1.11.tar.gz 11421650 BLAKE2B 487044a313c2ff005a8dfa247b3d8a3c3b52ef048cbc3050ec8c0402ccef4e12e28de53fed5a3a91df1e7f59ba6c03bf545413ffdd0ce3e4d604148c16c661e9 SHA512 e1520fd2f4a54b6ab4838f4da2ce3f0956e9884059467d196078935a3fce61dad619f3bb1bc2b4c6a757e1a8abfed0e83cba38957c7c52fff235676e9dd1d428
diff --git a/www-servers/civetweb/civetweb-1.11.ebuild b/www-servers/civetweb/civetweb-1.11.ebuild
new file mode 100644
index 000000000000..b723333e3653
--- /dev/null
+++ b/www-servers/civetweb/civetweb-1.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+HOMEPAGE="https://github.com/civetweb/civetweb/"
+DESCRIPTION="Embedded C/C++ web server"
+SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx +server ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's|DESTINATION lib$|DESTINATION ${CMAKE_INSTALL_LIBDIR}|' \
+ -i src/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DCIVETWEB_BUILD_TESTING=OFF
+ -DCIVETWEB_ENABLE_LUA=OFF
+ -DCIVETWEB_ENABLE_DUKTAPE=OFF
+ -DCIVETWEB_ENABLE_CXX="$(usex cxx)"
+ -DCIVETWEB_ENABLE_SERVER_EXECUTABLE="$(usex server)"
+ -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/www-servers/civetweb/metadata.xml b/www-servers/civetweb/metadata.xml
index da48c00830a1..a80fa5cce405 100644
--- a/www-servers/civetweb/metadata.xml
+++ b/www-servers/civetweb/metadata.xml
@@ -7,4 +7,7 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name="server">Build standalone server</flag>
+ </use>
</pkgmetadata>