summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMohamad Issawi <68k@segv.moe>2022-01-05 01:58:38 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-02-01 10:17:06 +0200
commit023462dda2e20598697775f4e731d0b16096be4c (patch)
treea6c628cee1a4721b07cbeac3dbfb83232cf4103c /www-servers/lighttpd/files
parentmedia-plugins/vdr-osdteletext: add acct-*/vdr deps to 2.3.1 (diff)
downloadgentoo-023462dda2e20598697775f4e731d0b16096be4c.tar.gz
gentoo-023462dda2e20598697775f4e731d0b16096be4c.tar.bz2
gentoo-023462dda2e20598697775f4e731d0b16096be4c.zip
www-servers/lighttpd: clean up config files
cleaned up the formatting of the default config files to match the style used by the lighttpd project. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mohamad Issawi <68k@segv.moe> Closes: https://github.com/gentoo/gentoo/pull/23655 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-servers/lighttpd/files')
-rw-r--r--www-servers/lighttpd/files/conf/lighttpd.conf366
-rw-r--r--www-servers/lighttpd/files/conf/mime-types.conf328
-rw-r--r--www-servers/lighttpd/files/conf/mod_cgi.conf28
-rw-r--r--www-servers/lighttpd/files/conf/mod_fastcgi.conf17
4 files changed, 339 insertions, 400 deletions
diff --git a/www-servers/lighttpd/files/conf/lighttpd.conf b/www-servers/lighttpd/files/conf/lighttpd.conf
index 2a13a57c1c8d..13d5e772ac1b 100644
--- a/www-servers/lighttpd/files/conf/lighttpd.conf
+++ b/www-servers/lighttpd/files/conf/lighttpd.conf
@@ -2,67 +2,67 @@
# Default lighttpd.conf for Gentoo.
###############################################################################
-# {{{ variables
-var.basedir = "/var/www/localhost"
-var.logdir = "/var/log/lighttpd"
+# Variables
+var.basedir = "/var/www/localhost"
+var.logdir = "/var/log/lighttpd"
var.statedir = "/var/lib/lighttpd"
-# }}}
-# {{{ modules
+
+# Modules
# At the very least, mod_access and mod_accesslog should be enabled.
# All other modules should only be loaded if necessary.
# NOTE: the order of modules is important.
server.modules = (
-# "mod_rewrite",
-# "mod_redirect",
-# "mod_alias",
- "mod_access",
-# "mod_cml",
-# "mod_trigger_b4_dl",
-# "mod_auth",
-# "mod_status",
-# "mod_setenv",
-# "mod_proxy",
-# "mod_simple_vhost",
-# "mod_evhost",
-# "mod_userdir",
-# "mod_compress",
-# "mod_ssi",
-# "mod_usertrack",
-# "mod_expire",
-# "mod_secdownload",
-# "mod_rrdtool",
-# "mod_webdav",
- "mod_accesslog"
+# "mod_rewrite",
+# "mod_redirect",
+# "mod_alias",
+ "mod_access",
+# "mod_cml",
+# "mod_trigger_b4_dl",
+# "mod_auth",
+# "mod_status",
+# "mod_setenv",
+# "mod_proxy",
+# "mod_simple_vhost",
+# "mod_evhost",
+# "mod_userdir",
+# "mod_compress",
+# "mod_ssi",
+# "mod_usertrack",
+# "mod_expire",
+# "mod_secdownload",
+# "mod_rrdtool",
+# "mod_webdav",
+ "mod_accesslog"
)
-# }}}
-# {{{ includes
+
+# Includes
include "mime-types.conf"
-# fcgi and cgi are included below
-# }}}
+# include "mod_cgi.conf"
+# include "mod_fastcgi.conf"
-# {{{ server settings
-server.username = "lighttpd"
-server.groupname = "lighttpd"
+# Server Settings
+server.username = "lighttpd"
+server.groupname = "lighttpd"
server.document-root = var.basedir + "/htdocs"
-server.pid-file = "/run/lighttpd.pid"
-
-server.errorlog = var.logdir + "/error.log"
+server.pid-file = "/run/lighttpd.pid"
+server.errorlog = var.logdir + "/error.log"
# log errors to syslog instead
-# server.errorlog-use-syslog = "enable"
-
-server.indexfiles = ("index.php", "index.html",
- "index.htm", "default.htm")
-
-# server.tag = "lighttpd"
-
+# server.errorlog-use-syslog = "enable"
+server.indexfiles = (
+ "index.php",
+ "index.html",
+ "index.htm",
+ "default.htm"
+)
+# server.tag = "lighttpd"
server.follow-symlink = "enable"
# event handler (defaults to "poll")
# see performance.txt
-#
+
# for >= linux-2.4
# server.event-handler = "linux-rtsig"
# for >= linux-2.6
@@ -71,13 +71,13 @@ server.follow-symlink = "enable"
# server.event-handler = "freebsd-kqueue"
# chroot to directory (defaults to no chroot)
-# server.chroot = "/"
+# server.chroot = "/"
# bind to port (defaults to 80)
-# server.port = 81
+# server.port = 81
# bind to name (defaults to all interfaces)
-# server.bind = "grisu.home.kneschke.de"
+# server.bind = "grisu.home.kneschke.de"
# error-handler for status 404
# server.error-handler-404 = "/error-handler.html"
@@ -85,157 +85,130 @@ server.follow-symlink = "enable"
# Format: <errorfile-prefix><status-code>.html
# -> ..../status-404.html for 'File not found'
-# server.errorfile-prefix = var.basedir + "/error/status-"
+# server.errorfile-prefix = var.basedir + "/error/status-"
# FAM support for caching stat() calls
# requires that lighttpd be built with USE=fam
-# server.stat-cache-engine = "fam"
+# server.stat-cache-engine = "fam"
# If lighttpd was build with IPv6 support, and you would like to listen on IPv6,
# uncomment the following:
# server.use-ipv6 = "enable"
-# }}}
-
-# {{{ mod_staticfile
+# mod_staticfile
# which extensions should not be handled via static-file transfer
# (extensions that are usually handled by mod_cgi, mod_fastcgi, etc).
static-file.exclude-extensions = (".php", ".pl", ".cgi", ".fcgi")
-# }}}
-# {{{ mod_accesslog
+
+# mod_accesslog
accesslog.filename = var.logdir + "/access.log"
-# }}}
-# {{{ mod_dirlisting
+
+# mod_dirlisting
# enable directory listings
-# dir-listing.activate = "enable"
-#
+# dir-listing.activate = "enable"
+
# don't list hidden files/directories
-# dir-listing.hide-dotfiles = "enable"
-#
+# dir-listing.hide-dotfiles = "enable"
+
# use a different css for directory listings
-# dir-listing.external-css = "/path/to/dir-listing.css"
-#
-# list of regular expressions. files that match any of the
+# dir-listing.external-css= "/path/to/dir-listing.css"
+
+# list of regular expressions. Files that match any of the
# specified regular expressions will be excluded from directory
# listings.
-# dir-listing.exclude = ("^\.", "~$")
-# }}}
+# dir-listing.exclude = ("^\.", "~$")
-# {{{ mod_access
-# see access.txt
+# mod_access
url.access-deny = ("~", ".inc")
-# }}}
-# {{{ mod_userdir
-# see userdir.txt
-#
+
+# mod_userdir
# userdir.path = "public_html"
# userdir.exclude-user = ("root")
-# }}}
-# {{{ mod_ssi
-# see ssi.txt
-#
+
+# mod_ssi
# ssi.extension = (".shtml")
-# }}}
-
-# {{{ mod_ssl
-# see ssl.txt
-#
-# ssl.engine = "enable"
-# ssl.pemfile = "server.pem"
-# }}}
-
-# {{{ mod_status
-# see status.txt
-#
+
+
+# mod_ssl
+# ssl.engine = "enable"
+# ssl.pemfile = "server.pem"
+
+
+# mod_status
# status.status-url = "/server-status"
# status.config-url = "/server-config"
-# }}}
-
-# {{{ mod_simple_vhost
-# see simple-vhost.txt
-#
-# If you want name-based virtual hosting add the next three settings and load
-# mod_simple_vhost
-#
+
+
+# mod_simple_vhost
+# If you want name-based virtual hosting add the next three settings
+# and load mod_simple_vhost
# document-root =
# virtual-server-root + virtual-server-default-host + virtual-server-docroot
# or
# virtual-server-root + http-host + virtual-server-docroot
-#
-# simple-vhost.server-root = "/home/weigon/wwwroot/servers/"
-# simple-vhost.default-host = "grisu.home.kneschke.de"
+# simple-vhost.server-root = "/home/user/webroot/servers/"
+# simple-vhost.default-host = "www.example.org"
# simple-vhost.document-root = "/pages/"
-# }}}
-
-# {{{ mod_compress
-# see compress.txt
-#
-# compress.cache-dir = var.statedir + "/cache/compress"
-# compress.filetype = ("text/plain", "text/html")
-# }}}
-
-# {{{ mod_proxy
-# see proxy.txt
-#
-# proxy.server = ( ".php" =>
-# ( "localhost" =>
-# (
-# "host" => "192.168.0.101",
-# "port" => 80
-# )
-# )
-# )
-# }}}
-
-# {{{ mod_auth
-# see authentication.txt
-#
-# auth.backend = "plain"
+
+
+# mod_compress
+# compress.cache-dir = var.statedir + "/cache/compress"
+# compress.filetype = ("text/plain", "text/html")
+
+
+# mod_proxy
+# proxy.server = (
+# ".php" => (
+# "localhost" => (
+# "host" => "192.168.0.101",
+# "port" => 80
+# )
+# )
+# )
+
+
+# mod_auth
+# auth.backend = "plain"
# auth.backend.plain.userfile = "lighttpd.user"
# auth.backend.plain.groupfile = "lighttpd.group"
# auth.backend.ldap.hostname = "localhost"
-# auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
-# auth.backend.ldap.filter = "(uid=$)"
-
-# auth.require = ( "/server-status" =>
-# (
-# "method" => "digest",
-# "realm" => "download archiv",
-# "require" => "user=jan"
-# ),
-# "/server-info" =>
-# (
-# "method" => "digest",
-# "realm" => "download archiv",
-# "require" => "valid-user"
-# )
-# )
-# }}}
-
-# {{{ mod_rewrite
-# see rewrite.txt
-#
+# auth.backend.ldap.base-dn = "dc=my-domain,dc=com"
+# auth.backend.ldap.filter = "(uid=$)"
+
+#auth.require = (
+# "/server-status" => (
+# "method" => "digest",
+# "realm" => "download archiv",
+# "require" => "user=jan"
+# ),
+# "/server-info" => (
+# "method" => "digest",
+# "realm" => "download archiv",
+# "require" => "valid-user"
+# )
+#)
+
+
+# mod_rewrite
# url.rewrite = (
-# "^/$" => "/server-status"
+# "^/$" => "/server-status"
# )
-# }}}
-# {{{ mod_redirect
-# see redirect.txt
-#
+
+# mod_redirect
# url.redirect = (
-# "^/wishlist/(.+)" => "http://www.123.org/$1"
+# "^/wishlist/(.+)" => "http://www.123.org/$1"
# )
-# }}}
-# {{{ mod_evhost
+
+# mod_evhost
# define a pattern for the host url finding
# %% => % sign
# %0 => domain name + tld
@@ -243,87 +216,64 @@ url.access-deny = ("~", ".inc")
# %2 => domain name without tld
# %3 => subdomain 1 name
# %4 => subdomain 2 name
-#
-# evhost.path-pattern = "/home/storage/dev/www/%3/htdocs/"
-# }}}
+# evhost.path-pattern = "/home/storage/dev/www/%3/htdocs/"
-# {{{ mod_expire
+
+# mod_expire
# expire.url = (
-# "/buggy/" => "access 2 hours",
-# "/asdhas/" => "access plus 1 seconds 2 minutes"
+# "/buggy/" => "access 2 hours",
+# "/asdhas/" => "access plus 1 seconds 2 minutes"
# )
-# }}}
-# {{{ mod_rrdtool
-# see rrdtool.txt
-#
-# rrdtool.binary = "/usr/bin/rrdtool"
+
+# mod_rrdtool
+# rrdtool.binary = "/usr/bin/rrdtool"
# rrdtool.db-name = var.statedir + "/lighttpd.rrd"
-# }}}
-# {{{ mod_setenv
-# see setenv.txt
-#
-# setenv.add-request-header = ( "TRAV_ENV" => "mysql://user@host/db" )
+
+# mod_setenv
+# setenv.add-request-header = ( "TRAV_ENV" => "mysql://user@host/db" )
# setenv.add-response-header = ( "X-Secret-Message" => "42" )
-# }}}
-# {{{ mod_trigger_b4_dl
-# see trigger_b4_dl.txt
-#
+
+# mod_trigger_b4_dl
# trigger-before-download.gdbm-filename = "/home/weigon/testbase/trigger.db"
# trigger-before-download.memcache-hosts = ( "127.0.0.1:11211" )
# trigger-before-download.trigger-url = "^/trigger/"
# trigger-before-download.download-url = "^/download/"
# trigger-before-download.deny-url = "http://127.0.0.1/index.html"
# trigger-before-download.trigger-timeout = 10
-# }}}
-# {{{ mod_cml
-# see cml.txt
-#
+
+# mod_cml
# don't forget to add index.cml to server.indexfiles
-# cml.extension = ".cml"
-# cml.memcache-hosts = ( "127.0.0.1:11211" )
-# }}}
+# cml.extension = ".cml"
+# cml.memcache-hosts = ( "127.0.0.1:11211" )
-# {{{ mod_webdav
-# see webdav.txt
-#
+
+# mod_webdav
# $HTTP["url"] =~ "^/dav($|/)" {
-# webdav.activate = "enable"
-# webdav.is-readonly = "enable"
+# webdav.activate = "enable"
+# webdav.is-readonly = "enable"
# }
-# }}}
-# {{{ extra rules
-#
+
+# Extra Rules
# set Content-Encoding and reset Content-Type for browsers that
# support decompressing on-thy-fly (requires mod_setenv)
# $HTTP["url"] =~ "\.gz$" {
-# setenv.add-response-header = ("Content-Encoding" => "x-gzip")
-# mimetype.assign = (".gz" => "text/plain")
+# setenv.add-response-header = ("Content-Encoding" => "x-gzip")
+# mimetype.assign = (".gz" => "text/plain")
# }
# $HTTP["url"] =~ "\.bz2$" {
-# setenv.add-response-header = ("Content-Encoding" => "x-bzip2")
-# mimetype.assign = (".bz2" => "text/plain")
+# setenv.add-response-header = ("Content-Encoding" => "x-bzip2")
+# mimetype.assign = (".bz2" => "text/plain")
# }
-#
-# }}}
-# {{{ debug
-# debug.log-request-header = "enable"
-# debug.log-response-header = "enable"
-# debug.log-request-handling = "enable"
-# debug.log-file-not-found = "enable"
-# }}}
-# {{{ cgi includes
-# uncomment for cgi support
-# include "mod_cgi.conf"
-# uncomment for php/fastcgi support
-# include "mod_fastcgi.conf"
-# }}}
-
-# vim: set ft=conf foldmethod=marker et :
+# Debug
+# debug.log-request-header = "enable"
+# debug.log-response-header = "enable"
+# debug.log-request-handling = "enable"
+# debug.log-file-not-found = "enable"
diff --git a/www-servers/lighttpd/files/conf/mime-types.conf b/www-servers/lighttpd/files/conf/mime-types.conf
index 3d7880811717..40e26c1ae9cd 100644
--- a/www-servers/lighttpd/files/conf/mime-types.conf
+++ b/www-servers/lighttpd/files/conf/mime-types.conf
@@ -3,168 +3,166 @@
# include'd from lighttpd.conf.
###############################################################################
-# {{{ mime types
-mimetype.assign = (
- ".pdf" => "application/pdf",
- ".epub" => "application/epub+zip",
- ".spl" => "application/futuresplash",
- ".jar" => "application/java-archive",
- ".class" => "application/java-vm",
- ".jsonld" => "application/ld+json",
- ".json" => "application/json",
- ".mdb" => "application/msaccess",
- ".doc" => "application/msword",
- ".ogg" => "application/ogg",
- ".pgp" => "application/pgp-encrypted",
- ".sig" => "application/pgp-signature",
- ".ps" => "application/postscript",
- ".eps" => "application/postscript",
- ".rar" => "applicaion/rar",
- ".rdf" => "application/rdf+xml",
- ".rss" => "application/rss+xml",
- ".rtf" => "application/rtf",
- ".azw" => "application/vnd.amazon.ebook",
- ".cbz" => "application/vnd.comicbook+zip",
- ".cbr" => "application/vnd.comicbook-rar",
- ".exe" => "application/vnd.microsoft.portable-executable",
- ".xls" => "application/vnd.ms-excel",
- ".ppt" => "application/vnd.ms-powerpoint",
- ".docm" => "application/vnd.ms-word.document.macroEnabled.12",
- ".odt" => "application/vnd.oasis.opendocument.text",
- ".ods" => "application/vnd.oasis.opendocument.spreadsheet",
- ".odp" => "application/vnd.oasis.opendocument.presentation",
- ".odg" => "application/vnd.oasis.opendocument.graphics",
- ".odc" => "application/vnd.oasis.opendocument.chart",
- ".odf" => "application/vnd.oasis.opendocument.formula",
- ".odi" => "application/vnd.oasis.opendocument.image",
- ".pptx" => "application/vnd.openxmlformats-officedocument.presentationml.presentation",
- ".xlsx" => "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet",
- ".docx" => "application/vnd.openxmlformats-officedocument.wordprocessingml.document",
- ".vsd" => "application/vnd.visio",
- ".wasm" => "application/wasm",
- ".xhtml" => "application/xhtml+xml",
- ".zip" => "application/zip",
- ".zstd" => "application/zstd",
- ".7z" => "application/x-7z-compressed",
- ".dmg" => "application/x-apple-diskimage",
- ".torrent" => "application/x-bittorrent",
- ".bz2" => "application/x-bzip",
- ".tbz" => "application/x-bzip-compressed-tar",
- ".tar.bz2" => "application/x-bzip-compressed-tar",
- ".pgn" => "application/x-chess-pgn",
- ".deb" => "application/x-debian-package",
- ".dvi" => "application/x-dvi",
- ".mm" => "application/x-freemind",
- ".gz" => "application/x-gzip",
- ".iso" => "application/x-iso9660-image",
- ".jnlp" => "application/x-java-jnlp-file",
- ".pac" => "application/x-ns-proxy-autoconfig",
- ".rpm" => "application/x-redhat-package-manager",
- ".swf" => "application/x-shockwave-flash",
- ".tar.gz" => "application/x-tgz",
- ".tgz" => "application/x-tgz",
- ".tar" => "application/x-tar",
- ".xz" => "application/x-xz",
- ".aac" => "audio/aac",
- ".adts" => "audio/aac",
- ".ac3" => "audio/ac3",
- ".snd" => "audio/basic",
- ".mid" => "audio/midi",
- ".midi" => "audio/midi",
- ".m4a" => "audio/mp4",
- ".mp1" => "audio/mpeg",
- ".mp2" => "audio/mpeg",
- ".mp3" => "audio/mpeg",
- ".oga" => "audio/ogg",
- ".opus" => "audio/ogg",
- ".spx" => "audio/ogg",
- ".sid" => "audio/prs.sid",
- ".mlp" => "audio/vnd.dolby.mlp",
- ".dts" => "audio/vnd.dts",
- ".dtshd" => "audio/vnd.dts.hd",
- ".flac" => "audio/x-flac",
- ".mka" => "audio/x-matroska",
- ".m3u" => "audio/x-mpegurl",
- ".mod" => "audio/x-mod",
- ".wma" => "audio/x-ms-wma",
- ".wax" => "audio/x-ms-wax",
- ".wav" => "audio/x-wav",
- ".otf" => "font/otf",
- ".ttf" => "font/ttf",
- ".woff" => "font/woff",
- ".woff2" => "font/woff2",
- ".bmp" => "image/bmp",
- ".gif" => "image/gif",
- ".heic" => "image/heic",
- ".heics" => "image/heic-sequence",
- ".heif" => "image/heif",
- ".heifs" => "image/heif-sequence",
- ".jpg" => "image/jpeg",
- ".jpeg" => "image/jpeg",
- ".png" => "image/png",
- ".tif" => "image/tiff",
- ".tiff" => "image/tiff",
- ".svg" => "image/svg+xml",
- ".svgz" => "image/svg+xml",
- ".webp" => "image/webp",
- ".psd" => "image/vnd.adobe.photoshop",
- ".apng" => "image/vnd.mozilla.apng",
- ".ico" => "image/x-icon",
- ".xbm" => "image/x-xbitmap",
- ".xpm" => "image/x-xpixmap",
- ".xwd" => "image/x-xwindowdump",
- ".ics" => "text/calendar",
- ".css" => "text/css",
- ".csv" => "text/csv",
- ".html" => "text/html",
- ".htm" => "text/html",
- ".js" => "text/javascript",
- ".asc" => "text/plain",
- ".c" => "text/plain",
- ".h" => "text/plain",
- ".cc" => "text/plain",
- ".cpp" => "text/plain",
- ".hh" => "text/plain",
- ".hpp" => "text/plain",
- ".conf" => "text/plain",
- ".log" => "text/plain",
- ".text" => "text/plain",
- ".txt" => "text/plain",
- ".diff" => "text/plain",
- ".patch" => "text/plain",
- ".ebuild" => "text/plain",
- ".eclass" => "text/plain",
- ".vcard" => "text/vcard",
- ".vcf" => "text/vcard",
- ".dtd" => "text/xml",
- ".xml" => "text/xml",
- ".vcs" => "text/x-vcalendar",
- ".x3db" => "model/x3d+binary",
- ".x3dbz" => "model/x3d+binary",
- ".x3dv" => "model/x3d+vrml",
- ".x3dvz" => "model/x3d+vrml",
- ".x3d" => "model/x3d+xml",
- ".x3dz" => "model/x3d+xml",
- ".ts" => "video/mp2t",
- ".m4v" => "video/mp4",
- ".mp4" => "video/mp4",
- ".mpeg" => "video/mpeg",
- ".mpg" => "video/mpeg",
- ".ogv" => "video/ogg",
- ".mov" => "video/quicktime",
- ".qt" => "video/quicktime",
- ".webm" => "video/webm",
- ".m4u" => "video/vnd.mpegurl",
- ".bik" => "video/vnd.radgamettools.bink",
- ".bk2" => "video/vnd.radgamettools.bink",
- ".smk" => "video/vnd.radgamettools.smacker",
- ".flv" => "video/x-flv",
- ".mkv" => "video/x-matroska",
- ".mk3d" => "video/x-matroska-3d",
- ".mng" => "video/x-mng",
- ".avi" => "video/x-msvideo",
- ".asf" => "video/x-ms-asf",
- ".asx" => "video/x-ms-asf",
- ".wmv" => "video/x-ms-wmv"
- )
-# }}}
+mimetype.assign = (
+ ".pdf" => "application/pdf",
+ ".epub" => "application/epub+zip",
+ ".spl" => "application/futuresplash",
+ ".jar" => "application/java-archive",
+ ".class" => "application/java-vm",
+ ".jsonld" => "application/ld+json",
+ ".json" => "application/json",
+ ".mdb" => "application/msaccess",
+ ".doc" => "application/msword",
+ ".ogg" => "application/ogg",
+ ".pgp" => "application/pgp-encrypted",
+ ".sig" => "application/pgp-signature",
+ ".ps" => "application/postscript",
+ ".eps" => "application/postscript",
+ ".rar" => "applicaion/rar",
+ ".rdf" => "application/rdf+xml",
+ ".rss" => "application/rss+xml",
+ ".rtf" => "application/rtf",
+ ".azw" => "application/vnd.amazon.ebook",
+ ".cbz" => "application/vnd.comicbook+zip",
+ ".cbr" => "application/vnd.comicbook-rar",
+ ".exe" => "application/vnd.microsoft.portable-executable",
+ ".xls" => "application/vnd.ms-excel",
+ ".ppt" => "application/vnd.ms-powerpoint",
+ ".docm" => "application/vnd.ms-word.document.macroEnabled.12",
+ ".odt" => "application/vnd.oasis.opendocument.text",
+ ".ods" => "application/vnd.oasis.opendocument.spreadsheet",
+ ".odp" => "application/vnd.oasis.opendocument.presentation",
+ ".odg" => "application/vnd.oasis.opendocument.graphics",
+ ".odc" => "application/vnd.oasis.opendocument.chart",
+ ".odf" => "application/vnd.oasis.opendocument.formula",
+ ".odi" => "application/vnd.oasis.opendocument.image",
+ ".pptx" => "application/vnd.openxmlformats-officedocument.presentationml.presentation",
+ ".xlsx" => "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet",
+ ".docx" => "application/vnd.openxmlformats-officedocument.wordprocessingml.document",
+ ".vsd" => "application/vnd.visio",
+ ".wasm" => "application/wasm",
+ ".xhtml" => "application/xhtml+xml",
+ ".zip" => "application/zip",
+ ".zstd" => "application/zstd",
+ ".7z" => "application/x-7z-compressed",
+ ".dmg" => "application/x-apple-diskimage",
+ ".torrent" => "application/x-bittorrent",
+ ".bz2" => "application/x-bzip",
+ ".tbz" => "application/x-bzip-compressed-tar",
+ ".tar.bz2" => "application/x-bzip-compressed-tar",
+ ".pgn" => "application/x-chess-pgn",
+ ".deb" => "application/x-debian-package",
+ ".dvi" => "application/x-dvi",
+ ".mm" => "application/x-freemind",
+ ".gz" => "application/x-gzip",
+ ".iso" => "application/x-iso9660-image",
+ ".jnlp" => "application/x-java-jnlp-file",
+ ".pac" => "application/x-ns-proxy-autoconfig",
+ ".rpm" => "application/x-redhat-package-manager",
+ ".swf" => "application/x-shockwave-flash",
+ ".tar.gz" => "application/x-tgz",
+ ".tgz" => "application/x-tgz",
+ ".tar" => "application/x-tar",
+ ".xz" => "application/x-xz",
+ ".aac" => "audio/aac",
+ ".adts" => "audio/aac",
+ ".ac3" => "audio/ac3",
+ ".snd" => "audio/basic",
+ ".mid" => "audio/midi",
+ ".midi" => "audio/midi",
+ ".m4a" => "audio/mp4",
+ ".mp1" => "audio/mpeg",
+ ".mp2" => "audio/mpeg",
+ ".mp3" => "audio/mpeg",
+ ".oga" => "audio/ogg",
+ ".opus" => "audio/ogg",
+ ".spx" => "audio/ogg",
+ ".sid" => "audio/prs.sid",
+ ".mlp" => "audio/vnd.dolby.mlp",
+ ".dts" => "audio/vnd.dts",
+ ".dtshd" => "audio/vnd.dts.hd",
+ ".flac" => "audio/x-flac",
+ ".mka" => "audio/x-matroska",
+ ".m3u" => "audio/x-mpegurl",
+ ".mod" => "audio/x-mod",
+ ".wma" => "audio/x-ms-wma",
+ ".wax" => "audio/x-ms-wax",
+ ".wav" => "audio/x-wav",
+ ".otf" => "font/otf",
+ ".ttf" => "font/ttf",
+ ".woff" => "font/woff",
+ ".woff2" => "font/woff2",
+ ".bmp" => "image/bmp",
+ ".gif" => "image/gif",
+ ".heic" => "image/heic",
+ ".heics" => "image/heic-sequence",
+ ".heif" => "image/heif",
+ ".heifs" => "image/heif-sequence",
+ ".jpg" => "image/jpeg",
+ ".jpeg" => "image/jpeg",
+ ".png" => "image/png",
+ ".tif" => "image/tiff",
+ ".tiff" => "image/tiff",
+ ".svg" => "image/svg+xml",
+ ".svgz" => "image/svg+xml",
+ ".webp" => "image/webp",
+ ".psd" => "image/vnd.adobe.photoshop",
+ ".apng" => "image/vnd.mozilla.apng",
+ ".ico" => "image/x-icon",
+ ".xbm" => "image/x-xbitmap",
+ ".xpm" => "image/x-xpixmap",
+ ".xwd" => "image/x-xwindowdump",
+ ".ics" => "text/calendar",
+ ".css" => "text/css",
+ ".csv" => "text/csv",
+ ".html" => "text/html",
+ ".htm" => "text/html",
+ ".js" => "text/javascript",
+ ".asc" => "text/plain",
+ ".c" => "text/plain",
+ ".h" => "text/plain",
+ ".cc" => "text/plain",
+ ".cpp" => "text/plain",
+ ".hh" => "text/plain",
+ ".hpp" => "text/plain",
+ ".conf" => "text/plain",
+ ".log" => "text/plain",
+ ".text" => "text/plain",
+ ".txt" => "text/plain",
+ ".diff" => "text/plain",
+ ".patch" => "text/plain",
+ ".ebuild" => "text/plain",
+ ".eclass" => "text/plain",
+ ".vcard" => "text/vcard",
+ ".vcf" => "text/vcard",
+ ".dtd" => "text/xml",
+ ".xml" => "text/xml",
+ ".vcs" => "text/x-vcalendar",
+ ".x3db" => "model/x3d+binary",
+ ".x3dbz" => "model/x3d+binary",
+ ".x3dv" => "model/x3d+vrml",
+ ".x3dvz" => "model/x3d+vrml",
+ ".x3d" => "model/x3d+xml",
+ ".x3dz" => "model/x3d+xml",
+ ".ts" => "video/mp2t",
+ ".m4v" => "video/mp4",
+ ".mp4" => "video/mp4",
+ ".mpeg" => "video/mpeg",
+ ".mpg" => "video/mpeg",
+ ".ogv" => "video/ogg",
+ ".mov" => "video/quicktime",
+ ".qt" => "video/quicktime",
+ ".webm" => "video/webm",
+ ".m4u" => "video/vnd.mpegurl",
+ ".bik" => "video/vnd.radgamettools.bink",
+ ".bk2" => "video/vnd.radgamettools.bink",
+ ".smk" => "video/vnd.radgamettools.smacker",
+ ".flv" => "video/x-flv",
+ ".mkv" => "video/x-matroska",
+ ".mk3d" => "video/x-matroska-3d",
+ ".mng" => "video/x-mng",
+ ".avi" => "video/x-msvideo",
+ ".asf" => "video/x-ms-asf",
+ ".asx" => "video/x-ms-asf",
+ ".wmv" => "video/x-ms-wmv"
+)
diff --git a/www-servers/lighttpd/files/conf/mod_cgi.conf b/www-servers/lighttpd/files/conf/mod_cgi.conf
index 982333a007c6..9897af78eafc 100644
--- a/www-servers/lighttpd/files/conf/mod_cgi.conf
+++ b/www-servers/lighttpd/files/conf/mod_cgi.conf
@@ -3,30 +3,22 @@
# include'd by lighttpd.conf.
###############################################################################
-#
-# see cgi.txt for more information on using mod_cgi
-#
-
server.modules += ("mod_cgi")
-# NOTE: this requires mod_alias
+# this requires mod_alias
alias.url = (
- "/cgi-bin/" => var.basedir + "/cgi-bin/"
+ "/cgi-bin/" => var.basedir + "/cgi-bin/"
)
-#
# Note that you'll also want to enable the
# cgi-bin alias via mod_alias (above).
-#
$HTTP["url"] =~ "^/cgi-bin/" {
- # disable directory listings
- dir-listing.activate = "disable"
- # only allow cgi's in this directory
- cgi.assign = (
- ".pl" => "/usr/bin/perl",
- ".cgi" => "/usr/bin/perl"
- )
-}
-
-# vim: set ft=conf foldmethod=marker et :
+ # disable directory listings
+ dir-listing.activate = "disable"
+ # only allow cgi's in this directory
+ cgi.assign = (
+ ".pl" => "/usr/bin/perl",
+ ".cgi" => "/usr/bin/perl"
+ )
+} \ No newline at end of file
diff --git a/www-servers/lighttpd/files/conf/mod_fastcgi.conf b/www-servers/lighttpd/files/conf/mod_fastcgi.conf
index 5d5ea51ef252..515e7c52aafd 100644
--- a/www-servers/lighttpd/files/conf/mod_fastcgi.conf
+++ b/www-servers/lighttpd/files/conf/mod_fastcgi.conf
@@ -4,13 +4,12 @@
###############################################################################
server.modules += ("mod_fastcgi")
-fastcgi.server = ( ".php" =>
- ( "localhost" =>
- (
- "socket" => "/run/lighttpd/lighttpd-fastcgi-php-" + PID + ".socket",
- "bin-path" => "/usr/bin/php-cgi"
- )
- )
- )
-# vim: set ft=conf foldmethod=marker et :
+fastcgi.server = (
+ ".php" => (
+ "localhost" => (
+ "socket" => "/run/lighttpd/lighttpd-fastcgi-php-" + PID + ".socket",
+ "bin-path" => "/usr/bin/php-cgi"
+ )
+ )
+)