summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-servers/mongoose
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-servers/mongoose')
-rw-r--r--www-servers/mongoose/Manifest1
-rw-r--r--www-servers/mongoose/metadata.xml10
-rw-r--r--www-servers/mongoose/mongoose-5.3.ebuild47
3 files changed, 58 insertions, 0 deletions
diff --git a/www-servers/mongoose/Manifest b/www-servers/mongoose/Manifest
new file mode 100644
index 000000000000..7c98b12c217a
--- /dev/null
+++ b/www-servers/mongoose/Manifest
@@ -0,0 +1 @@
+DIST mongoose-5.3.zip 124529 SHA256 9807751a888c7c32008d3ecf3c90d7ddff1469139b07a14e27e2f54874250bd7 SHA512 eb2f5de1bfb7e2314b64a695f579145644ff84c68b886fdd7f1adab40308a468438416799359788d36cc735b06cbb89b402938ed07ac3d4e40fa02c0a859fcd9 WHIRLPOOL 5cf2183d372d8a8117e7411d98242332a04e97f7d39d0186f74fa7925e1e22a9caf83a35eb08772809cc6c280d7270826edca2c13d12cddfce930bf6e2a10c3f
diff --git a/www-servers/mongoose/metadata.xml b/www-servers/mongoose/metadata.xml
new file mode 100644
index 000000000000..252b6ee7ade2
--- /dev/null
+++ b/www-servers/mongoose/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cesanta/mongoose</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-servers/mongoose/mongoose-5.3.ebuild b/www-servers/mongoose/mongoose-5.3.ebuild
new file mode 100644
index 000000000000..876ae37fe3e9
--- /dev/null
+++ b/www-servers/mongoose/mongoose-5.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="easy to use web server"
+SRC_URI="https://github.com/cesanta/${PN}/archive/${PV}.zip -> ${P}.zip"
+HOMEPAGE="https://code.google.com/p/${PN}/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~arm-linux ~x86-linux"
+IUSE="lua"
+
+RDEPEND="lua? ( >=dev-lang/lua-5.2.3:5.2= )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/examples
+
+src_prepare() {
+ if use lua ; then
+ sed \
+ -e "s|^#CFLAGS += -I\$(LUA) -L\$(LUA) -llua|CFLAGS += -I$($(tc-getPKG_CONFIG) --variable includedir lua5.2)/lua5.2 -L$($(tc-getPKG_CONFIG) --variable libdir lua5.2) -llua5.2|" \
+ -i Makefile || die
+ fi
+ sed \
+ -e 's|^CFLAGS = -W -Wall -I.. -pthread -g -pipe $(CFLAGS_EXTRA)|CFLAGS += -I.. -pthread $(LDFLAGS)|' \
+ -e "s|g++ unit_test.c -Wall -W -pedantic -lssl|$(tc-getCC) unit_test.c -Wall -W -pedantic -lssl -pthread|" \
+ -i Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake server
+}
+
+src_test() {
+ emake u
+}
+
+src_install() {
+ newbin "${S}/server" "${PN}"
+ dodoc ../docs/{FAQ,LuaSqlite,Options,SSL,Usage}.md
+}